Podcasts - randomly stop

  • 23 December 2017
  • 28 replies
  • 4725 views

Userlevel 1
Often when I’m listening to podcasts (from my IPhone) a podcast will randomly stop mid stream (in different parts of an episode). I then have to restart the podcast and find my place again. It can happen several times while listening to one podcast and can be frustrating. Anyone else have this issue?

28 replies

Userlevel 7
Badge +19
Hello there, Steph_NE. Thanks for posting and welcome to the Community. In most cases, audio dropouts occur due to problems with local wireless interference. Would you mind submitting a diagnostic report and replying with the seven-digit confirmation number it gives at the end? Thanks!
Userlevel 1
8312704

Thank you!
(It seems to be particular to certain podcasts and lately my Pandora has been randomly stopping as well)
I have exactly the same problem can anyone help just keeps cutting off the podcast after about 8 minutes or so
Userlevel 7
Badge +19
Steph_NE: Let's first talk about Pandora. We are currently tracking an outage with Pandora where after a couple hours, Pandora playback will stop. You should be able to click play to get playback to resume, but know that we are working closely with Pandora on this.

Looking through the diagnostic report, I am seeing a few errors pointing to data not getting to its destination in time. I am also seeing lost connection errors for Spotify. This leads me to believe there may be something getting in the way of Sonos connection to the internet. Your BRIDGE (device hardwired to the Router) seems to have encountered a spike physical electronic interference. Since the BRIDGE is the main source of data for Sonos, let's take a look at the immediate area. Are there any large electronic devices near the BRIDGE?

Additionally, you could swap the BRIDGE with your PLAY:1 in the Master Bedroom to see if it is a problem with the BRIDGE unit itself. All you would need to do is plug the PLAY:1 into the Router using the same Ethernet cable, plug in the PLAY:1 and remove the BRIDGE from power.

samffuk: Please submit a diagnostic report and reply with the seven-digit confirmation number it gives at the end. I'll be happy to take a preliminary look and advise on next steps.
similar issues sent diagnostic report #8387099
Happening constantly to me. Basically can not use the play from iPhone podcast option. Every podcast cuts out randomly at some point and moves to the next in queue. Replay it and it cuts out at a different point. New iPhone X, new AC5400 router, Playbar all about 2 meters from each other.

Shame as I bought the Sonos to play podcasts while in the kitchen. Was using a Bluetooth speaker before. Who would have thought Bluetooth was more reliable than WiFi.

This sucks. Why did I waste this money. Technology disappoints yet again. It doesn’t even retry, if it is a WiFi issue, just skips to next track.. using the WiFi.. which then plays seemlessly for x number of minutes... and repeat. It’s TCP isn’t it? Not UDP. Why can’t it resend packets if it thinks there is a issue with WiFi which seems to be the generic sonos “they won’t be able to determine the issue if we blame their WiFi” excuse.
Userlevel 1
I am having the same problem and have had my set of six speakers for three years. Recently it has gotten worse. I have a new high powered router (Netgear nighthawk x4s) and powerful WiFi. I feel the problem is on Sonos end as I don't have this issue with anything else, ever. How can this be fixed?

I just sent diagnostics and this is my number: 449954851
Userlevel 7
Badge +20
I am having the same problem and have had my set of six speakers for three years. Recently it has gotten worse. I have a new high powered router (Netgear nighthawk x4s) and powerful WiFi. I feel the problem is on Sonos end as I don't have this issue with anything else, ever. How can this be fixed?

I just sent diagnostics and this is my number: 449954851


Hi Mirabai50,

There's some wireless interference showing up in your diagnostic report which may explain the playback issues. Interference can cause the audio stream to stop from time to time, leading to a pause in the music, or even cause the system to start up the next track. Please try changing the wireless channel on your Sonos system and see if that helps. If not, send along a new diagnostic report and reply with the confirmation number.
Userlevel 1
I am going to try that now. Thx.
Same issue here. Podcasts skip to the next episode randomly, usually after several minutes. Have a very hard time believing this has anything to do with breaks in WiFi signal. Any more updated progress on this issue than from several months ago?
This issue is honestly making me hate sonas and we are very happy with the quality I listen to podcasts mostly and it makes it impossible. I’ve given up using our new beami just listen on my phone now because I have had to restart the same podcast 8 times and I still have not gotten past 24 mins on the podcast the diagnostics is below

1515706944
Userlevel 7
Badge +20
This issue is honestly making me hate sonas and we are very happy with the quality I listen to podcasts mostly and it makes it impossible.
From various other posts on this forum, it appears that a temporary workaround may be to disable Auto-Lock on your phone:
Settings | Display & Brightness | Auto-Lock -> Never

If that fails, I've also heard that disabling Airplay on all non-Sonos devices on your network may be required.

I trust that Sonos is working with Apple on the underlying issue.
SONOS, any new information here? Considering that Apple IOS devices are the largest contingent of users of SONOS products, I am stunned that this issue has not resolved. And any information about how to solve the current issues by using various odd workarounds are appreciated, but at the quality and price point of SONOS products PLUS the ubiquitous IOS user base, this lack of progress here is bizarre.
Userlevel 7
Badge +20
Hi folks,

We're investigating an issue causing playback troubles for media stored on iOS devices when non-Sonos AIrPlay devices are on the network and your iOS device goes into auto lock. We'll update the thread when we have more to share, but for now you can get the streaming going again by disabling AirPlay on any non-Sonos devices or by disabling auto lock in the display and brightness menu of your iOS device's settings menu.

You can also bypass this issue by syncing your iOS device with the iTunes on a computer, then setting up a music share. This will make your media available to Sonos even when your iOS device is offline, off the network, or being engaged by AirPlay.
Jeff, thank you for your response.
I just tried it, and this may be premature, but it is glitchy in and of itself. the SONOS desktop app doesn't seem to show all of the podcasts that are in my iTunes account.
BUT, more in general, i have read may threads with SONOS's responses, and its always the same, for at least 9 months on this thread and likely even longer if you hunt around for older threads. Does it realistically take almost a year to make progress on this? your responses have been materially the same each time, so it seems no progress has been made. knowing full well you cannot admit to this being ZERO priority or LOW priority, I am near officially giving up. seeing literally the same complicated workaround suggestions for this long tells me mostly what i think i need to know. that said, i love SONOS but am damn stumped how this could be such a neglected or complicated fix.
Userlevel 7
Badge +20
I just tried it, and this may be premature, but it is glitchy in and of itself. the SONOS desktop app doesn't seem to show all of the podcasts that are in my iTunes account.
The issue being discussed here applies only to podcasts (and other music files) that are being played from iOS devices. As such, only files that are actually downloaded to the device will be available to be played. Are you sure the missing podcasts are downloaded and present on the device?
yes, there are many podcasts on my iPhone that do not appear on the desktop app. there are also locally downloaded podcasts on my iMac iTunes app that are also missing. no rhyme or reason. if i follow the instructions provided by Jeff above, this is the result i get. if there are hidden steps or more subtle steps a higher level tech person needs to do in addition, i have not done them, and frankly, if there are, this is not a simple workaround,
Jeff (SONOS), I tried your suggested method of adding the music library. In addition to no observable pattern as to why some podcasts show up and some don’t (see my earlier response), playing the podcast still ends abruptly after several minutes. Aside from possible benefits of network fixes you have been suggesting repeatedly for almost a year, I officially do not believe the suggested workarounds are actually real solutions and seemingly just time buying distractions. I quit until I see officially confirmed software updates that fix this problem once and for all.
Userlevel 7
Badge +20
Jeff (SONOS), I tried your suggested method of adding the music library. In addition to no observable pattern as to why some podcasts show up and some don’t (see my earlier response), playing the podcast still ends abruptly after several minutes. Aside from possible benefits of network fixes you have been suggesting repeatedly for almost a year, I officially do not believe the suggested workarounds are actually real solutions and seemingly just time buying distractions. I quit until I see officially confirmed software updates that fix this problem once and for all.

At this point it would be best to work with our phone team so they can troubleshoot this live. Please give us a call, you can find our phone number and hours here.
Same issue here and it’s been going on for a while. So long I had forgot why I always played podcasts on my phone speaker till today when I tried to play them again on a Sonos speaker.

While playing a podcast from my iPhone on a Play3 (that’s 10’ from my wireless router) the podcast will randomly stop playing or skip to another one. Pretty frustrating. I’ve never had music skip before it’s only podcasts.
Userlevel 7
Badge +20
Same issue here and it’s been going on for a while. So long I had forgot why I always played podcasts on my phone speaker till today when I tried to play them again on a Sonos speaker.

While playing a podcast from my iPhone on a Play3 (that’s 10’ from my wireless router) the podcast will randomly stop playing or skip to another one. Pretty frustrating. I’ve never had music skip before it’s only podcasts.


Hi Tuffy,

We are currently investigating an issue where playback from the storage on iOS devices is interrupted and skips while non-Sonos AirPlay devices are active on your network, and your iOS device goes into auto lock or goes to sleep. You can get the streaming going again by disabling AirPlay on any non-Sonos devices on your network, or by disabling auto lock in your iOS device's settings menu under display and brightness.

Another way to get your podcasts playing is to sync them with the iTunes on a computer, then set up a music share. This will allow your Sonos system to play the podcasts when there are non-Sonos AirPlay devices active on your network, when your phone goes into auto lock, and even when your phone is offline or not on your network.
Unusable feature. Needs a proper integration with Podcasts.
I have this same problem on my iPhone and do not use AirPlay on my network.
This issue is ruining the experience I am now actively looking for replacements.
Hi

Got the same problem as Steph(first one above)

Report: 1111308947

Reply