Question

Playbar not receiving audio input

  • 14 January 2021
  • 8 replies
  • 75 views

I have a Benq HT2050 projector that I am trying to (re) connect to my Sonos Playbar and two Sonos:1s. My set up has worked in the past, but when I recently replaced the lamp in the projector and hooked it back up the Playbar no longer receives audio input. The projector itself has a small built-in speaker which still works (it can’t be turned off), but for the past year or two that has been the case without interfering with the Playbar for playing TV audio. 
 

I use an HDMI Switch, to which the projector is connected (via HDMI out), AppleTV is connected (via HDMI in) and the Playbar is connected (via audio optical). I tried resetting the Playbar and replacing the audio optical cord (which does show the red light) but have had no luck. When I check the “About My System” there is no audio signal being received by the Playbar. 
 

Appreciate any guidance—we miss our sound system. 


8 replies

Userlevel 5
Badge +12

After you reset your Playbar, did you redo the setup process in the Sonos app?

After you reset your Playbar, did you redo the setup process in the Sonos app?

Yeah. When the Playbar tried to connect to the TV it couldn’t find a signal. 

Userlevel 5
Badge +12

Is there a setting with your projector to output audio through optical? Is your optical cable firmly attached on both ends? Have you power cycled your projector by unplugging it for about a minute?

If there is a red light going to the PLAYBAR, and it isn’t ‘seeing’ a signal, it’s likely receiving something other than Dolby Digital. 

Is there a setting with your projector to output audio through optical? Is your optical cable firmly attached on both ends? Have youpower cycled your projector by unplugging it for about a minute?

There is not, the projector settings are extremely limited. Don’t think I have power cycled the projector actually—will try. 

If there is a red light going to the PLAYBAR, and it isn’t ‘seeing’ a signal, it’s likely receiving something other than Dolby Digital. 

Interesting. If this is true, any idea why it worked previously but hasn’t since I replaced the lamp?

Is there a setting with your projector to output audio through optical? Is your optical cable firmly attached on both ends? Have you power cycled your projector by unplugging it for about a minute?

Optical cable is definitely firmly attached. Power cycling didn’t change anything. 

Userlevel 5
Badge +12

Would you happen to have another TV with an optical audio connection that you could test your Playbar with?

Reply