Question

Playback Delay on Nearest Speaker

  • 29 October 2020
  • 6 replies
  • 108 views

I have a reproducible issue that applies to multiple Sonos speakers, looking for some help on how to resolve.

Currently I have Sonos One’s and a few Subs in several (8) rooms and a couple of Sonos Fives.

When starting to play music in the Sonos app across all speakers at once, the speaker that I am physically closest to always has a delay of about 5-10 seconds. Other speakers in my house start playing instantly.

I can reproduce this in any room with any of the speakers and from any device (iPhone, iPad and Mac).

Anyone else seeing this or have a solution?

 


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

Userlevel 5
Badge +16

Hi @DCinQC.

Thanks for reaching out and welcome to the community!

I appreciate your detailed post outlining the issue, let me help and try to figure this out.

Kindly reproduce the issue, then submit a diagnostic report through the Sonos app, and reply with the confirmation number.

I'd start by reviewing your system as well as the status of the devices, it will help in identifying what's possibly causing the issue.

 

I’m looking forward to assisting you further from here.

If you have any other questions or run into any issues,  please do not hesitate to reach out,  we are always here to help.

I have submitted the diagnostic reports from my Mac (736475749 ) and iPhone (711778949).  Two different speaker locations, same mechanism of playback.

It’s been a week and issue is still reproducible and persistence, any updates?

Userlevel 5
Badge +16

Hi @DCinQC.

Thanks for your response and my apologies for the delayed response time.

Upon checking on the diagnostic report, the system detected interference and sync errors around Sonos components running on your network. This often caused by wireless interference and I suggest following the steps in this article that will help you reduce wireless interference around your Sonos products. 

I also notice that your Sonos system is currently using a Wifi channel (48) that looks congested, you may try to change your Sonos system’s wireless channel to one of the recommended non-overlapping channels 1,6, and 11. Please try using your Sonos system on each of the three channels to find which one performs best. 

If the issue still persists, please submit a new diagnostic report and reply with the confirmation number so I can check further and see if there’s anything else causing this issue.

 

Let us know how it goes and if you have any questions feel free to reach out, we’re always here to help.

Thank you for the response but the information is not applicable and the link you provided was for connections using 2.4GHz not 5GHz. Wifi channel 48 is for 5GHz and you cannot set 5GHz connections to 1, 6 or 11.  The Sonos speakers are connecting to 5Ghz.

In light of this, I did some testing on my end and enabled beamforming and mu-mimo for direct handshake between my devices and the router/access-points as well as direct handshake between the Sonos speakers.  

After a quick test through multiple devices and locations I can report that the delay is completely gone for now.  I will report back if this changes in the future…

Thanks for the support!

Userlevel 5
Badge +16

Hi @DCinQC.

Thanks for your immediate response and we’ll be looking forward to your update.

We usually recommend connecting using 2.4ghz for the Sonos system, for the 5Ghz signal although faster than the 2.4Ghz signal has less range and less penetration through solid objects beyond a certain distance. If using a 5ghz band, please ensure the SSID name is different from the 2.4ghz SSID and set its channel width to no more than 40MHz.

 

Looking forward to hearing from you soon, we’re always here to help.