Play3 only available on Macbook-App, not on iPhone App in same WiFi-Network

  • 17 March 2018
  • 2 replies
  • 226 views

I have 3 Sonos Play3 in 2 Rooms. I can controll two of them via iPhone and Macbook but one of them only via Macbook. The devices are all in the same WiFi-Network and are all working well.
Any idea?
Thank You

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

2 replies

It sounds like you may have possibly setup two separate Sonos households, possibly one is using WiFi and the other on SonosNet. However there is not really enough detail in your post to establish if this is truly the case.

Can you describe your setup in a little more detail please. Are any devices wired to your LAN?
Are you using any WiFi extenders or powerline adapters within your network?
In the 'About box' in each controller what devices do you see. Are the devices showing as WM: 0 or are they WM: 1

Have you already tried turning things off/on in the order shown below...

1/ Router
2/ Any wired network device.
3/ Any wired Sonos device (such as the Sonos Boost)
4/ Any other non-wired Sonos device
5/ Any other brand of WiFi device

Just a little bit more info is needed to help provide you with the next steps to try.
Hi, Kenn. Thank you for your reply. I think you´re right and so here´s some more Input:
- On Wifi Site there are one router and two accesspoints (one on the 3rd floor, one on the ground floor) and a few switches
- The Wifi setup is a single SID in a single LAN, all devices can talk to each other, the accespoints are LAN-connected and they do roaming very properly
- On Sonos Site there are 3 sonos play3 (one single on the 3rd floor and two stereo-connected on the ground floor) and one Sonos Bridge (the bridge is placed on the ground floor and connected via LAN, the Play3-Boxes via Wifi)

The Problem:
If I´m on the ground floor and open sonos on my iPhone I see both rooms and can control the boxes in them
If I´m on the 3rd floor and open sonos on my iPhone I see only the boxes from the ground floor (and can control them) but not the box from the 3rd floor.
If I open sonos on my MacBook on ground or 3rd floor I see both rooms and can control the boxes in them
In the 'About box' in each controller I see the devices I can control and they are connected as WM: 0.

So on the MacBook all is fine, on the iPhone I have to go downstairs to control the box upstairs. (not so comfortable)

And oh yes - I switched everything off and on several times in serveral ways, I reconnected the sonos boxes a few times to the system and so on...

I´m looking forward to hear your solutions or explainings
Thank you for Support
kind regards
Andreas