Answered

Play:5 stereo pairing disconnects, Play:5 disconnects, Soundbar out of sync, Play:3s cut out

  • 3 February 2017
  • 3 replies
  • 362 views

I have two Play:5s, two Play:3s, two Play:1s, a connect:amp for floor-standing speakers, a Soundbar, and boost directly connected to the router.

I have two Play:5s (1st Gen) set up as an audio pair connected to PC through a line in. This pairing only works for a few minutes, then disconnects. Sometimes one of the Play:5s disappears completely. They also randomly separate during regular music playback without the line-in. They have become completely useless as computer speakers and for background music.

For my home cinema setup, I have a projector connected to a Ligawo HDMI switch (to connect my Roku, PS4, and Laptop) that outputs the audio to the Soundbar. I also have two Play:3s as satellites and a connect amp for my floor standing speakers in the back. When I pair the Soundbar to the Play:3s, the sound is either barely audible or it cuts out completely at times. I prefer the sound of the big speakers from the connect:amp and when I pair it with the Play:3s, they also intermittently cut out. When I connect all the audio components, the Soundbar is out of sync and the Play:3s still cut out at times.

The only thing that seems to be working properly are two Play:1s in my bedroom/bathroom, even though they are much further away form the boost. I have tried switching channels.

Any ideas? Is there a Sonos customer service that could come and inspect my setup at home? I am growing rather frustrated after a substantial investment.
icon

Best answer by SHARKB8T 4 February 2017, 05:35

Well... There are a number of options that may be causing the issues you are experiencing... I'll dump a lot of detail here and hopefully it gives you a bit of a troubleshooting guide... 🙂 You may know a bunch of this, but just in case it can be helpful....

I'd start eliminating the most common problems that occur and see what happens. You can absolutely get better data on what is occurring by submitting a diagnostic from within the Sonos App, record the number, and post it here and the Sonos Staff on the board can look at data from your system and may be better able to isolate the specifics of your problem...

But there are things you can do in the meantime that may make that unnecessary:

Potential issues generating the problems:

1) IP address conflicts. This is when more than one device on your network has the same IP address and that obviously makes communication with the devices a challenge (Think of a computer that hibernates, while "off the network" another device requests an IP from the router... If the router assigned the IP of the hibernating computer because it thinks it is available... and then you "wake" the computer... network challenges. These are most simply resolved by forcing the reassignment of IP addresses by powering down **all** networking devices (computers, phones, hubs, tablets, NAS, Sonos devices, etc....), the router and your modem (if different). The power them up starting with the modem, then the router, then each device one at a time and this forces new IP assignments to each device and *tadaa* communication flows freely. This requirement can be avoided by logging into most routers and assigning IP addresses to devices that are typically on your network.

2) Network noise, interference, congestion... If I were guessing (... and, of course, I am) this sounds more likely to be your particular problem.

Given you have a Boost connected, this means you should have your computers operating on "SonosNet", this is a mesh wifi network that the Sonos devices create between themselves to take load off the router and direct all internet through the wired boost.

I would first make sure that your boost is the *full length* of the ethernet cable *away* from your router and that you have no 2.4Ghz wireless device near any of the Sonos Devices (home wireless Phones, Baby Monitors, etc.).

Ensure that the 2.4Ghz "channel" you set the SonosNet on is one that has as little network noise as possible... (you can easily find small utility programs that will show you networks near your computer, the "channel" they are on and their strength.

You want to go into your router's control panel and ensure that you set the router channel as well and that it is at least 5 channels away from whatever you set SonosNet to (Don't let it "auto" select the channel.)


Go into the Sonos controller software and look at "About My Sonos System" and you should see a listing of your devices... in that listing, for each device, you will see a line that says "WM: 0" or "WM:1" You *Should* have all of them saying "0"... which means each device is communicating on the SonosNet mesh network... If any are connecting over wifi instead of SonosNet (the "1"), that suggests there is a weak signal for some reason on some devices... post back with what you find if it isn't all on SonosNet.

On the volume of surrounds... they typically are very quiet... let's get everything working awesomely first, and then we can discuss if you really are getting 5.1 audio (if so there is usually very little audio in surrounds - ambiance, action effects, etc... but almost never audio for dialogue, etc.... ) If Sonos is creating the effect for you from a stereo source, again, that contains segmented audio that, by design, isn't that "loud". If you are tying in the Amp by "grouping" the audio, but NOT bonding it as surrounds, (you are simply grouping them in the app....) that may not work so well... there may be too much delay in any audio going to non-"bonded" speakers for comfortable viewing /listening of TV .... which brings me to:

You mention sync issues, but I'm unclear when specifically they are occurring.... but just in case... here are a few details In order for you to created your "Bonded" sound for use with the Playbar. When the Play 3s are used as Surrounds.., that is you "bond" them into a single "room" as opposed to just grouping them together, the Playbar communicates with the surrounds on a 5Ghz network for increased speed to keep them in sync. The Connect:Amp doesn't have a 5Ghz radio... so it can't be surrounds unless there is a physical wired connection between them - That is... either ethernet cable goes from the playBar to the Connect Amp, or from each device back to the router. Then you can "bond" the connects in instead of the 3s.

Audio played from a source like a music library, or music service, should be perfectly in sync for all Sonos devices.

Hope this helps 🙂
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

Anyone?
Userlevel 5
Badge +10
Well... There are a number of options that may be causing the issues you are experiencing... I'll dump a lot of detail here and hopefully it gives you a bit of a troubleshooting guide... 🙂 You may know a bunch of this, but just in case it can be helpful....

I'd start eliminating the most common problems that occur and see what happens. You can absolutely get better data on what is occurring by submitting a diagnostic from within the Sonos App, record the number, and post it here and the Sonos Staff on the board can look at data from your system and may be better able to isolate the specifics of your problem...

But there are things you can do in the meantime that may make that unnecessary:

Potential issues generating the problems:

1) IP address conflicts. This is when more than one device on your network has the same IP address and that obviously makes communication with the devices a challenge (Think of a computer that hibernates, while "off the network" another device requests an IP from the router... If the router assigned the IP of the hibernating computer because it thinks it is available... and then you "wake" the computer... network challenges. These are most simply resolved by forcing the reassignment of IP addresses by powering down **all** networking devices (computers, phones, hubs, tablets, NAS, Sonos devices, etc....), the router and your modem (if different). The power them up starting with the modem, then the router, then each device one at a time and this forces new IP assignments to each device and *tadaa* communication flows freely. This requirement can be avoided by logging into most routers and assigning IP addresses to devices that are typically on your network.

2) Network noise, interference, congestion... If I were guessing (... and, of course, I am) this sounds more likely to be your particular problem.

Given you have a Boost connected, this means you should have your computers operating on "SonosNet", this is a mesh wifi network that the Sonos devices create between themselves to take load off the router and direct all internet through the wired boost.

I would first make sure that your boost is the *full length* of the ethernet cable *away* from your router and that you have no 2.4Ghz wireless device near any of the Sonos Devices (home wireless Phones, Baby Monitors, etc.).

Ensure that the 2.4Ghz "channel" you set the SonosNet on is one that has as little network noise as possible... (you can easily find small utility programs that will show you networks near your computer, the "channel" they are on and their strength.

You want to go into your router's control panel and ensure that you set the router channel as well and that it is at least 5 channels away from whatever you set SonosNet to (Don't let it "auto" select the channel.)


Go into the Sonos controller software and look at "About My Sonos System" and you should see a listing of your devices... in that listing, for each device, you will see a line that says "WM: 0" or "WM:1" You *Should* have all of them saying "0"... which means each device is communicating on the SonosNet mesh network... If any are connecting over wifi instead of SonosNet (the "1"), that suggests there is a weak signal for some reason on some devices... post back with what you find if it isn't all on SonosNet.

On the volume of surrounds... they typically are very quiet... let's get everything working awesomely first, and then we can discuss if you really are getting 5.1 audio (if so there is usually very little audio in surrounds - ambiance, action effects, etc... but almost never audio for dialogue, etc.... ) If Sonos is creating the effect for you from a stereo source, again, that contains segmented audio that, by design, isn't that "loud". If you are tying in the Amp by "grouping" the audio, but NOT bonding it as surrounds, (you are simply grouping them in the app....) that may not work so well... there may be too much delay in any audio going to non-"bonded" speakers for comfortable viewing /listening of TV .... which brings me to:

You mention sync issues, but I'm unclear when specifically they are occurring.... but just in case... here are a few details In order for you to created your "Bonded" sound for use with the Playbar. When the Play 3s are used as Surrounds.., that is you "bond" them into a single "room" as opposed to just grouping them together, the Playbar communicates with the surrounds on a 5Ghz network for increased speed to keep them in sync. The Connect:Amp doesn't have a 5Ghz radio... so it can't be surrounds unless there is a physical wired connection between them - That is... either ethernet cable goes from the playBar to the Connect Amp, or from each device back to the router. Then you can "bond" the connects in instead of the 3s.

Audio played from a source like a music library, or music service, should be perfectly in sync for all Sonos devices.

Hope this helps 🙂
Thank you! That was an awesome reply! have so far resolved all my issues by moving the boost away from the rest of my electronics and rebooting the entire system. I am now using the Soundbar with the (still somewhat quiet) 3s as surrounds and synced them for TV sound with the floor standing speakers by adding some delay - not perfectly synced to the projector image but much better in terms of sound quality.

The only issue that remains is that the the left Play:5 cuts out for a few seconds intermittently when I'm feeding the right Play:5 audio straight from the PC...The stereo pair works fine when I use it without the line. Would it help to get a long Ethernet cable and physically connecting them?

Thank you for your help!