Answered

Play:5 gen 1 speaker keeps disconnecting

  • 13 April 2021
  • 1 reply
  • 46 views

  • Contributor I
  • 0 replies

I have multiple speaker spread around the house. The one in the kitchen keeps disconnecting. Power cycling fixes the issue temporarily but then it disconnects from the Sonos app after a while again. This speaker has worked flawlessly for several years and stood in the same position. Issues started when I swapped to a mesh router, so I suspect network issues.

 

diagnostic: 1609197692

icon

Best answer by Corry P 13 April 2021, 17:20

Hi @Ooze 

Welcome to the Sonos Community!

Thanks for the diagnostics. I see quite a few problems, but I’m not sure how many will be fixed by fixing just one in particular. We’ll get to that one in a bit.

First, is there a reason your Sub is wired to ethernet? We don’t recommend this for normal use unless the unit it bonds with is in a different location. As you’re using it with a Play:5, this wouldn’t make sense so please re-activate WiFi on the Sub (Settings » System » Lounge » Sub » Enable Wi-Fi). Then remove the ethernet cable from the Sub. The Sub will then link to the Lounge Play:5 over a dedicated 5GHz link (not to your WiFi).

On the subject of the Lounge, the Play:5 there is reporting a faulty ethernet cable. Now, we can’t tell the difference between an actual faulty ethernet cable and you just unplugging it, so: if you haven’t been adjusting that cable, I recommend you replace it. If you have adjusted it, ignore this. 

 

Ok, now for the important bit. As other people may try to find help here, I’m going to keep things non-specific at first.

When changing SonosNet channel, an instruction is sent to all the players to change to that channel simultaneously and immediately. Therefore, any rooms that are not online in the app or any that are having intermittent problems, will not or may not, respectively, get the message to switch and therefore will not find SonosNet on the channel they expect and will either fail to connect, or will fall back to connecting to your WiFi (if Sonos knows the credentials) instead.

It is therefore important to make sure all your Sonos devices are powered on and visible in the app before changing SonosNet channel.

If Sonos does not know your WiFi password (you can check in Settings » System » Network » Networks), then after changing SonosNet channel you should check for missing rooms. The app may take some time to realise a room is offline, so allow a minute or two. If there are rooms missing, revert back to the previous channel used, observe the missing rooms return and try again. You may need to reboot the rooms that were missing.

If Sonos does know your WiFi credentials, then any players that don’t receive the message to switch will connect to your WiFi instead. This isn’t the worst thing to happen (usually), but it may explain issues appearing when there were none before. In this case, after changing SonosNet channel, go to Settings » System » About My System and check that all of your wireless players are reporting WM:0. If they say WM:1, then they are connecting to WiFi. Again, switching back to the previously used SonosNet channel should bring these back into the fold.

Note that the Move and the Roam will connect to WiFi and never to SonosNet, so will always report WM:1.

Subs and Surrounds will report WM:2 as they’re bonded to their Home Theatre boss.

 

In your case, @Ooze, every wireless player you have is looking for SonosNet on channel 11, but your wired Beam and Play:5 are transmitting it on channel 1. To compound the problem, your WiFi network is trying to get Sonos to connect to 5GHz, which the majority won’t do. Please select Settings » System » Network » Change SonosNet Channel » 11. Wait about 1 minute then check About My System for any rooms reporting WM:1 and reboot them by removing their power for 10 seconds. As your WiFi is on 6, and 11 is busy, I recommend you then change back to channel 1, once all your wireless players are visible and report WM:0. Once done, check About My System again to confirm WM:0 once more.

Be sure to test all rooms and likely groups (as in, don’t plan an end-of-lockdown party without checking Party mode/Play Everywhere first). When grouping, Lounge or TV Room are the best rooms to select first.

View original

1 reply

Userlevel 6
Badge +17

Hi @Ooze 

Welcome to the Sonos Community!

Thanks for the diagnostics. I see quite a few problems, but I’m not sure how many will be fixed by fixing just one in particular. We’ll get to that one in a bit.

First, is there a reason your Sub is wired to ethernet? We don’t recommend this for normal use unless the unit it bonds with is in a different location. As you’re using it with a Play:5, this wouldn’t make sense so please re-activate WiFi on the Sub (Settings » System » Lounge » Sub » Enable Wi-Fi). Then remove the ethernet cable from the Sub. The Sub will then link to the Lounge Play:5 over a dedicated 5GHz link (not to your WiFi).

On the subject of the Lounge, the Play:5 there is reporting a faulty ethernet cable. Now, we can’t tell the difference between an actual faulty ethernet cable and you just unplugging it, so: if you haven’t been adjusting that cable, I recommend you replace it. If you have adjusted it, ignore this. 

 

Ok, now for the important bit. As other people may try to find help here, I’m going to keep things non-specific at first.

When changing SonosNet channel, an instruction is sent to all the players to change to that channel simultaneously and immediately. Therefore, any rooms that are not online in the app or any that are having intermittent problems, will not or may not, respectively, get the message to switch and therefore will not find SonosNet on the channel they expect and will either fail to connect, or will fall back to connecting to your WiFi (if Sonos knows the credentials) instead.

It is therefore important to make sure all your Sonos devices are powered on and visible in the app before changing SonosNet channel.

If Sonos does not know your WiFi password (you can check in Settings » System » Network » Networks), then after changing SonosNet channel you should check for missing rooms. The app may take some time to realise a room is offline, so allow a minute or two. If there are rooms missing, revert back to the previous channel used, observe the missing rooms return and try again. You may need to reboot the rooms that were missing.

If Sonos does know your WiFi credentials, then any players that don’t receive the message to switch will connect to your WiFi instead. This isn’t the worst thing to happen (usually), but it may explain issues appearing when there were none before. In this case, after changing SonosNet channel, go to Settings » System » About My System and check that all of your wireless players are reporting WM:0. If they say WM:1, then they are connecting to WiFi. Again, switching back to the previously used SonosNet channel should bring these back into the fold.

Note that the Move and the Roam will connect to WiFi and never to SonosNet, so will always report WM:1.

Subs and Surrounds will report WM:2 as they’re bonded to their Home Theatre boss.

 

In your case, @Ooze, every wireless player you have is looking for SonosNet on channel 11, but your wired Beam and Play:5 are transmitting it on channel 1. To compound the problem, your WiFi network is trying to get Sonos to connect to 5GHz, which the majority won’t do. Please select Settings » System » Network » Change SonosNet Channel » 11. Wait about 1 minute then check About My System for any rooms reporting WM:1 and reboot them by removing their power for 10 seconds. As your WiFi is on 6, and 11 is busy, I recommend you then change back to channel 1, once all your wireless players are visible and report WM:0. Once done, check About My System again to confirm WM:0 once more.

Be sure to test all rooms and likely groups (as in, don’t plan an end-of-lockdown party without checking Party mode/Play Everywhere first). When grouping, Lounge or TV Room are the best rooms to select first.

Reply