pLAY:3

  • 12 March 2021
  • 5 replies
  • 53 views

I’m very upset with SONOS. Can’t understand why they mistreat their customers that bought a PLAY:3… it no longer works, not even connected to a modem


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies

Badge

I know this doesn't really answer your question but this happened to me last year. So I put it in a Time Capsule in my kitchen. For someone to find when I've gone up to the Cloud ☁️

I have two play:3s and they work just fine.

Userlevel 7
Badge +17

@Bbert Take a look here: Play:3 - Wikipedia: “Sonos ended production of the Play:3 on July 31, 2018 while maintaining updates and service for the discontinued speaker.” The Play:3 is even S2 capable.

Must be just yours that's broken, not nice but these things happens. it is between 10 and 3 years old.

Or maybe there is a network issue.  You could call Sonos Support.  As the other replies have noted, The Play:3 is still a fully-supported speaker.

It cannot be connected to a modem.  I does need to be connected to a router, either by cable or wirelessly.

Userlevel 7
Badge +18

I’m very upset with SONOS. Can’t understand why they mistreat their customers that bought a PLAY:3… it no longer works, not even connected to a modem

I feel the same about Dell Computers, Intel and Microsoft; the Intel 386-based MS-DOS computer I bought from them no longer works and they say they’re not supporting it any more.