Question

Play 1 keeps cutting out

  • 9 February 2017
  • 4 replies
  • 3549 views

I have two PLAY1's and both keep cutting out and skipping songs. This is happening through both radio and spotify. I've tried rebooting them but this hasn't helped.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

4 replies

If you are going to power cycle your router.... you really need to power off *all* wired and wireless devices that connect to your network.

The reason you would want to do this is to force your router to hand out new IP addresses all devices... it will not be done by just power cycling the router...

The reason this is sometime a solution to problems like you are experiencing is because it can occur that devices can end up thinking they are to be communicating over the network with the same assigned IP address.... (longer description is like this: an example of how IP address can occur.... consider a hypothetical example where you come home and turn on a laptop computer. It asks your router for an address... then you walk away and it hibernates.... then you use a phone and install an upgrade to Sonos and the devices power cycle and request new addresses from your router... in our example, let's say the router thinks the address the laptop was using is now free and hands it to a Play1... when you open the laptop up and it restarts from hibernation, it may not request new addressing data from the router and now the Play1 and laptop are sending and receiving data trying to use the same identifying address... that ends upon working very very poorly.

So yes, work at troubleshooting this by forcing new IP address assignment, but to do it, shut off everything that connects to your router... everything.. computers, phones, tablets, hubs, printers, Sonos devices, etc.. shut off your router and modem (if different). Start the modem, router, and then each device one at a time.

You can also see if wireless networking is an issue.... you can go into your router and it likely is set to 'auto' select a channel for what 2.4Ghz channel to use. You can force this to be 1,6 or 11. And see if it improves things. (There is a lot of overlap between neighbouring channels, so I'd suggest you avoid using other channels at this time).

You can also submit a diagnostic using the Sonos Controller when it is occurring and post the number it gives you back here on the forum. The Sonos staff here can look at it and may be able to see if there is a lot of interference occurring.


You want to make sure you do not have wireless devices near the Play 1s (2.4Ghz home phones for example... baby monitors, etc) and if you choose to wire one of them to he router with Ethernet cable (if that is practical) you will allow the 2 de ices to set up their own wireless between them and you can then. Ore that wirelsss to a different channel than the one your wireless router is using. If you only have the two devices, you may not have a need to do that if you can find a relatively clear wireless channel for hem to use...( there are apps you can get to see neighbouring networks and the channels they are on if you need to. A quick search in most app stores will find them)


Best of luck and post back here with questions,or issues as you go through the troubleshooting steps.


All seems to be working now. Unplugged everything including router and turned everything back on one by one and all has been fine since. Thank you
Roannahs-

Connect 1 into your router with a network/ethernet cable. I'd say make sure your controller (phone?) is on your home's wifi network. Your phone dropping network won't cause the cutout/skipping though. Have you had the 1's awhile? Is this ongoing, or a new issue? Rebooting your router can help. Unplug 15 seconds, plug back in and wat 1-3 min your Sonos should be good to go.......


Had them both about a year I'd say, its only just recently started doing it and on both of them. Tried rebooting several times and it doesn't seem to help unfortunately. Shall try keep one connected to router and see if that helps. thank you
Userlevel 5
Badge +10
If you are going to power cycle your router.... you really need to power off *all* wired and wireless devices that connect to your network.

The reason you would want to do this is to force your router to hand out new IP addresses all devices... it will not be done by just power cycling the router...

The reason this is sometime a solution to problems like you are experiencing is because it can occur that devices can end up thinking they are to be communicating over the network with the same assigned IP address.... (longer description is like this: an example of how IP address can occur.... consider a hypothetical example where you come home and turn on a laptop computer. It asks your router for an address... then you walk away and it hibernates.... then you use a phone and install an upgrade to Sonos and the devices power cycle and request new addresses from your router... in our example, let's say the router thinks the address the laptop was using is now free and hands it to a Play1... when you open the laptop up and it restarts from hibernation, it may not request new addressing data from the router and now the Play1 and laptop are sending and receiving data trying to use the same identifying address... that ends upon working very very poorly.

So yes, work at troubleshooting this by forcing new IP address assignment, but to do it, shut off everything that connects to your router... everything.. computers, phones, tablets, hubs, printers, Sonos devices, etc.. shut off your router and modem (if different). Start the modem, router, and then each device one at a time.

You can also see if wireless networking is an issue.... you can go into your router and it likely is set to 'auto' select a channel for what 2.4Ghz channel to use. You can force this to be 1,6 or 11. And see if it improves things. (There is a lot of overlap between neighbouring channels, so I'd suggest you avoid using other channels at this time).

You can also submit a diagnostic using the Sonos Controller when it is occurring and post the number it gives you back here on the forum. The Sonos staff here can look at it and may be able to see if there is a lot of interference occurring.


You want to make sure you do not have wireless devices near the Play 1s (2.4Ghz home phones for example... baby monitors, etc) and if you choose to wire one of them to he router with Ethernet cable (if that is practical) you will allow the 2 de ices to set up their own wireless between them and you can then. Ore that wirelsss to a different channel than the one your wireless router is using. If you only have the two devices, you may not have a need to do that if you can find a relatively clear wireless channel for hem to use...( there are apps you can get to see neighbouring networks and the channels they are on if you need to. A quick search in most app stores will find them)


Best of luck and post back here with questions,or issues as you go through the troubleshooting steps.
Userlevel 1
Badge +2
Roannahs-

Connect 1 into your router with a network/ethernet cable. I'd say make sure your controller (phone?) is on your home's wifi network. Your phone dropping network won't cause the cutout/skipping though. Have you had the 1's awhile? Is this ongoing, or a new issue? Rebooting your router can help. Unplug 15 seconds, plug back in and wat 1-3 min your Sonos should be good to go.......