Answered

Play:1 and Symfonisk not working at the same time

  • 8 August 2019
  • 28 replies
  • 1032 views

Hi,

I used to have only a Play:1 and just got an additional Ikea Symfonisk player.

When one player is connected via Wifi and one via Ethernet, both work fine.

When both are connected via Wifi, the Sonos controller only finds one. However, my router shows both and I can ping both. So the Wifi connection itself looks fine. Interestingly, both have the hostname SonosZP.

When I unplug any one of the two players from its power supply, the remaining one works fine with the Sonos controller.

Can you help me?

Kind regards

Marcus
icon

Best answer by Smilja 9 August 2019, 22:23

@Smilja Yes it's a Fritz!Box. o_O

I suppose that you speak German, then I'm not required to translate the following into English.


Wie sieht es mit den Optionen Alle neuen WLAN-Geräte zulassen und WLAN-Geräte dürfen untereinander kommunizieren aus, sind diese angehakt?

Kindersicherung (Internetfilter) für Sonos auf Unbeschränkt setzen. Vergewissere Dich, dass die IP-Adresse des Symfonisk oder des Play:1 nicht doppelt vergeben ist (Heimnetzübersicht/Ungenutzte Verbindungen); wenn doch, bitte beide IPs löschen und im Anschluss Fritzbox sowie die betreffenden Geräte neu starten.

Außerdem der Fritzbox einen festen Funkkanal zuweisen, entweder 1,6 oder 11. Bitte durchtesten, Autokanalwahl ist nicht empfohlen.
View original

28 replies

Userlevel 5
Badge +13
You may want to reach out to Sonos with a diagnostic while you have one player wired.

I'd say try doing a wireless setup while one is wired into your router, and they are both showing in the application.

Just go to more - settings - advanced settings - wireless setup .Hopefully your the one speaker is just missing the wireless network credentials.
Is there a possibility that you set them both up as a "new" system, rather than using the "add a speaker" to your current system? I'm wondering if you've got two "households" going on.
Userlevel 5
Badge +13
Is there a possibility that you set them both up as a "new" system, rather than using the "add a speaker" to your current system? I'm wondering if you've got two "households" going on.

Good point, but then we need clarification as to what mschmidt means by this.

When one player is connected via Wifi and one via Ethernet, both work fine.
That would put them both on the same household 🙂
Userlevel 5
Badge +13
That would put them both on the same household :)

right but if they both "work" while one is wired, that makes me think they're on the same household, but one just doesn't have the wireless credentials to connect to WiFi.
Hi Misfit and Airgetlam,

thanks a lot for your replies!

I will try to answer your questions:

  1. Both speakers seem to have the wireless network credentials. If each of them is powered on (and the other one's power cord is unplugged) they get lilsted in the Sonos Controller app and I can play music on them. Only if both of them are simultaneously connected to my wifi network, the Controller only sees one of them (probably the one that booted faster). This made me thinking that there is some kind of conflict.
  2. I'm sure I used "add speaker" instead of setting up a new system. By the way, I' not familiar with the terminology "household" since this seems no to appear anywhere in the software. However, when one speaker is connected via wifi, and the other one via ethernet, I see both speakers in the "Rooms" list of the same Sonos Controller app. I would therefore guess that they're on the same household.
I have submitted a system diagnostics with confirmation number 1506774021.
By the way, I would love to know what is inside this report!

I have read something about a "SonosNet" and speakers creating a separate Wifi network. Unfortunately, I couldn't find a techinical documentation on this. Can I look up these details somewhere? Could it for example be possible that the ethernet-connected speaker somehow opens a separate Sonos-Wifi and that's why everything works in this case?

Kind regards
Marcus
Marcus,

When setting up the speakers, did you give them the same room name. If so, goto their Room Settings of one of the speakers and rename it to something different, or just add a number, or letter, to the end of the name and see if that solves the issue.
Wire one of the speakers. Power them both up. Wait a couple of minutes. What does it show in About My Sonos System?
Hi,

thanks again for your responses.

@Ken_Griffiths They're both named differently. One is called "Wohnzimmer" (living room), and one is called "Küche" (kitchen).

@ratty The About dialog looks as follows:

Associated ZP: 192.168.178.35
---------------------------------
IKEA SYMFONISK Bookshelf: Küche
Serial Number: 34-7E-5C-35-C6-96:0
Version: 10.3 (build 51166240)
Hardware Version: 1.20.3.3-2
Series ID: A100
IP Address: 192.168.178.35
WM: 0
---------------------------------
Play:1: Wohnzimmer
Serial Number: 34-7E-5C-C3-2F-06:0
Version: 10.3 (build 51166240)
Hardware Version: 1.20.1.6-2
Series ID: A200
IP Address: 192.168.178.33
WM: 0

The first ZP is the one that is cabled. It will receive the same IP address when connecting to my router via Wifi.

I have also turned off 5Ghz Wifi, such that all communication goes over 2.4Ghz

Kind regards
Marcus
Marcus,

Thanks for the reply.

Maybe try this...

With both speakers still showing in the App, as above. Goto “Settings/Advanced Settings/Wireless Setup” in the Sonos App and reset and enter your Routers Wifi details, SSID and password (note they are case sensitive).

Give it a few moments and then un-cable the wired speaker and see if that fixes the problem for you.
Hi,

I tried out your suggestion with the following result after disconnecting the speaker from ethernet:

  • My Sonos Controller app on my phone (Android) cannot connect to Sonos anymore. It says "No connection to Sonos. Let's try out a few things ..."
  • On my desktop PC (Sonos Controller for PC, Windows), I can still see the formerly ethernet-connected speaker and can play music on it.
  • The other speaker doesn't appear in the rooms list anymore.
  • Both devices are still on my home wifi network and still have the same IP addresses and I can ping them from my PC.
  • The about dialog of my Sonos Controller for PC now says:
Associated ZP: 192.168.178.35
---------------------------------
IKEA SYMFONISK Bookshelf: Küche
Serial Number: 34-7E-5C-35-C6-96:0
Version: 10.3 (build 51166240)
Hardware Version: 1.20.3.3-2
Series ID: A100
IP Address: 192.168.178.35
WM: 1

I have submitted diagnostic information for this situation under confirmation number 2100110687.



Afterwards, I did the following:
I removed the power cord from that speaker with IP address 192.168.178.35.
On my Windows PC, I restarted the SonosLibraryService and the Sonos Controller for PC.
Now the latter lists only the other speaker (which I didn't touch in the meantime).
Accordingly, the about dialog now says:
Associated ZP: 192.168.178.33
---------------------------------
Play:1: Wohnzimmer
Serial Number: 34-7E-5C-C3-2F-06:0
Version: 10.3 (build 51166240)
Hardware Version: 1.20.1.6-2
Series ID: A200
IP Address: 192.168.178.33
WM: 1

Somehow, the two speakers seem to block each other when using only wifi.

I still cannot connect to Sonos at all with my cell phone. It still says "No connection to Sonos. Let's try out a few things ...". I followed these recommendations several times but didn't have any success.

I have submitted diagnostic information for this situation under confirmation number 1368162045.


I am really curious: Can I read somewhere about the exact network topology that the Sonos software requires, and the order in which the communication is set up? I would like to understand what happens under the hood, instead of doing trial-and-error approaches and hoping that some function will magically resolve the problem as some kind of side effect ;-)

Kind regards
Marcus
Try renaming the SYMFONISK from "Küche" to "Kuche"
I had trouble with mine that had the Norwegian "ø" in its name. It was very slow to connect and lost connection every few minutes. So far it has behaved after the renaming.
Userlevel 4
Badge +9
A few things come to mind;

depending on you router you could have an option called Airtime Fairness, you want this turned off since it limits the amount of devices that can be connected wireless simultaneously or prioritizes one device over an other.

Or you might have multiple AP's where one speaker is connected to one and the other to an other and the communication between the two AP's is flawed.
Naahhh...back to being unstable again now...
@harjoferie That's an interesting point. I removed the special character for good measure. My speakers are now called "Flur" (192.168.178.35) and "Wohnzimmer" (192.168.178.33).

@Damon77 I checked my router settings. I didnt find a feature such as Airtime Fairness. I never had any bandwidth problems on my wifi network. I have enabled automatic channel connection to use less frequented channels. Besides, I only have a router, and no additional APs or repeaters.

To the support team: Did you already have the chance to look at the diagnostic reports?
Are there any additional debugging tools that I could use to analyze the problem?
@mschmidt, What's the make and model of the router, a Fritzbox by chance?
Userlevel 4
Badge +9
It's not called Airtime fairness on all brands, maybe it's called something else on yours. You could Google your routers brand together with airtime fairness to check that.
@Smilja Yes it's a Fritz!Box. o_O
Note that Sonos support doesn't respond on these boards. The folks who do, when they have the opportunity, are the Sonos Community Forum moderators.

If you wanted to speak directly to Sonos support, you should contact Sonos Support directly.

I suggest the phone folks, they have more tools available because they're on the phone with you, but they are only available Monday through Friday during business hours. Both the Twitter and Facebook support folks are available 24/7.
@Smilja Yes it's a Fritz!Box. o_O

I suppose that you speak German, then I'm not required to translate the following into English.


Wie sieht es mit den Optionen Alle neuen WLAN-Geräte zulassen und WLAN-Geräte dürfen untereinander kommunizieren aus, sind diese angehakt?

Kindersicherung (Internetfilter) für Sonos auf Unbeschränkt setzen. Vergewissere Dich, dass die IP-Adresse des Symfonisk oder des Play:1 nicht doppelt vergeben ist (Heimnetzübersicht/Ungenutzte Verbindungen); wenn doch, bitte beide IPs löschen und im Anschluss Fritzbox sowie die betreffenden Geräte neu starten.

Außerdem der Fritzbox einen festen Funkkanal zuweisen, entweder 1,6 oder 11. Bitte durchtesten, Autokanalwahl ist nicht empfohlen.
Userlevel 7
Badge +26
Great job helping out everyone! Smilja's suggestions are a good next series of steps, so I'd follow those.

From the diagnostics, the last one did show a lot of wireless interference, so try setting the wireless channel on the router to channel 1, since it was on 11 at the time.

While I think this may be network related, and not wireless interference, if you're still having trouble it'd be good to confirm the wireless is fine. Check out how they both perform when you have them sitting next to each other, somewhere close to the router (if you haven't done so already). Unless you're using large packet pings, small ones might go through while larger ones are unable to make it. This could theoretically prevent the players from both showing up, though as I said, it's probably more likely to be a setting on the router.
Hi,

@Smilja Enabling the option "Wifi devices may communicate among each other" did actually solve the problem. Thanks a lot.

On the other hand, I must say that I find it disappointing that I have to weaken the security standards of my home network to properly run Sonos!

  • Enabling this option allows intruders to also attack all wifi-connected devices in my home (instead of just being able to use the internet)
  • Also configuring a fixed communication channel would increase the risk of Dos and Jamming attacks, since the attacker must only concentrate on a smaller set of channels.
Can someone explain why I even need to enable communication among wifi devices? Don't the sonos devices just commnuicate via the SonosNet?

Kind regards
Marcus
When Sonos devices are on WiFi, they communicate via WiFi. Since they have to be able to talk to controllers and their peers, client isolation must obviously be disabled.

Apply a strong WPA2 password.

Alternatively put Sonos into SonosNet mode by wiring a component, and get it off your WiFi.
Userlevel 4
Badge +9
As I understand the Sonos system (and please correct me if I’m wrong) the need for the Sonos speakers to talk to eachother, even when you’re not using the multiroom capabilities, is that they share setting and (if applicable) the music database with eachother.
Yes, they chat to each other from time to time, albeit with not a huge volume of data. But crucially 'client isolation' stops a WiFi-based controller from talking to a WiFi-based player. In other words the system doesn't work.

It's simply not expected for a shared broadcast medium such as a local LAN to impose client isolation restrictions. Indeed the UPnP standard, on which Sonos relies, is actually based on the LAN being a broadcast medium.

Reply