Answered

Play 1 and alexa: “sorry something went wrong”

  • 15 November 2017
  • 3 replies
  • 7742 views

We bought a sonos 1 at the weekend to add to our sonos system of 2 play 1s, 2 play 3s and a play 5. The speaker is labelled “kitchen”. It works as a sonos speaker through the sonos app, but we can’t make Alexa play any music.

Alexa can answer questions about the weather etc, but doesn’t seem to be linked with sonos at all. We haven’t set up a music account that works through it yet (we have been using deezer), but that isn’t the issue. It won’t link with sonos at all. Eg-

If we start music through the sonos app and ask Alexa to stop playing it says “I can change the playback mode only when music is playing”. Which it is.

If we ask Alexa to play radio 1 it says “bbc radio 1 from tune in playing in kitchen”. But then “sorry, something went wrong”. And plays nothing.

In Smart Home Alexa can see all the speakers. Tried activating and deactivating the sonos skill.

But- under Settings in Alexa app, as well as ‘kitchen’ it has ‘sonos one’ separately- although that is showing as offline. (That was originally named ‘Daniels’ sonos one’). If I deregister the ‘sonos one’ Alexa now says “sorry I’m having trouble understanding right now please try a little later” to everything.

So basically we just have a play one that we paid an extra 20 quid for, that can tell us the weather.

We are not the most technological people, but have bumbled through various issues with sonos for about 10 years now. How do we make this work?
icon

Best answer by Confusedwomble 15 November 2017, 21:07

No worries. Fixed it. On another post someone had suggested activating sonos skill on the website rather than the app. And miraculously it worked.
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

No worries. Fixed it. On another post someone had suggested activating sonos skill on the website rather than the app. And miraculously it worked.
I’m confused by your fix. What did you do to make it work?
It is apparently correct to see the speaker twice under devices. The problem was that the speaker was offline, because Sonos Skill wasn’t enabled. The Alexa app isn’t working properly. It showed the Sonos Skill as enabled, but it wasn’t. Instead of using the Alexa app, we logged in via amazon (on a pc). Then we enabled the Sonos Skill from there. Problem solved for us.