Phone App and PC controller don't show the same Sonos system components

  • 24 January 2018
  • 3 replies
  • 120 views

After the latest update, 1/24/2017, the phone App is not showing all my components that were previously set up. A PLAY1 is missing. Tried to add it to the system manually, no luck. PC controller was updated at the same time and shows all components including the missing PLAY1. This missing PLAY1 cannot be grouped using the phone as it isn't shown as part of the system, but I have to use the PC controller to do so. Any suggestions?

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

If you can't see a speaker, it's likely due to either wifi interference or duplicate IP address issues. You shouldn't ever need to re-add a speaker to your system, and should never do a factory reset except in extreme circumstances, and generally only when advised to do so by a Sonos employee. Resetting a speaker erases all data that is stored on it, including playlists, wifi credentials, etc, and has the potential to completely erase your settings when it's your only speaker.

Now, having said all that, I'm concerned about how one device (the PC) can see the speaker, and the other (some sort of phone) can not. That suggests that the phone isn't connected to the proper wifi signal.

What kind of OS does your PC run? What kind of phone do you have?

Since you stated the latest update as today, I'm guessing you're running 8.3. Have you tried to submit a system diagnostic?

If you use the PC to group the missing room with another, what does the controller on the phone show you?

Have you tried rebooting your router? Or perhaps your phone?

I certainly agree with you that what you're seeing isn't normal. And I'm not sure I quite understand how it got to this state, where one controller can see a device, but the other can't, so I'm kind of shooting in the dark here.
Thank you very much for your quick response. I appreciate your advice and insight as to what could have caused the PC controller and the phone app not to recognize the same components.
An interesting turn of events, as sit here this evening to respond I see now that the problem is fixed! Both the PC controller and I-phone app now recognize all the components, the rebel Play1 is now on both controllers. I would like to take credit for fixing the problem by having done at least some of the things you suggested, however, I cannot. Seems the I-phone app fixed itself. Though I am not sure why or how it happened I feel it must be another 'one of those things' that sometimes happen to electronics.
In any case, thank you again for your attempt to help solve my problem. I have learned something from the exercise, however - if something happens like this again, wait a couple of days it might go away on its own.
I wonder if it's a reflection of the fact that your phone "went away" i.e. disconnected from the wifi, and then when you came back it reconnected, and queried the Sonos system for an update of what it thought exists.

In any case, I'm glad it's resolved. Good listening!