One of my Play:1s keeps reverting to standard setup

  • 9 February 2017
  • 6 replies


I set up my first Play:1 in standard set-up. I then added a second Play:2 near my router, so I switched to the boost set-up. I followed the instructions and everything seemed to be working although I was unable to follow the suggestion to remove wifi settings as it didn't seem to know them (no reset button to click, it seemed to want me to go through a wizard to add the wifi password) so I assumed it was forgotten.

Later, I checked in About My Sonos System and the first speaker was showing as WM:1. The one connected to the router is WM:0. Am I right in thinking both should be WM:0 if they're correctly in boost mode? Both are working but I'd prefer both in boost as our network is quite congested.

I tried rebooting the first speaker by turning it off - it still showed WM:1. I read somewhere online to try a factory reset (hopefully not the wrong thing to do, I should probably have asked here first) and that seemed to work. Both were then showing as WM:0. I thought that a factory reset would remove any wifi information so it was all fixed.

Unfortunately, I had to unplug the speaker (the one not connected to the router) for a few seconds and when it restarted and I checked About My Sonos System, it was back at WM:1. I don't know how that's even possible as it should have forgotten the wifi settings during the factory reset, but it is definitely using the wifi as when I turn off the other speaker it still works.

Any suggestions would be most appreciated as to what I've done wrong and how to fix it. Thanks.

Best answer by John B 9 February 2017, 21:57

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

Much Sonos system information (e.g. playlists) is stored on every player, so I'm guessing it's still in there unless you factory reset everything, and that is not to be recommended.

It may be that it is communicating badly over SonosNet. You need to have your router on fixed channel 1, 6 or 11 and Sonos on a different one of those 3. And the wired speaker should be at least 3 feet from the router. What is the current situation on channels and distance?
Haha. Glad to have given you an excuse. You can never have too much Sonos, and the more you have, the more robust it really does make the setup.

If you have an Android device there is an app on the Play Store called "Wifi Analyzer" which I have found useful. I don't know about Apple.
Thank you. Out of curiosity, why is it bad to factory reset everything? I've only had them a few days so there's not much stored on them that I would lose.

Bizarrely, I've just checked again and both speakers are now WM:0. Would that support your suggestion that it's poor communication over SonosNet? The router is on Channel 6 and Sonos is on 11 so that shouldn't be the problem, but the wired speaker is right next to the router. I will try moving it and see if that stops the non-wired speaker flitting between modes.

Is it also possible that the speakers are too far apart for SonosNet? The room the non-wired speaker is in has poor wifi due to the thickness of the walls. I had hoped that Sonos would be more powerful than the router, but perhaps that isn't the case? The speaker is, however, in the best spot for normal wifi so I hope SonosNet can cope with it.

Thanks again for your help.
It does sound like it's on the edge of SonosNet range in your circumstances. Do you have many near neighbours? There might be other competing wireless signals. There are free wifi analyser apps out there that can show you what channels everything is using, to take the guesswork out of channel selection. You could try Sonos on channel 1 and see if it helps.

If you have next to nothing to lose then factory resetting and starting from scratch is not a real problem. But it doesn't really solve the range issue (if there is one).

One of the great strengths of SonosNet is that it is a mesh network in which every Sonos component is a potential repeater. So if the rooms aren't adjoining then a speaker in between would probably sort it!
We're in a narrow terraced house with lots of wireless networks around so I will have a look at that over the weekend, thank you.

I've moved the wired speaker as far from the router as the supplied cable will allow - while it was unplugged, the non-wired speaker downstairs was on wifi, but as soon as I plugged the wired speaker back in it switched over to SonosNet, which I had trouble getting it to do earlier, so I hope this has helped.

Thank you so much for your time. I was just saying to my husband that I think we need more speakers so I can walk around and have music follow me... so if you're saying that it would help with the signal, I should probably make him buy a speaker for half way between the two we have now (I bought those ones!).
Userlevel 2
Badge +2
If an apple device try 'Airport Utility' from the App Store. Once installed, go to Iphone settings, scroll down to Airport Utility and turn 'Wi-fi Scanner' on.

Then start the app and choose 'Wi-fi Scan' in the top right. (Not as good as 'Android Analyzer' but it's the best i've found for non-jailbroken apple devices)