Answered

One iPhone and iPad can't see existing Sonos system, other controllers fine


Userlevel 2
Badge +5
Hi all,

To get around longstanding wireless issues, today we bought a Boost and switched everything over (with great pain!). We now have all speakers connected, and my own iPhone, iPad and 2 MacBooks all working.

Bizarrely my partner's iPhone and iPad refuse to find the existing Sonos devices. The app simply shows the 'you need to add at least one device' screen. I've tried deleting and reinstalling the app, 'reset' the controller, restarting the phone. Nothing works.

Any suggestions much appreciated as the household approval factor for Sonos is rapid falling this afternoon (and it was in jeopardy before!)
icon

Best answer by Chris 7 May 2018, 20:29

ios update has probably messed up its network connectivity. On the iPhone and ipad go to apple settings...wifi ....forget home network. Once forgotten reboot router and phone/ipad. Add wifi back to device. Now try.
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

2 replies

Userlevel 7
Badge +22
ios update has probably messed up its network connectivity. On the iPhone and ipad go to apple settings...wifi ....forget home network. Once forgotten reboot router and phone/ipad. Add wifi back to device. Now try.
Userlevel 2
Badge +5
ios update has probably messed up its network connectivity. On the iPhone and ipad go to apple settings...wifi ....forget home network. Once forgotten reboot router and phone/ipad. Add wifi back to device. Now try.

Thanks Chris. Without us changing anything we tried the app again about an hour later and it just 'found' the players and carried on as normal. No idea what was going on there, and doubt I ever will! 🙂