Question

Not getting 5.1 surround from Nvidia Shield TV through Playbase (detailed post)

  • 17 December 2019
  • 0 replies
  • 493 views

 

I posted this over on the Nvidia forums but am going to post here as well in hopes of getting an answer.

So I've read a ton of topics posted about this but none describe my exact issue and I'm at my wits end with this one.

I recently purchased a Sonos Playbase, as well as left and right surrounds composed of two Sonos One SLs. I had been having trouble getting 5.1 surround sound output to my speakers from any of my devices. I have a PS4, Nintendo Switch, and Nvidia Shield TV. When I would play a show or movie on Netflix on my Shield TV or PS4, Netflix would not even display the option to output 5.1 audio. All of my devices were hooked up to my TV, and then the TV was hooked up via optical to the Sonos. The Playbase only has an optical input. I learned that my TV cannot pass through 5.1 audio (it is fairly old.)

So I purchased an audio splitter so that I could get the audio from my devices to my Sonos system before it passed through the TV. This fixed the issue on my PS4: I can now output 5.1 surround sound from Netflix and everywhere else from the system. The Shield TV, too, seems to recognize it can now output 5.1 sound: Netflix now presents the option to output 5.1 audio. However, when actually switching Netflix on the Shield TV to 5.1 audio, my speakers receive no signal.

I have tried every audio setting possible on the Shield TV's system settings. The Sonos can only receive 5.1 audio in Dolby Digital format. If I let the Shield. "automatically select" the proper output, Netflix recognizes that it can output 5.1 audio. But when selecting the 5.1 option in Netflix, it cuts the audio. Switching back to non 5.1 audio in Netflix brings the sound back, but only in stereo.

I also tried manually selecting the various different audio outputs on the shield TV settings. Some make Netflix show 5.1 output, some make the option go away, but on every setting that showed the option to output 5.1 audio in Netflix, actually SELECTING the 5.1 option caused the speakers to not play any audio.

Does anyone know what could be going on here? I know Netflix supports streaming the proper 5.1 audio format for my speakers to be able to decode it; it works fine on the PS4. It seems to be doing SOMETHING because it shows the option to output 5.1 audio on the Shield, and when selecting it the audio becomes muted, so something is happening there.

Any help would be greatly appreciated!


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.