Answered

No sound on certain channels after system update today.



Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

1877 replies

Great. Works again.
Ryan S, sorry for the delay in getting back to you regards no sound on BBC 2 and channel 5 still. Could you let me know how I get a private message to you to arrange a call regards the ongoing issue? Just about to reach a week with no sound so if it can't be resolved i'm keen to know so I can get it all boxed up and back to the shop. I'm UK based so guess the time difference may need to be accounted for. Many thanks.
Userlevel 2
TV is Panasonic
The Playbar is connected via an Optical cable to the TV

Wirelessly connected to the Rest of Sonos

I have no sound at all with Netflix

Sky and normal TV are working fine.

Diagnostic is 7842002

I also have 2 x play 3 surround and a Sonos subwoofer.

Please let me know when this will be fixed!!!
Same problem for my Playbar since 7.4 update.
Samsung tv with Playbar and Sub. Sound stops every time i pause a movie or show, or change channels.
Diagnostic 7842184
I'm having this issue. Samsung KS8500 Smart TV connected to soundbar and sub, Cable (Xfinity) no issue, but smart apps have delay in audio (Amazon seems the worst, but HBO and Showtime smart apps having issue too), up to 3 minutes. I switch to TV sound and it's playing sound. I've submitted diagnostic, but didn't get any email or anything.
Diagnostic 7842688

No sound on some TV channels. Sony TV.
Same problem here
Diagnostic #7842722

Samsung 65" smart tv
Playbar with sub
The team has been working tirelessly on this as we wanted to get you all a resolution as soon as possible. There is now an update available for testing to fix this issue.

If you haven't already been added to this beta (version 7.4.1) and you'd like to test it out, we'd love your feedback. Please submit a diagnostic from your Sonos system and post your confirmation number here so we can confirm you're experiencing the issue. We'll use that to apply the update too. We'll be adding this fix to a future release, but we'd like to offer everyone affected the chance to join this beta.

Update September 1st: Adding this to the main answer for visibility, I posted it as a comment below too.
Thanks everyone for your patience and helping out test this fix for us. So far, it’s going extremely well, which is a great sign.

The team is making sure there isn’t going to be any other adverse issues before wrapping this up into a full release and sending it to everyone. For now, we’re still going to be individually flagging systems. They’ll be evaluating everything next week to determine if this update is ready for prime time, we don’t yet have an official date on when it’s going to get set live.

This weekend we’re going to be a little short handed with the holiday in the US, so it may take a little while after posting here before you get added to the beta test list for the update. Feel free to post your diagnostics below and we’ll make sure to address each one as soon as we can. Our apologies for the delay and the silence in the meantime.



I'd like to get this update
Diagnostic # 7842722
Userlevel 2
Badge +2
I'm having the same issue. Only it's very specific. No audio through Netflix app via smart TV. No audio on DVR recorded programs for specific channels (HBO, Showtime, ESPN) - can sometimes get the DVR audio to work. Can always get it to work if I change audio out from the cable box to stereo instead of DD5.1
Samsung UN65H7150
Diagnostic = 7842743
I'm having issues with Comcast and switching channels. My diagnostic number is 7842795.
Same issue, on my Playbar. updated my systems yesterday and only noticed the issue today. Diagnostics submitted: 7842837
Hope we get this fixed asap. Thx for the help.
Badge
Same issue here.

Diagnostics: 7842887
Userlevel 2
Badge +2
I was able to have the update pushed to my playbar in an hour by contacting sonos via Facebook messenger - sent the message @ 9:45 EST, issue resolved by 10:45 EST. Sonos customer service is top notch!
Diagnostic 7842919 submitted.
I have no sound. Diagnostics 7842950
Same issue started for me tonight, DirecTV works (didn't check too many channels), smart TV apps just give clicking sound as well as PS4. Diagnostic 7843376.
I submitted my diagnostic number a couple of days ago. Please add me to the Beta.

#7832152
I also have the same problem since the update. However I'm at work now so I dont have any diagnostics. Can I receive the update without the diagnostics?
When will there be a general release to fix the surround sound problem?
Userlevel 5
Badge +3
yeti_sir, ernst, timms_andrew, jfletcher73, Redshifted, Olivier_9, Seadawg, smmcve2, and djn876 your systems have been flagged for the beta. Please update when ready.

Jeroen Bos we'll need a diagnostic in order to apply the fix.

Foxybear10 yes, there will be a general release to address this problem, but I don't have a timeframe to share today.
Please add me to the beta. 7838566
Badge
I have the same problem, suddenly no sound from TV. Diagnostics: 7845178
Userlevel 7
Badge +26
Please add me to the beta. 7838566
The system for that diagnostic happens to already have the beta, added yesterday, but it doesn't look like it's the same email as the one you're registered with. If you're having problems with your PLAYBAR audio still, can you send a new diagnostic for me and make sure you post the correct number?

I have the same problem, suddenly no sound from TV. Diagnostics: 7845178
You're all set now for the beta update. Go ahead and check for updates in your app, you should be fine after it installs.
Dito like all other, Need beta release! TV sound problem with TIVO System! No sound when switching channels. Playchannels like netflix no sound!
TV - Samsung 55" 8 series
Is your PLAYBAR wired or wirelessly connected to your network - Wireless
Is your PLAYBAR wired to your TV or cable box/SAT box - Yes
Is the PLAYBAR experiencing issues when watching TV and(or) from a 3rd party app eg; Netflix? - Yes

diag 7845468
Sorry for posting the same message twice but can't seem to see a reply. Ryan S, sorry for the delay in getting back to you regards no sound on BBC 2 and channel 5 still. Could you let me know how I get a private message to you to arrange a call regards the ongoing issue? Just about to reach a week with no sound so if it can't be resolved i'm keen to know so I can get it all boxed up and back to the shop. I'm UK based so guess the time difference may need to be accounted for. Many thanks.