Question

New Update (8.1) Broke My Sonos

  • 21 October 2017
  • 63 replies
  • 6725 views

Userlevel 1
I can't add anything to my queue on mobile or desktop with the new 8.1 update regardless of what service I use. Basically, trying to roll out cool stuff for new Sonos users broke a reliable Sono 3 I've loved for years. This is really infuriating as a long time user and am just looking for it to be resolved as soon as humanly possible so I can get back to my jams

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

63 replies

As of the recent update (I'm now on 8.2.2), we are experiencing non-stop problems with connectivity also. It's driving us crazy. We've rebooted the modem, the router, the bridge, re-chosen wifi channels, etc. Frequently. The music continues to drop out and the system frequently requests us to 'Add a new controller' or 'connect to an existing system' without going anywhere from there. We've had our Sonos player for several years now and the last year of having to update and receiving continuing issues have been extremely frustrating. This should work wirelessly as it always had. I've not changed positions of the Playbar, Router or Modem or bridge. Please please Sonos can you help. Please don't ask me to replace ethernet cables, they've all been working perfectly and this has all happened since the recent updates. Help.
MichelleG

Just to say I’m running the same version of the Sonos software and I am not having any drop-out issues so it’s likely to be your local network.

I assume you are running your Sonos system on SonosNet with at least one Sonos device cabled to your router. If that is correct you need to perhaps check these things:

1. Your router 2.4ghz band is on channel that is least-used by neighbouring properties.
2. That the SonosNet channel (channel 1, 6 or 11) in the Sonos controller settings is different to the one eventually set in your router (2.4ghz band) and also least used in your locality.
3. The router wifi credentials are not set in the Sonos Controller 'Settings/Advanced Settings/Wireless Setup' as these are not required when running on SonosNet... if they are stored there, then go through the reset procedure to remove them (only if using SonosNet).
4. Your Sonos devices are not too close to your router, or other items in you premises that may receive, or broadcast, a wifi signal such as cordless telephones etc.
5. Make sure that the Audio Compression in advanced Settings is set to 'Automatic' or perhaps try 'Compressed' instead.
6. After switching off and/or rebooting your Sonos devices, bring them back online one at a time starting with the device linked-to and nearest-to the router.

These are the basics you need to check first, if you are running your devices on SonosNet to help eliminate the interference and network issues.
Hi Ken,

Thanks for the advice.
I was a bit overwhelmed by the suggested solution, because if any of those things were the problem, it doesn't explain why they were never a problem prior to the update. I've never had problems previously with the right/wrong channel, being too close/far away to the router or compression, etc. This sort of thing happens exclusively after certain Sonos updates. It means I have to reboot all the devices, routers, modems, bridge, re-index my library, remember the link and server address of my remote music storage location, etc. In short, it's a headache. I always fear the headaches of Sonos updates.
But I solved it doing this:
- by installing a 'new system', which technically is incorrect. There were only 2 options, connect to an existing or to install a new one. But after doing this, it all worked again.

Cheers and thanks again,
Michelle
MichelleG,

Glad to hear things are now working fine, that’s the main thing, but the steps in my last post are worth checking every now and again and also I recommend you store your Sonos devices IP address in your routers DHCP reservation table at some point as that should help prevent future problems with any Sonos updates.

The access to your routers DHCP Reservation Table will usually be described in its manual, which you may find on your providers website or elsewhere online.

Anyhow let’s hope you now remain problem free to enjoy your music.

Kind Regards...

Ken
Badge +1
My Sonos doesn't work - disconnects with messages about connection etc that aren't true - Netflix and my Amazon Firestick work fine. So I'm getting fed up to the point that I won't be using it much except as a speaker. It was fun whilst it lasted but this is the end of my Sonos affair. Time to dig out those old CD's and do proper hifi.
Badge +1
Hi Michelle. Exactly same experience as you were having. I may try the 'install as a new system' route. I use a 1st gen Sonos 5 still using the bridge. I gather this is no longer required. Has anyone had any good/bad experiences removing the bridge? I don't use any other Sonos in the house. Thanks.
Badge +1
Hi Michelle. Thanks for the inspiration. Removed Bridge as part of the plan then set up from scratch. So far so good but just a few minutes in. The My Sonos doesn't appear to work yet on the app but I use Google Play for a better display of my music with album covers displayed (My Sonos does the same bright orange avatar for everything - yuk!) and then cast to my Sonos (you do still need the app to connect to the wifi but after that the Google Play app can bypass the Sonos app). PS Does anyone know how to lose the User + no and substitute a name in this forum?
Software just updated to v8.3 on my Android and PC. Let's just say I had to uninstall the app from my phone to even get the system to respond. Just terrible QA by Sonos over the past 6 months. Major issues with skipping, and app not being able to control/change play in rooms, etc. This latest little bug was a gem. I opened the Sonos app on my phone and some random songs started playing in my kitchen, even though the app said it was playing some other playlist in the bedroom. The app would not respond and had to move to my PC, let it update to v8.3 and then stop the music. I'm at the point where I will not buy any more Sonos gear and recommend anyone to steer clear of the products until they can get their damn software fixed.
Badge +1
Happy to report that getting rid of the Bridge and using Google Play to cast to my Sonos 5 (Gen 1) has cleared all my problems (as well as installing as if from new). In addition, my old tablet (original Tesco Hudl) which is no longer supported by the latest Sonos app update doesn't need the Sonos app at all. Just works from Google Play. Same with my phone although I've kept the Sonos app on that for the volume control. That is one thing not on the Google Play app. But the Google Play app does search which is not available on the Sonos app if using Google Play (I used to be on Spotify and I think that had a search facility on the actual Sonos app). So I am a happy bunny and steering clear of future updates. Who needs the Sonos app and its updates to mess up your system?
Userlevel 7
Badge +20
Hi, TrevorG. Hello, iseekthegrail. I'm not entirely sure that this is an issue caused by the software. The symptoms strongly suggest a network communication issue. While Netflix and other devices or services may be unaffected, Sonos communicates in a different manner than the aforementioned. As such, I would like to ask you to submit a diagnostic and respond with the confirmation number. This will outline the cause of the issue and enable me to advise how to resolve your issues. Many thanks.
I've been working with Tech Support for a month now. The claim is that there is a lot of packet loss on my network, both using my BRIDGE or my personal home WIFI. I have 7 sonos device which all worked flawlessly for several years until 8.x updates. I notice there are a lot of minor updates right now too. Hopefully they get this resolved soon. Looks like I'm not alone. 'bout ready to consider Google's or Apples setup or some other solution. This is unacceptable. At the very least, why can't we as users choose to rollback to a previous software version? This would never fly in an enterprise environment. To be fair, Taylor from tech support has been great to work with and is always friendly and professional.
Why did “Line In” disappear? Or, where is it? Since update I get No Music error. Serious waste of time trying above fixes.
Line in only shows up when something is physically plugged in to the socket. If there's nothing plugged in, it won't show up.