New Sonos Roam - Wifi Connection Issues

  • 19 December 2021
  • 34 replies
  • 4748 views

Userlevel 1
Badge +1

I recently purchased a new roam this week after much anticipation. I am however very disappointed with the purchase. I am unable to keep the roam connected to WiFi. It works for a few hours but eventually disconnects and then the status like blinks from white to orange. I can hear the music skipping if I listen to the speak against my ear. The speaker itself makes a popping sound as it connects and disconnects from WiFi. 

The room works through bluetooth. The Sonos app shows the roam connected to the system despite the blinking light. The Sonos system is up to date, the roam is up to date and I am using the latest Sonos iOS app as well. 
 

I’ve gone through the forum’s posts on this subject and did hard resets, rebooted my WiFi. Nothing seems to work. My current system has five other speaks connected without issue, throughout the house. I’ve tried moving the roam closer to the router. Nothing seems to work and I am afraid that I’ve received a lemon…

 

Edit as of this afternoon: Bluetooth does not work either. The status light will blink from blue to orange. When I try to play music, the status light blinks blue to orange and a pink color. No idea what is going on and very frustrating. My Other Sonos speakers were far easier to setup and play without issue. 

 

 


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

34 replies

Userlevel 1
Badge +1

@RBuchetto,

It is likely the case that changing default router/network settings are perhaps beyond the remit of Sonos Support and I guess we can all understand that.

I think it’s the case for the Roam to have likely worked on your network that it would have required such router changes/configuration, not least I would personally have suggested disabling QOS & Airtime Fairness on the Router, putting all your Asus WiFi AP’s to run on the same channels/channel-width and set the non-portable Sonos products to only run on SonosNet.

My choice would also have been to put the Roam to run on the 5Ghz band only.. and those things are probably a step beyond what Sonos Support are there to do, which is provide support for their own products only, rather changing settings elsewhere across the LAN. 

If I look around the various threads in the community here, I also see that the Asus Router firmware may cause issues from time to time in regards to SSDP multicast discovery issues too and I guess that may also add to the woes seen aswell. So I guess it’s maybe best to leave things as they stand for the time being and fingers-x’d🤞that things continue to work okay for you with the non-portable Sonos devices.


Agree that this is all beyond Sono’s scope of support. I had asked if the Roam could be on 5g and I was told that it currently only supported 2.4g.

 

Fingers crossed that things continue to work. My Sonos system has been up and running for 7 years so far, which is why the Roam had me completely annoyed! 


 

@RBuchetto,

It is likely the case that changing default router/network settings are perhaps beyond the remit of Sonos Support and I guess we can all understand that.

I think it’s the case for the Roam to have likely worked on your network that it would have required such router changes/configuration, not least I would personally have suggested disabling QOS & Airtime Fairness on the Router, putting all your Asus WiFi AP’s to run on the same channels/channel-width and set the non-portable Sonos products to only run on SonosNet.

My choice would also have been to put the Roam to run on the 5Ghz band only.. and those things are probably a step beyond what Sonos Support are there to do, which is provide support for their own products only, rather changing settings elsewhere across the LAN. 

If I look around the various threads in the community here, I also see that the Asus Router firmware may cause issues from time to time in regards to SSDP multicast discovery issues too and I guess that may also add to the woes seen aswell. So I guess it’s maybe best to leave things as they stand for the time being and fingers-x’d🤞that things continue to work okay for you with the non-portable Sonos devices.

Userlevel 1
Badge +1

@RBuchetto,

You mention you set the Roam’s priority in your router to high - is that through Airtime Fairness or QOS?

Did you also do that prioritisation with your new Sonos One gen2 aswell?

Also are any of your current Sonos products wired directly, or indirectly, to the main router, particularly  as you are currently using an Asus mesh system for your WiFi network?

Ken,

all existing sonos speakers are wireless and dispersed across the home (kitchen, living, dining, family room, bedrooms). The home is two levels. 
 

ASUS AI mesh is setup such that AX88U is the primary switch that is wired directly to the cable modem. The AC88U is setup as a wireless repeater and place on the other end of the home to expand coverage of the WiFi. As an example or WiFi signal strength, I can remain connected to my system, two homes down the road. 
 

Regarding the Roam’s priority under the Router’s QoS settings. I also tried giving streaming services QoS priority as well as bound the Roam to the network so that it wasn’t prone to roaming between the main router and the repeater node. Airtime Fairness is turned on by default with the ASUS Routers, so I leave it alone.


Regarding the existing Play:1 and One speakers, none of them are bound to the network or have any higher priority over other devices in the network. 
 

Ultimately I just flat out gave up, as Sonos Tech offered no further solutions and wouldn’t really get deeper into the operation of my wireless network. I spent a lot of time on this and even searched solutions through the SNBForums. 

 

I also want to point out the the Roam never wanted to group with any of the other wireless Sonos speakers on the system. 
 

However Ken, I really do appreciate all of the time you’ve invested in reviewing this issue with me and offering feedback. You’ve gone above and beyond the level of service that I experienced from Sono’s dedicated support team. Cheers to you! 🍻 

 

 

 

@RBuchetto,

You mention you set the Roam’s priority in your router to high - is that through Airtime Fairness or QOS?

Did you also do that prioritisation with your new Sonos One gen2 aswell?

Also are any of your current Sonos products wired directly, or indirectly, to the main router, particularly  as you are currently using an Asus mesh system for your WiFi network?

Userlevel 1
Badge +1

Just an update from me on this topic. I returned the Roam to Best Buy and swapped for another Sonos One.

Sonos Technical support ran diagnostics on my system twice and made the claim that it was my router’s issue. As I had stated to the rep, the Roam was not the only product I had (as they confirmed by pulling the information of my system). They suggested moving the Roam and that it was in a location with a weak signal. I eventually became frustrated and returned the Roam.

 

I purchased a Generation 2 Sonos One and place it in the same soot as the Roam, in our kitchen. Works beautifully and we just recently added two new connected washer and dryers and dishwasher to our home network. My theory is that there are Roams out there with a terrible WiFi and Bluetooth antenna. Sad, because I was really looking forward to the portability of the Roam. for a portable speaker, I may settle on a UE Boom. 

There’s quite a lack of information in the comparison of the two Sonos products and their wireless connection to your network..

What WiFi band was the Roam using and what band is the Sonos One now using? - were they the same type of wireless connection to the router?

Are the devices using the same wireless channels and channel-width (you do not mention what they were?) …or… are the router channels perhaps set to ‘auto-select’?

Not to mention the potential influence from possible neighbouring channels.

If the router auto-selects it’s WiFi channels for each band, then you may just have a case here where you are perhaps simply comparing ‘Apples’ to ‘Pears’, and that’s without even actually altering anything yourself. You may have a case of auto-WiFi connections, which maybe entirely different from each other.

 

 

To be fair, I didn’t think I needed to be overly complete in recounting my problems!
 

However;

 

When Sonos Tech support ran their diagnostics, they suggested to dedicate my Sonos system speakers to WiFi channel 1, 6 or 11 and said that all off their products “typically” work best when on these channels. I tried setting the Roam to one of these channels and it did not resolve the issue. It was then suggested that I had too many connected devices (currently 34) on my netowork and that I may experience better operation when there was less network traffic. Still did not work, regardless of time of day or my disconnection of devices on the wireless network to test. 

 

Support later suggested that maybe my WiFi issues came from my network being on a similar WiFI channel as my neighbors - causing congestion and pushing the newer Roam on my network to the back of the priority line to connect. So, I did a WiFi scan and selected a less congested channel on my router. I also tried setting the priority high on the Roam in my router settings. Still, the Roam did not work.


The last attempt, Sonos tech support accessed my system online and said they did a reset on their end. The Roam started to work and stream music, but then after about 30minutes of straight running, the audio would cut-off and I could hear a popping sound of the audio coming on and off. There Roam would then no longer connect.  Sort of like a stuttering in audio. Bluetooth, still never worked correctly and with respect to Bluetooth and I was then told to disable all Bluetooth devices connected to my iPhone to try streaming, but that did not work. 

 

I tried moving the Roam closer to the router antennas, changing channels to the suggested ones that Sonos products best operate on. Nothing worked and so I decided to return it before my store’s return policy expired. 
 

Currently, my Sonos system is now dedicated all speakers to channel 1 (now six) comprised of Gen1 Play:1s and Gen1 and Gen2 Play One speakers. Same ASUS Router Mesh network comprised of an RT-AX88U and RT-AC66U. Some have suggested an issue with ASUS routers in general, but I keep the firmware up to date and never had problems until I tried to connect the Roam.

 

I may have received a lemon, but it gave me a poor impression that I don’t want to even consider the new RoamSL. 

 

Just an update from me on this topic. I returned the Roam to Best Buy and swapped for another Sonos One.

Sonos Technical support ran diagnostics on my system twice and made the claim that it was my router’s issue. As I had stated to the rep, the Roam was not the only product I had (as they confirmed by pulling the information of my system). They suggested moving the Roam and that it was in a location with a weak signal. I eventually became frustrated and returned the Roam.

 

I purchased a Generation 2 Sonos One and place it in the same soot as the Roam, in our kitchen. Works beautifully and we just recently added two new connected washer and dryers and dishwasher to our home network. My theory is that there are Roams out there with a terrible WiFi and Bluetooth antenna. Sad, because I was really looking forward to the portability of the Roam. for a portable speaker, I may settle on a UE Boom. 

There’s quite a lack of information in the comparison of the two Sonos products and their wireless connection to your network..

What WiFi band was the Roam using and what band is the Sonos One now using? - were they the same type of wireless connection to the router?

Are the devices using the same wireless channels and channel-width (you do not mention what they were?) …or… are the router channels perhaps set to ‘auto-select’?

Not to mention the potential influence from possible neighbouring channels.

If the router auto-selects it’s WiFi channels for each band, then you may just have a case here where you are perhaps simply comparing ‘Apples’ to ‘Pears’, and that’s without even actually altering anything yourself. You may have a case of auto-WiFi connections, which maybe entirely different from each other.

Userlevel 1
Badge +1

Just an update from me on this topic. I returned the Roam to Best Buy and swapped for another Sonos One.

Sonos Technical support ran diagnostics on my system twice and made the claim that it was my router’s issue. As I had stated to the rep, the Roam was not the only product I had (as they confirmed by pulling the information of my system). They suggested moving the Roam and that it was in a location with a weak signal. I eventually became frustrated and returned the Roam.

 

I purchased a Generation 2 Sonos One and place it in the same soot as the Roam, in our kitchen. Works beautifully and we just recently added two new connected washer and dryers and dishwasher to our home network. My theory is that there are Roams out there with a terrible WiFi and Bluetooth antenna. Sad, because I was really looking forward to the portability of the Roam. for a portable speaker, I may settle on a UE Boom. 
 

Hi

 

I have exactly the same intermittent problem on wifi.  I can get bluetooth working fine.  So this isn’t an isolated issue.

 

However, once I have got it working on wifi it doesn’t drop out.  Its like it needs a little time to settle and connect to the network.

 

Having got it working on bluetooth, I disconnected the BT and forgot the device as suggested.  I was then able to connect spotify directly to the Roam on wifi.  wierd.

 

 Follow-up and something of a workaround: 

I called support and I could not get the problem to occur while they were ready to troubleshoot.
Next day, it was back to skipping again :rage: .

It continues to misbehave and I will send it back when I find the time.

For now, I have a clunky workaround that may help.
 

  • Turn on the Roam
  • Connect (via Sonos app or otherwise)
  • Play audio through the Roam
  • When it starts to skip, press the Play/Pause button on the Roam
    • Press close to the time the “skip” sound occurs
    • If you hear a bit of your audio play, press play/pause button again about the time it skips
    • Repeat, listening to “good” audio till the next skip and then press the button again
  • Basically, continue to do this and eventually, audio will just play normally.
  • Once it plays for at least 5 seconds, until the speaker goes to sleep or is turned off, it will work perfectly

NOTE:  I have not been able to determine one set of repeatable steps, but I can consistently get the Roam working if I take up to 20 seconds doing the above steps.

I still need to send it back, but I am just too busy to go through the support process right now.  I’ll report back if I figure out anything better, but I’m hoping this might help some other poor soul.

I’m glad I have tons of other Sonos hardware or I’d think badly of it going off the Roam experience.  I feel like they should have a recall or something as they must know what is causing this.

For what it’s worth, I’ve had the exact same experience. Two Roams that had the connection issues, orange flashing light, skipping, etc. 

Have tried all the troubleshooting steps to no avail. Will be returning the speaker and waiting for the next gen. All my other Sonos products work flawlessly… seems to be some spotty hardware.

Thanks all for your work!!!  Mine has been failing like you describe for a month now and I was convinced that if I found the exact order of button-pressing I could get it to work.


I finally found this thread and am happy to learn my next step of calling Sonos support was the right call.

Lucky us to receive the “broken” Roams :-(

All- Sonos support ran a diagnostic and confirmed this new Roam had the same issue as the last new Roam they shipped, so it too is being sent back and they are sending another new one. They said this is a known issue with a batch of new Roams, and the diagnostic they run remotely can easily identify the issue and there is nothing to be done to fix it. It needs to be replaced. Thanks again for the help from this community to try different things!

Apologies, Airgetlam, we aren’t technically savvy and since it’s a brand new Roam, we wanted it fully fixed to use in all modes, not just wi-fi. Thanks, Kengriffiths, for that clarification that it could impact the Bluetooth mode as well. We’ll try this fix today!

If you ‘could’ do that, why not try?  At the very least, it eliminates one of the potential variables. 

Thanks, Ken. We could do that, but both brand new Roams do the same thing on Bluetooth connection or Wi-Fi so I don’t think the fix is the wi-fi

Both your local WiFi and Bluetooth use the 2.4Ghz band, so it’s still worth trying the routers WiFi channel switch to a non-overlapping channel and possibly change the band that the Roams are connected to too, to see if that helps …and switching the channel-width to 20MHz will certainly reduce interference.

Thanks, Ken. We could do that, but both brand new Roams do the same thing on Bluetooth connection or Wi-Fi so I don’t think the fix is the wi-fi

Really interested in a fix for this. We got a new Roam, connecting to wifi fine, but it has all the other issues you list here for your Roam: says it is playing, you can control the volume and skip tracks with it, but it sounds like an old school record or CD skipping. Happens in wifi and Bluetooth, and no factory reset works. If I push the play/pause button quickly I can get it to play about 1 second just fine and then it goes back to skipping. We too have 5 other Sonos devices, all working just fine.
Here’s the rub: tech support did all the official reboots and troubleshooting, couldn’t fix it. said the first one was a lemon. So they shipped us a new one. Opened today, and it’s doing the exact same things- same exact issues as the first new Roam. Before I call Tech support to do the same things, I’m suspicious of  whether this might be a software glitch. I don’t know when the new software rolled out since this is our first Roam, but when you get a new one in the last 2 weeks during setup is says there is a required software update that I couldn’t figure out a way to bypass and continue through setup process. Any chance when your Roam was working with Bluetooth and playing it was before a software update rolled out?  

It’s quite unusual, in that both of your Roams seem to have the exact same issue - anyhow, have you perhaps tried changing the WiFi band that’s being used for the Roams connection to the router? So if it’s currently connected to the 5Ghz band, then maybe try switching it to use the routers 2.4Ghz band. I would set the 2.4Ghz band to use either channel 1, 6 or 11 (as any of those are non-overlapping) and set it’s channel-width to 20MHz in your router configuration pages. Just see if that makes a difference.

Really interested in a fix for this. We got a new Roam, connecting to wifi fine, but it has all the other issues you list here for your Roam: says it is playing, you can control the volume and skip tracks with it, but it sounds like an old school record or CD skipping. Happens in wifi and Bluetooth, and no factory reset works. If I push the play/pause button quickly I can get it to play about 1 second just fine and then it goes back to skipping. We too have 5 other Sonos devices, all working just fine.
Here’s the rub: tech support did all the official reboots and troubleshooting, couldn’t fix it. said the first one was a lemon. So they shipped us a new one. Opened today, and it’s doing the exact same things- same exact issues as the first new Roam. Before I call Tech support to do the same things, I’m suspicious of  whether this might be a software glitch. I don’t know when the new software rolled out since this is our first Roam, but when you get a new one in the last 2 weeks during setup is says there is a required software update that I couldn’t figure out a way to bypass and continue through setup process. Any chance when your Roam was working with Bluetooth and playing it was before a software update rolled out?  

Yes, I’m out of ideas too. Hope Sonos Support are able to assist you tomorrow. You should be able to contact them via this LINK.

All the best.👍 

Userlevel 1
Badge +1

Can you perhaps just try this… Off it’s charger, press/hold the rear power button for 20+ seconds, don’t let go until you see the status LED light reappear and then see if that sorts your issue. Note: the device will power off during this process, but just keep the power button pressed till you see the light return and then let go and it will boot up. Then try the Bluetooth pairing again.🤞

Still not working. 
 

Thank you for all of your kind help! I’ll try with tech support tomorrow. But, I have a feeling they this will be going back to the store soon. Seems to be broken out of the box! 

Can you perhaps just try this… Off it’s charger, press/hold the rear power button for 20+ seconds, don’t let go until you see the status LED light reappear and then see if that sorts your issue. Note: the device will power off during this process, but just keep the power button pressed till you see the light return and then let go and it will boot up. Then try the Bluetooth pairing again.🤞

Userlevel 1
Badge +1

I’m not sure your pairing it correctly - if you first delete the existing pairing with the speaker on your mobile, then do this:

  • From WiFi mode (constant white status LED light) normal power on state, press and hold rear power button for 3 seconds and let go - you will hear a ‘ding’ and the Status LED will now flash blue.
  • Goto Mobile’s Bluetooth list and you should see the speaker ready to pair.. select it to pair it and you will hear the ‘success’ tone and the status LED switches to a constant steady Blue light.

You can then play music to your speaker from the mobile source Apps like Spotify, Deezer etc.

To stop the pairing/playback and return the speaker to WiFi only, just disconnect, (not remove) it using the mobile device Bluetooth list. (NB: You can also reconnect to it from this list).

Note when the Roam is connected to Bluetooth, it will remain connected to your local WiFi too and so it can be grouped with any other Sonos device(s) to play the playing Bluetooth audio to those other Sonos device(s) aswell.

HTH

I’ve tried again, using the same steps outlined above. I have connected, but then the stays light flashes from Blue to Orange. I try to send music using the IOS music app, no audio plays. 
 

Tired with my wife’s phone and get the same flashing status light result. The phones says they are connected, but the light never stays a static blue color. 
 

 

I’m not sure you’re pairing it correctly - if you first delete the existing pairing with the speaker on your mobile, then do this:

  • From WiFi mode (constant white status LED light) normal power on state, press and hold rear power button for 3 seconds and let go - you will hear a ‘ding’ and the Status LED will now flash blue.
  • Goto Mobile’s Bluetooth list and you should see the speaker ready to pair.. select it to pair it and you will hear the ‘success’ tone and the status LED switches to a constant steady Blue light.

You can then play music to your speaker from the mobile source Apps like Spotify, Deezer etc.

To stop the pairing/playback and return the speaker to WiFi only, just disconnect, (not remove) it using the mobile device Bluetooth list. (NB: You can also reconnect to it from this list).

Note when the Roam is connected to Bluetooth, it will remain connected to your local WiFi too and so it can be grouped with any other Sonos device(s) to play the playing Bluetooth audio to those other Sonos device(s) aswell.

HTH

Userlevel 1
Badge +1

Have you perhaps tried a factory reset of the Roam? It maybe worth a try…

  1. Power off the Roam (5+ second press) on rear power button until you hear the 4 descending shutdown tones.
  2. Wait 10 seconds.
  3. Hold down Play/Pause and power ‘on’ with rear power button - keep Play/Pause button pressed until you see it flash Amber. Then let go the button.
  4. Status LED will switch to flashing Green, at which point open the S2 Sonos App and setup the device on your existing system.

Thanks! I tried this, setup the roam into the system again. Tried playing music VIA Bluetooth and I hear a brief 1second fragment of the song and the audio goes off again. Still does not work on WiFi, either. 
 

I’ll try Sonos support tomorrow, but from the other threads online it seems a lot of people share the same issues and end up returning their roam. 

Having Factory reset the Roam, did you first of all remove the ‘existing’ pairing of the Roam in your Bluetooth list on your mobile device? - you will definitely need to delete/remove it and setup the Bluetooth pairing again. This is required so the sharing token can be setup again between your mobile Bluetooth link and the ‘reset’ device.

Yes, I “forgot” the prior token and reconnected the roam to my iPhone. When I try to play music, the Blue status light be dings to flash orange and pink/purple. I can’t find an orange to pink/purple status light color in the Sonos manual to understand what it might mean.

Have you perhaps tried a factory reset of the Roam? It maybe worth a try…

  1. Power off the Roam (5+ second press) on rear power button until you hear the 4 descending shutdown tones.
  2. Wait 10 seconds.
  3. Hold down Play/Pause and power ‘on’ with rear power button - keep Play/Pause button pressed until you see it flash Amber. Then let go the button.
  4. Status LED will switch to flashing Green, at which point open the S2 Sonos App and setup the device on your existing system.

Thanks! I tried this, setup the roam into the system again. Tried playing music VIA Bluetooth and I hear a brief 1second fragment of the song and the audio goes off again. Still does not work on WiFi, either. 
 

I’ll try Sonos support tomorrow, but from the other threads online it seems a lot of people share the same issues and end up returning their roam. 

Having Factory reset the Roam, did you first of all remove the ‘existing’ pairing of the Roam in your Bluetooth list on your mobile device? - you will definitely need to delete/remove it and setup the Bluetooth pairing again. This is required so the sharing token can be setup again between your mobile Bluetooth link and the ‘reset’ device.