New apple tv 4k, LG onscreen volume message


Original setup: LG 60UJ6300, Sonos Playbar, Sub, Apple TV 4th Gen.
With the original setup, I could control the volume of the Sonos, and not have an onscreen message. I swapped the Apple TV4th Gen with a new Apple TV 4K. I followed sonos instructions setting up the remote, etc. Now with the Apple TV 4K, when changing the volume, a grey circle with a crossed out speaker shows up on the TV screen. I have searched all over the sonos site and the LG site, and cannot find how to turn this off.

Please help if you can. I will keep searching for an answer. again, it didn't have this message when I had the ATV4th gen,

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

13 replies

Userlevel 7
Badge +19
Hi, bummer. Thanks for posting. Typically the reason TV's give off this message is that it can recognize the codes being sent from the remote. The way to not have the TV give that nag message would be to either turn off the remote control receiver on the TV or use a remote that can be programmed to use commands that the TV wouldn't recognize but your other components are able to.

We have a really great Home Theater Megathread you may want to check out when you have a free moment.

Best of luck!
Thanks for the reply, but the Home Theater Megathread is no help. I don't want to use a universal remote. I want the setup to be simple and I want the functionality of using the microphone on the Apple TV remote.
Something has changed with the Apple TV 4th gen vs Apple TV 4K. I never got this message on the older model. I'm thinking that the new Apple TV is using the HDMI-CEC to control the volume.
I am still frustrated that everytime I use the volume button I get a grey circle with a line thru it. It's driving me mad.
Today I decided to take the Apple TV out of the equation. I used just the built in TV apps, and the sonos. I used just the TV remote to control the volume, and boom, still getting the grey circle with the line thru it. So this doesn't have anything to do with Apple TV or HDMI-CEC. it's a LG / Sonos thing.

I verified my audio settings on the LG TV. The LG TV is set to use the optical out, no internal speakers. See attached pictures.

Bump
Bump. Just got the beam and have this problem with my LG tv
I'm still having this issue with the LG TV. Everytime a LG software update comes out I cross my fingers hoping it fixes this annoying issue.
Userlevel 7
Badge +21
@Bummer, you may want to take a look at this if you haven't already.

https://support.sonos.com/s/article/2072?language=en_US

That really only refers to your Apple TV side of the issue, not LG or any tv manufacturer, so it may not be any help.

For your test case where you changed to volume via the TV remote, did the volume actually change on your playbar?

Also, have you tried switching your sound setting to 'LG Sound Sync'?

I could be way off on these suggestions, mostly just guessing.
I have gone thru this support article about 10 times. https://support.sonos.com/s/article/2072?language=en_US It's no help. The issue is on the TV, there is no way to eliminate the onscreen message.
The TV remote and the Apple TV remote both control the playbar. Both give the onscreen message.
I tried LG sound sync, but this enabled the LG speaker and the playbar, the onscreen message disappears and you get the LG volume controls instead. Not terrible, but when using the Sonos and the TV speaker it sounds just a tad echo-y.
It sounds to me like you should work with LG support as well, since this looks to be generated by the TV.
It sounds to me like you should work with LG support as well, since this looks to be generated by the TV.
LOL. LG will just say its Sonos or Apple TV's fault. I don't have the patience to call LG and have them post the finger at someone else.
@Bummer, you may want to take a look at this if you haven't already.

https://support.sonos.com/s/article/2072?language=en_US

That really only refers to your Apple TV side of the issue, not LG or any tv manufacturer, so it may not be any help.

For your test case where you changed to volume via the TV remote, did the volume actually change on your playbar?

Also, have you tried switching your sound setting to 'LG Sound Sync'?

I could be way off on these suggestions, mostly just guessing.


Tried all of these, nothing works 😞
This seems like your problem: "You may notice that when you press the volume on your remote, it is not adjusting the volume of the home theater speaker, but the television speakers instead. If your TV speakers are disabled or muted, you may get an icon or message telling you this."

https://support.sonos.com/s/article/3403?language=en

Check out the description/procedure at: "I have recently purchased a Sonos home theater speaker, and already have the Apple TV setup"

You have to trick the Apple TV remote to "unlearn" your TV.
Bummer:

Just in case you haven’t already found the solution...sorry I didn’t want to read through all the threads.

I have an LG tv with an Apple TV 4K connected directly. I was also getting that dreaded grey ghostbuster sign every time I controlled the Playbar volume with the Apple TV remote....it was actually controlling the volume of the Playbar, but it was also sending an IR signal to the tv. Problem is the tv’s speakers were turned off, hence the grey error signal.

The solution for me was quite simple. I needed something to control the Playbar via IR...but not the tv. In my case, I already had a Logitech Harmony remote set up to control my Playbar via IR.

With this Logitech remote, I simply went into the Apple TV settings->Remotes and Devices->Volume Control->Learn New Device. When prompted to hit the volume+/- buttons, I used the buttons on the Logitech remote to complete the task (NOT NOT NOT the Apple TV remote).

Voila!!

Now my Apple TV remote controls my Apple tv, power to my LG tv, and volume for the Playbar without any grey circle error messages. If Sonos actually came with a cheap IR remote, this whole process would have been easier to figure out, IMO. It stumped Apple and Sonos support when I called both.

So, get some type of programmable universal remote and set it up to control the Playbar, then you’ll have what you need to finish the setup.

Hope this helps!!