Netflix Sound disappeared. Why?


Our Sony 56" has perfectly played Netflix via 2 sonos S1' and playstation. Until tonight. We went down the list of things that ARE working. TV surround sound: check. Goodgle via tv. Sound is perfect, Apple Music controlled S1's. (3 more around the house). I loaded all 5 as a "group" tonight and they played perfectly. Back to Sony TV control. We get a good looking picture but no sound. It worked last night. i doubt our Snarky Sneaky friends aren't smart enough to futst with it. Did asssigning (controlling) all 5 sonos to a group from my iPad do something bad? Seems to be undone now but still no sound.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

11 replies

Userlevel 7
Badge +21
There will be 4 reasons you get this:-

1) Playbar has no power - Not in this case
2) Playbar is faulty - Not in this case
3) There is a signal being sent down the optical but it is the incorrect format - Check the audio settings in your PlayStation Netflix app and make sure that you select a suitable audio format (EG Dolby Digital 5.1). Playbar will give silence if it receives a DTS, Dolby Digital + or format it cannot decode.
4) No signal from the optical cable. Harder to check but it seems likely that if you are receiving audio when using the PlayStation with other apps then it is likely issue 3 above but you don't give enough data on your problem. The cable could be damaged or not fully inserted at either end
are we saying Netflix and now Amazon apps are only now outputting DTS or DD+ 5.1. Everything was working fine for me a couple months ago, and now both native apps on smart TV have no sound out of playbar. The Sonos diagnostic says 'silence'. This is a major major sonos problem
I'm not aware that anyone is saying that Netflix and Amazon apps are now only offering DTS or DD+. Every post I've noticed suggests that you need to lock those apps down to Dolby Digital, which isn't the same thing as saying they only offer one thing.
in my new Vizio smart Netflix and Amazon app there's no way to edit the audio output. Of course, I can change the audio out on the TV to PCM (stereo) vs Bitstream, but sound isn't great and shouldn't have to adjust TV setting wverytime I switch to smart app
Not 100% sure, but you may be helped by the latest beta, which you can get by posting a diagnostic in this thread:

https://en.community.sonos.com/troubleshooting-228999/no-sound-on-certain-channels-after-system-update-today-6789926
Since update there is no audio when I play netflix. I have Samsung 4K smart tv, playbar, subs etc. diagnostic submitted. #7886746. Pls help.
heychey,

Perhaps if you were to post in the thread I linked to in the post just before yours, you might find a remedy.
Thank you. I finally figured out how to do that. 🆒
Glad to hear it 🙂
I added a long story here:

https://en.community.sonos.com/troubleshooting-228999/7-4-update-and-netflix-6790011

Short story: Bad/non-compliant redmere HDMI cable after Fall updates.
Huh. That's really interesting. Thanks for sharing!