Answered

Need help connecting Play:3 to wifi

  • 5 June 2022
  • 2 replies
  • 49 views

  • Contributor I
  • 0 replies

Long story (sorry)

 

I have had a Play:3 for many years… love the product.

It used to be connected wireless to my old router (let’s call it “A”)

I then switched internet provider and got a new router (let’s call it “B”)

Router A is no longer connected to the internet, but still active (it is used as a switch to connect devices that don’t need internet), but router B is connected to the internet.

I then removed the wifi connection to A, from my Play:3 speaker (via the Sonos S2 App). I then attached an ethernet cable from B to my Play:3 speaker. And it works perfectly. But still no wifi connection to B.

Connecting my Play:3 speaker via ethernet cable is not solution (unfortunately) and I need to connect via wifi. But I cannot figure out how to do it. I have tried every to-do on this site and others. No luck

When I try to add ‘a trusted network’ I press “Find System” and the little circle spins around 4-5 times and the times out and goes back to “Find System”…… not happy!

What am I doing wrong?

icon

Best answer by nik9669a 5 June 2022, 16:37

View original

2 replies

Userlevel 7
Badge +18

Check you’ve not disabled wifi on the speaker. If it’s not that the wifi hardware in the speaker may have failed: best way to check that is to submit a diagnostics report and contact Sonos support. 

Userlevel 7
Badge +18

Also make sure the wifi on router A is turned off. 

Reply