Answered

NAS drive

  • 3 April 2022
  • 8 replies
  • 118 views

My family of Sonos speakers are connected on the home wifi and so is my NAS drive.  Streaming Apple Music plays fine but connecting my NAS drive is a nightmare - it is often not recognised and it randomly skips tracks when playing music stored on it.  I have checked - my NAS drive does not have bad sectors.  Any other person facing the same problem and is there a fix?  Would it help if i connected all speakers to an internet cable?  Thanks

icon

Best answer by Corry P 6 April 2022, 12:56

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

8 replies

Not really enough information here to give a semi useful answer, sorry.

Are you using S1 or S2? What kind of NAS are you using? Is you NAS hardwired to your router? Is up your Sonos system set up as a wired system, or is it connected to your WiFi signal? What make and model router are you using? Have you submitted a diagnostic after experiencing this disconnection, and contacted Sonos support?

 

Are you using the Sonos Music Library and app for this? Or some sort of audio player on the NAS? If the latter then please do the former.

https://support.sonos.com/s/article/257?language=en_US

Userlevel 7
Badge +21

Music should play flawlessly from your NAS if other sources are also playing well.

It does not take much of a NAS to support Sonos but if it does odd things or sleeps it can be a problem.

The info asked for above can help find you more specific answers.

Thanks so much all of you for your responses and apologies i was not clear at the outset:

I am using the SONOS library and S2 app for this

My NAS drive is a Western Digital “My Cloud” model.  It is hardwired to the router.  However, my SONOS system is working off the home WiFi.  I will need to double check the make/ model of my router and i have not yet run diagnostics/ contacted SONOS support with this.

Appreciate any steer you can provide.  Tx/ rgds

Ok, similar to my system, then, except that I’m using SonosNet (the ‘wired’ option). 

The challenge here is you state other streaming music is working without interruption, yet your NAS is having difficulty. Just for clarity, when you’re streaming Apple Music, that’s via the Sonos app, and not via AirPlay 2 from an Apple device?

It suggests some difficulty in your NAS connection, rather than the Sonos speakers. Just to verify, which version of SMB is your WD using?

There might be value in unplugging the NAS, then rebooting the router, just to clear any potential duplicate IP addresses that may be lingering. Once the router comes back up, you could plug the WD back in to power. That being said, I don’t recall if I’ve ever had a duplicate IP address issue with my router, but I suppose there’s a very small chance.

It might be worth trying to wire a single Sonos device to your router, just as a test, but I wouldn’t expect that to make any difference, since my expectation is the connection is failing on the / to the NAS, not the Sonos, since you say Apple Music is working. 

In all honesty, your best bet may be to reproduce the issue, then run that diagnostic, and contact Sonos support. This is an unusual enough occurrence that looking at some hard data in logs might help. 

Thanks Bruce.  When i am streaming music off the net, i am using Apple Music and not the SONOS app.  Have there been any known bugs in the SONOS app in relation to this issue?  Maybe i should also check again if i have bad sectors on my NAS drive...

So, using AirPlay 2, not Sonos’ own controller/software. Just confirms the issue isn’t with the connection with the Sonos speakers, though, if you’re not getting similar interruptions. 

I’ve never seen what data is actually in a Sonos diagnostic, but assume that it’s all data about what is connected, and not hardware issues on those devices. Still, it might be good to rule out any potential connection issues, but if it was indeed bad sectors on the NAS, I wouldn’t think that would show up in the data that Sonos can see. I would expect them just to see a brief interruption in the data, without an explanation why. 

Userlevel 7
Badge +18

Hi @sat2010 

Welcome to the Sonos Community!

It’s hard to say exactly what’s going on here (at the moment), but Western Digital MyCloud devices can utilise a “fake” music service in order to play your locally stored music on Sonos. Using this service may be the simplest way to bypass the problems you are experiencing.

In the Sonos App, please go to Settings » Services & Voice » Add a Service (under Music & Content) » Search Icon (top right) » My Cloud Home » Add to Sonos and follow the on-screen instructions. When Playing, choose My Cloud Home as the source to browse.

If you’d like help getting it working using the normal Sonos Music Library, please submit a support diagnostic and reply here with the number given and I’ll see what I can find. Thanks.

I hope this helps.