Question

My wireless Play 1s cut in and out at random.

  • 14 January 2017
  • 8 replies
  • 269 views

My setup: a Mac mini connected to a Vizio TV. I have a Playbar connected to the TV to capture the sound from my mini (iTunes, the SONOS Mac app, Netflix, YouTube, etc.) To stream the music throughout our apartment, I have a Play1 in the bedroom and another in the kitchen; these are both getting a signal from the Playbar (I'm not using my Internet wifi signal to stream SONOS; i.e. it's in "Boost" mode, as you guys call it.)

My problem: sound from the Play1s will randomly cut in and out. There doesn't seem to be any discernible pattern to it - it happens at various times throughout the day. And sometimes it'll go for days and work flawlessly, then one day I'll be streaming some music and the 1s will cut in and out. When it's happening, it seems to happen once every 30-60 seconds and the drop out lasts for a second or two, then resumes playing.

The Playbar sound does not drop in and out (it's hardwired to the TV, so no surprise there.)

The closest Play1 is probably less than 20 feet from the Playbar, with almost zero visible obstruction, and the second Play1 is just around a corner from the first, maybe 6 feet away from it.

My Internet router is an Apple Airport Extreme. It's sitting 17.5 inches away from the end of my Playbar. It's putting out a 2.4GHz signal and a 5GHz signal, set to choose the channel automatically.

My SONOS is currently set to use Channel 11 (because I had a problem a month or two ago where my speakers disappeared and the only way I was able to reconnect them was to change the channel they were operating on.)

I submitted a diagnostic report and my conf # is 6999376.

I'm sure this question has been addressed somewhere by now, but after about half an hour of digging through the archive, I gave up and decided to submit a new question. Thanks for any help.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

8 replies

Userlevel 7
Badge +22
I would set the Airport to either channel 1 or 6 permanently - you don't really want it using any other channels other then those 2. That will keep it from going to channel 7 or above and interfering with the playbar (which being pretty close to it would be pretty likely).

Are there any other wireless devices near the Play:1s (like a cordless phone or something within about 6 ft.).
Userlevel 7
Badge +22
Great descriptive post by the way 😃
Userlevel 7
Badge +22
Also - while your in the router settings updating that channel.

I like to reserve the IP addresses for all my Sonos units to avoid future issues. I would pick 3 IP addresses at the far top end of your routers allowable numbers (that won't ever get assigned by the router automatically). After doing so turn off the sonos units, reboot router, and then plug back in all the sonos units (starting with the playbar that is connected to your router).
I would set the Airport to either channel 1 or 6 permanently - you don't really want it using any other channels other then those 2. That will keep it from going to channel 7 or above and interfering with the playbar (which being pretty close to it would be pretty likely).

Are there any other wireless devices near the Play:1s (like a cordless phone or something within about 6 ft.).


Hi - thanks for the quick response. Follow-up question about this one: I don't know a ton about wireless networks, so I could be off here, but I have a vague memory of setting my Airport to automatically pick its channels b/c I read somewhere that it would pick the best ones on its own (i.e. channels with least congestion). As I live in an apartment building, there are lots of other wifi signals floating around. Is this not accurate? I'd hate to sacrifice the quality of my Internet signal for the sake of my Sonos signal.

As for your question: there aren't. Other than our iPhones and iPads (and the aforementioned wifi signals from neighbors), we don't have any other wireless devices near the Play:1s.
Also - while your in the router settings updating that channel.

I like to reserve the IP addresses for all my Sonos units to avoid future issues. I would pick 3 IP addresses at the far top end of your routers allowable numbers (that won't ever get assigned by the router automatically). After doing so turn off the sonos units, reboot router, and then plug back in all the sonos units (starting with the playbar that is connected to your router).


Thanks, I'll look into doing this
Userlevel 7
Badge +22
You can use a wifi sniffer program to see the clearest channels on your network. I'm not sure about the automatic being the best thing. Because it could pick like channel 9 or something thinking clearer but that would be interfering with your channel 11 Sonos.
Userlevel 7
Badge +20
My setup: a Mac mini connected to a Vizio TV. I have a Playbar connected to the TV to capture the sound from my mini (iTunes, the SONOS Mac app, Netflix, YouTube, etc.) To stream the music throughout our apartment, I have a Play1 in the bedroom and another in the kitchen; these are both getting a signal from the Playbar (I'm not using my Internet wifi signal to stream SONOS; i.e. it's in "Boost" mode, as you guys call it.)

My problem: sound from the Play1s will randomly cut in and out. There doesn't seem to be any discernible pattern to it - it happens at various times throughout the day. And sometimes it'll go for days and work flawlessly, then one day I'll be streaming some music and the 1s will cut in and out. When it's happening, it seems to happen once every 30-60 seconds and the drop out lasts for a second or two, then resumes playing.

The Playbar sound does not drop in and out (it's hardwired to the TV, so no surprise there.)

The closest Play1 is probably less than 20 feet from the Playbar, with almost zero visible obstruction, and the second Play1 is just around a corner from the first, maybe 6 feet away from it.

My Internet router is an Apple Airport Extreme. It's sitting 17.5 inches away from the end of my Playbar. It's putting out a 2.4GHz signal and a 5GHz signal, set to choose the channel automatically.

My SONOS is currently set to use Channel 11 (because I had a problem a month or two ago where my speakers disappeared and the only way I was able to reconnect them was to change the channel they were operating on.)

I submitted a diagnostic report and my conf # is 6999376.

I'm sure this question has been addressed somewhere by now, but after about half an hour of digging through the archive, I gave up and decided to submit a new question. Thanks for any help.


Hi Jody,

There are wireless communication errors between your PLAYBAR and PLAY:1 speakers. This is most often due to wireless interference. Are there any third party wireless devices near your PLAYBAR or in between it and your PLAY:1s? Common sources of interference include cordless phones, wireless cameras, wireless baby monitors and wireless printers. Try moving any such device away and see if things improve.

It may also help to change the wireless channel your Sonos system is using.

Hi Jody,

There are wireless communication errors between your PLAYBAR and PLAY:1 speakers. This is most often due to wireless interference. Are there any third party wireless devices near your PLAYBAR or in between it and your PLAY:1s? Common sources of interference include cordless phones, wireless cameras, wireless baby monitors and wireless printers. Try moving any such device away and see if things improve.

It may also help to change the wireless channel your Sonos system is using.


Hi Jeff - while I appreciate the fact that you responded to my post, the content of your response leads me to believe you didn't actually read my question :(

As I mentioned above - my router is 17.5 inches from the end of my PlayBar. There are no other wireless devices near my Play:1s. As for changing the channel my Sonos is using - I recently changed it (as stated above). The dropping out happened in the past (on whatever channel Sonos was using before), and the dropping out is happening now, using channel 11.

So far is sounds like Chris (see response above) has the most realistic, permanent solution - lock my wifi router into channel 1 or 6, and the Sonos system to channel 11, so they can't interfere with each other. The only downside I can see in this scenario is that if my apartment neighbors' routers are heavily skewed to channels 1 and 6, my wifi signal might suffer due to interference from them. But I could be wrong about this...I'm not a networking expert.

Any thoughts on this proposed solution, Jeff?

Thanks