My Sonos no longer sees my iPhone music library


Without explanation my iPhone music library no longer appars on the Sonos menu as an ption to play - I'm left with just radio stations etc. I recenly updated my iPhone which included a freshening up of the music app on the iPhone 6 - now no joy with SONOS - anyone help?

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

37 replies

This remains an active problem for me. When I have no internet, no music for me except from the phone speakers lol.

Tried all suggestions listed here and some of my own ideas. Very disappointed, having spent over 2k on Sonos.
I'm sorry, you've resurrected an 8 month old thread.

Would you re-state the issue you're having, with specifics, so that we can help?

Based on your initial post, I'd suggest that if you have no internet, your internet speakers should not work.Things would be different if you have a local wifi set up, just without access to the outside world. In that case, you should be able to connect your phone to the wifi signal, as well as the speakers, and be able to play music "from this phone" without issue. But of course, no streaming from outside.

But it's unclear what situation you've run in to, which is why I'm asking for more specifics. Especially since you claim to have spent more that 2K on your Sonos. I've had 17 speakers for years, and haven't had a significant issue, it's worked the whole time.
Bruce,

Thanks for reply.

I am in a touring band, and we have a large Sonos system we carry with us for the green rooms. Not all locations have internet access, so I rely heavily on my downloaded music library.

Local network working fine, which is why having no access to my local downloaded library (usually accessed from ‘on this iphone’) is crucial.

I’ve tried every suggestion in the thread with no results.
Ah, I see.

In your case, what I would be doing (and have done) is purchase a travel router. Then, I'd connect my travel router to the local internet, and have my phone and Sonos speakers connect to the travel router's signal. That way, your phone would always be able to play on your Sonos, and you'd only need to be connecting a single device to each internet system.

I did this when living in a hotel in Thailand. They had a web page log in that would refresh periodically. I would connect my travel router to their system as needed, and would have my phone, computer, and Sonos speakers connected to the travel router, and the system would work at all times, even when I switched hotels (on occasional trips to India).

And, to be honest, I set up my travel router to have the same SSID and password as my home network, so that I really didn't have to "reset" my speakers, they would just connect, since they thought it was the same network.
Yes, that’s exactly what we do. We have 2 routers, and set up a network daily for music, tv, comms, etc. I can connnect to Sonos just fine, But when I cannot select downloaded non-cloud music from my iPhone under ‘on this iphone’, no music can be played.
That would lead me to think that the phone isn't connected to the same router as the Sonos, then. As long as they're both on the same subnet, it should connect without issue.
I’m not having connectivity issues. I cannot see the music from “on this iphone”. That’s what this thread is about.
Userlevel 7
Badge +19
Iv22: Are you still having trouble with this? If you are able to connect to Sonos, but Sonos is not able to locate the content on your phone, it sounds like it could be a file sharing permission on the network. Have you dug around in the settings of your router to make sure file sharing is enabled?
I fixed mine by going to SETTINGS, SONOS... There’s a switch at the very bottom that says something like “Stream to Sonos”.
I had this same issue after downloading and re installing the sonos app. Thank me later

Solution- Settings > sonos app > on this device (as image)
Allow the Sonos app on iOS to have access to your iTunes library: settings > scroll down to Sonos > App Settings > iTunes Music (slider should be on the right hand side) This worked for me! Thank you.