Answered

My Sonos keeps cutting off songs before the end on iOS



Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

175 replies

If your controller app can't send a diagnostic, it's a sure sign that something is blocking the Sonos speaker system from reaching certain addresses on the internet (it has to upload the data on Sonos' servers). Most people, when faced with this issue, do a simple reboot of the router, which refreshes the DNS settings, and frequently clears up the issue.

That being said, there's nothing better than a direct call to Sonos to discuss it. It would give them the opportunity to do a remote desktop session with your system, and look at some possibilities, and most likely resolve your issues.
Same issue with songs cutting off before the end. Playing songs from an iOS device. Diagnostic number is: 1209871801.
I'd just like to (a) say i have * exactly * this problem and (b) thank the person(s) who suggested preventing the lock screen coming on the iPhone - this has 100% fixed my issue. The problem (as already pointed out) is that this is now totally insecure and at odds with apples own security advice.

Based on this, i can't see how an argument for "wireless interference" can be made. If i let my iphone lock, i lose the last 3rd of tracks, if i prevent lock, they all play to the end. The iphone is in exactly the same location the whole time.

This is very clearly an issue with sonos software and one which needs to be addressed immediately. Sonos have a very passive-agressive approach to support, its all very friendly but they will never, ever admit to any issue. Its futile to ask this, but sonos needs to acknowledge there is a problem and they are working on it, that would go a long way to helping fix this situation.

thanks anyway to the folks who posted, its helped me at least
Same problem with Android and when streaming from my Mac. Diagnostic report 502145234. Please provide solution
I mostly play my music library on my laptop or through Spotify with no problem. It's been a long time since I played my library from my iPhone but that was the problem way back when. I tried doing that today thinking surely what ever the problem was way back when was fixed by now but I was wrong, it seemed worse. Every song played for about 20 seconds before moving to the next.
Same problem here. Playing from my phone to Sonos one HAY limited edition. Diagnostic: 842708265
This crap has infected my system too. This has never happened until now although it’s been awhile since I streamed music from a device. It’s happening while playing music on Sonos through my iPhoneX and my MacBook Pro so I have zero reliability now. It’s infuriating.
I've also been having this problem for several months. It was a problem on the iphone, but I've switched to Android and still have the problem. Tried changing wireless channel, even hardwired the speaker. Same problem..only when playing from my library, never from a streaming service. This is not a wireless interference issue. And tonight it's gotten worse...skipping after only a few seconds,and the lock screen is not coming on. Tried changing the wifi power settings as some have suggested, still no good.
Userlevel 7
Badge +21
So submit a diagnostic to Sonos and contact them with the number it gives you. Here will work when someone comes by, twitter and facebook are staffed 24x7 or the phones open for you again based on your location.
Hi everyone. Songs cutting out is a fairly generic symptom, however, there is a specific issue that we're looking into where streaming from iOS device's storage (using "On this iPhone/iPad") runs into issues with non-Sonos AirPlay devices. You can change your iOS settings such that your devices do not auto lock, which would prevent this issue. To do so, head into the settings app and go to Display & Brightness, then set auto lock to never. Also, you can try disabling AirPlay on any non-Sonos devices on your network, as this can also prevent the issue from coming up.
My wife’s iPhone played here playlists fine by switching off auto lock until today when she updated her iOS. Now no songs play all the way through even when auto lock is switched off.
Something needs to be done about this as it was bad enough having to switch auto lock off every time we want to play music then remembering to switch it back on so the phone battery doesn’t go flat. It’s a real pain in the *#se!
So this is clearly a generic app/software problem if it has cropped up fairly recently for people. Can someone from Sonos please update on how they are addressing this with Android as well as ios. Please....thanks.
Yes, come on Sonos, this is clearly an issue that you need to fix NOW!
Or Apple does....
So can Sonos confirm or deny whether the issue is theirs or Apple? Although I believe some people have the same problem on Android?
I’ve submitted the same question on the Apple support pages to see what happens
Yep same issue on Android phone. Every song cuts off at roughly 1m - 1m 20secsfrom the end, then there's a gap and the next song plays irrsepective as to whether i touch my phone or let each song just play. I have been watching roughly when this happens, even rewinding part of songs to see if it happens again and it always does. Diagnostic number: 1580247923
I am having the same issue with songs getting cut off. This is a massive Sonos issue. It happens from my iPhone, my wife’s iPhone and my laptop. The “wireless extension” excuse is crap. If you are building a network of audio devices for a home the use of wireless exenters is a common practice for internet. We have sonos in multiple rooms and one hell of a strong WiFi signal. I have assigned addresses for all sonos equipment and we still have this problem. I get skipping on Pandora, iTunes and almost any other music service except if I hardwire my line in. This is a problem with sonos and it needs to be fixed.
Userlevel 7
Badge +20
Yep same issue on Android phone. Every song cuts off at roughly 1m - 1m 20secsfrom the end, then there's a gap and the next song plays irrsepective as to whether i touch my phone or let each song just play. I have been watching roughly when this happens, even rewinding part of songs to see if it happens again and it always does. Diagnostic number: 1580247923

Hi there,

The specific issue with iOS streaming and AirPlay does not apply to streaming from Android devices. If you're getting cut outs while streaming from your Android, the issue is caused by wireless interference, network congestion, or another connection issue between your Android, router, and speakers.

Your diagnostic reports are coming through with errors in the formatting, which can happen when there is a large number of communication errors. Please see this guide for some troubleshooting tips.

If those steps don't help, try sending another diagnostic report. Though it may be best to reach out to our phone team in case your report has errors again, making it hard to read. You can find our phone number and hours here.
Userlevel 7
Badge +20
I am having the same issue with songs getting cut off. This is a massive Sonos issue. It happens from my iPhone, my wife’s iPhone and my laptop. The “wireless extension” excuse is crap. If you are building a network of audio devices for a home the use of wireless exenters is a common practice for internet. We have sonos in multiple rooms and one hell of a strong WiFi signal. I have assigned addresses for all sonos equipment and we still have this problem. I get skipping on Pandora, iTunes and almost any other music service except if I hardwire my line in. This is a problem with sonos and it needs to be fixed.

Hi there,

There is a current issue we're investigating that causes playback from iOS devices to be interrupted by non-Sonos AirPlay devices on the network when the iOS device goes into auto lock or goes asleep.

If you have any playback issues when playing from your laptop's storage, then there is a different issue going on. Most of the time audio playback issues are caused by wireless interference, or network congestion. You mention extensions, which I assume means wireless extenders. These can work with Sonos systems, though they can also cause communication troubles if not configured correctly. Are you using a home WiFi mesh system? If so, which type?

Please submit a diagnostic report from your Sonos system and reply here with the confirmation number after you have a playback error while streaming from your laptop's storage. I'll take a look for you.


Hi there,

There is a current issue we're investigating that causes playback from iOS devices to be interrupted by non-Sonos AirPlay devices on the network when the iOS device goes into auto lock or goes asleep.

If you have any playback issues when playing from your laptop's storage, then there is a different issue going on. Most of the time audio playback issues are caused by wireless interference, or network congestion. You mention extensions, which I assume means wireless extenders. These can work with Sonos systems, though they can also cause communication troubles if not configured correctly. Are you using a home WiFi mesh system? If so, which type?

Please submit a diagnostic report from your Sonos system and reply here with the confirmation number after you have a playback error while streaming from your laptop's storage. I'll take a look for you.


A few things: I am having this issue on my iOS devices AND my laptop, playing saved playlists from Spotify. This is not local storage. Impossible to submit a diagnostic report as I get an error message when I try to do that. Really very frustrating but I was relieved to see that I'm not the only person having this problem. Still, the answers/solutions posed by Sonos here don't seem to work for anyone.
You may have a completely separate issue, which only looks the same from the outside. If it's happening on your laptop as well, it's likely one of two things. The most likely issue is wifi interference. That's a pretty good FAQ that has quite a few suggestions on things you can try which might resolve your issues.

The other potential, which they don't seem to have a FAQ on, is the possibility of duplicate IP addresses in your local LAN. This can get exposed often by software updates by Sonos, when each speaker is put through a soft reboot in order to pick up the new software. If your router is in a bad way, it can then hand out duplicate IPs.

There's a quick way to check this, though. Unplug all your Sonos devices from power. Then reboot your router, which resets it. Then, one at a time, plug back in each Sonos device, allowing it to boot up completely before moving on to the next and plugging it in. If you've got one of your Sonos devices hooked to the router with an ethernet cable, it's good practice to start with that one, otherwise, I'd just do the device closest to the router.

If that happens to work, I'd think seriously about looking at your router's manual to figure out how to set up reserved IP addresses. It usually isn't hard to do, once you understand the process, but each router company seems to handle it slightly differently. But once you've done it, you shouldn't run into this situation again.

Good luck!
Badge
I am also having this problem on my iPhone X since the last update
This happens for us and has done all the time we have had Sonos equipment (4 - 5 years)...... very frustrating.
We use OS devices and even keeping the autolock off and turning off airplay makes no difference. I've changed channels and also this make no difference. Here are our diagnostics 14641820
Has happened to me for ages, but recently has been happening loads... Can I ask please, how do you get a diagnostic number...?
Thx
submit a system diagnostic

The amount of data submitted is in the range of 10 to 15 minutes, so be sure to replicate the issue before submitting the diagnostic.