Question

My Playbar stopped receiving power

  • 3 November 2016
  • 3 replies
  • 172 views

My Playbar recently stopped receiving power. I attempted a power cycle, and was unsuccessful. I'm not able to see any lights appear on the Playbar once plugged in, and it's removed from my app. Is there anything you can do to help?

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

Userlevel 6
Badge +3
My Playbar recently stopped receiving power. I attempted a power cycle, and was unsuccessful. I'm not able to see any lights appear on the Playbar once plugged in, and it's removed from my app. Is there anything you can do to help?

Hi jp84, welcome to the community.

Make sure the power plug is fully pushed into the PLAYBAR. Also, you can try in a different power well plug in the house.

If the PLAYBAR still doesn't turn on the best would be to contact us by phone. A Sonos agent will be able to check the available options for returning your PLAYBAR.

Let us know how it goes.
Userlevel 7
Badge +17
Put a new fuse in the plug, if UK style plug, always worth a try ;O)
I see you are USA so forget that...
But I'd agree with the "push the plug in" comment from Max P. I recently moved mine, and it surprised me at how hard it was to seat, and just how far in pushed in.

Oh, and another thing, which I ran into with some other Sonos speakers.....make sure the plug is live. I tried plugging in some Play:3s into the wall in my bedroom, and it turned out the plug that I was using was controlled by the light switch. That took me a good 10 minutes to figure out 🙂