Answered

My Alarm is playing Sonos Chime instead of Tunein Radio Station


Help,

This is so annoying and it never used to happen. I have had Sonos Speakers in every room since 2018 and no problem until recently. The first alarm is set for 5am weekdays to play LBC on Tunein. The second one is set for 7am weekends to play Classic FM on Tunein. The problem is totally Random, some days it happens and others it doesn't. I had a 46 minute one to one with Sonos on Wednesday 18th May and the alarms worked for 3 days until the problem started reoccurring, again randomly. The case number is 03899693. 

icon

Best answer by dave77 21 June 2022, 13:05

View original

27 replies

Userlevel 7
Badge +18

Hi @dave77 

Assuming you haven’t disabled WiFi on your wired Play:5 (which you do not want to do), you will already be on SonosNet, so the issue won’t be down to unsupported WiFi extenders, as it was with above.

As you have never submitted diagnostics from your system before, I can only assume the issue is either due to:

  1. Electromagnetic interference, in which case you should see what you can do to minimise it - check our Reducing wireless interference help page
  2. Slow DNS resolution from your router or DNS server - reboot your router by switching it off for at least 30 seconds, or change the DNS server in your router’s settings, then reboot the router (8.8.8.8 is Google’s DNS server address, and is generally a good option)
  3. Something weird and random - reboot the speaker
  4. Random server glitch - try another radio station
  5. Poor signal strength - move the speaker, keeping it in the same room, but getting it closer to the wired Play:5 or if clearly out of range, another non-portable Sonos device. This is less likely than the first four, as you are able to play. Perhaps the signal is worse when you happen to be in bed - bodies can absorb WiFi signals.

I hope this helps. If not, please help me help you by submitting a support diagnostic and replying here with the number given. Thanks.

 

Userlevel 6
Badge +11

The Sky router was set to Auto for the 2.4GHz channel, so I’ve set that to 11 and disabled 2.4GHz on the Sky mesh boxes (I still need 2.4 on for some gadgets). I’ve set Sonos to ch1. The alarm worked this morning, i’ll see how it goes!
Thanks for your help 👍

Userlevel 7
Badge +18

Hi @dave77 

The alarm worked this morning, i’ll see how it goes!
Thanks for your help 👍

That is a good start, and you are very welcome!

Userlevel 7
Badge +18

Hi @dave77 

I see that Radio X is also on Sonos Radio, I will try that first rather than TuneIn and see how that goes.

I would be surprised if that made a difference, but it is technically possible. In your position, I would start with the reboots.

Userlevel 7
Badge +18

Hi @dave77 

Now that is some out-of-the-box thinking. I like it. 🤞🏻

Although in those 7 minutes I would fall asleep again. Perhaps 6:58? 

Userlevel 7
Badge +18

Hi @GordonRoof 

You are correct - the reboot cleared any useful information. The best time to send the diagnostic, ironically, is when the chime is going which is when you’re unable to connect to the system to silence the alarm or send a diagnostic.

I did notice, however, that none of your Sonos devices are connecting directly to your router, and that you have Sky internet. In my experience, this most likely means that your Sonos system is now connected to the WiFi broadcast repeated by a Sky Q box, and this is known to cause issues. In fact, if your Sonos devices are connecting to the Sky Q box and your phone is connected to the router (or vice-versa, as on the previous diagnostic the speakers were connecting to the router), that would explain exactly why you are unable to connect in the app. If speakers were spread across the two Sky WiFis, this would create grouping problems.

I recommend you connect any one (not the Sub) of your Sonos devices to the router with an ethernet cable, permanently. Ideally, this would be a unit centrally located, in relation to the locations of the other units. This will shift the entire system onto SonosNet - the wired unit broadcasting Sonos-only WiFi and each unit repeating the broadcast to create a mesh, much like your old Bridge did. This is quite likely to fix all the problems you’ve been experiencing. Please keep the wired Sonos unit at least 1m away from the router.

If, after testing, you are happy that things are better, you can then remove the WiFi credentials from your Sonos system. If no speaker “lives” near the router, and SonosNet does help, you can use the fact that you own a Bridge to get a discount on a Boost - just call our sales team. Remember that a long ethernet cable is cheaper than a Boost, however.

I hope this helps.

 

Userlevel 7
Badge +18

Hi @GordonRoof 

It probably has a lot to do with reboots - if you were to reboot your Q box, all the speakers would immediately jump over to the router, where there’s still a connection to be had. If you were to reboot your router, all the speakers would jump over to the signal from the Q box, which even without an active internet connection, would still be broadcasted. If you reboot the speakers, however, they will log on to whichever signal is stronger at that particular location. Switching your Sky Q box off and on again at the wall will likely clear up issues for a while - until the next reboot of the router or speaker. However, you’d need to make sure your phone wasn’t connected to the Q box either, and the phone is more likely to switch as it is moved around the house.

It’s a real shame that Sky insist on repeating the WiFi signal, but poorly! Your use of a Bridge will have been preventing this issue back when it was in use - we just need to get you back to that configuration.

Userlevel 6
Badge +11

Hi @Corry P - I rebooted the Play:1, and also switched to Radio X on Sonos Radio. Same result, the sonos chime starts instead of the radio, I turn it off then press play immediately to start the same radio station (it was the last played one) and it plays fine.

Diagnostics: 757536972

Userlevel 7
Badge +18

Hi @dave77 

Thanks for the diagnostic.

I think the problem here comes, in part, due to alarms not wanting to wait for a stream to arrive - if it doesn’t do so within 3 seconds, the chime is played instead. When manually playing, the speaker will wait much longer before returning a fail code.

As to why the speaker cannot get the stream in 3 seconds, I will, for now, put it down to congestion and interference - the fact that your WiFi and SonosNet are both using the same 2.4GHz channel (6) is a bit of a red flag, and I see some transmission failures right at the time of your alarm. As one of your Sky access points (I’m guessing these are Sky Q boxes too) is on channel 11, that leaves channel 1 for Sonos. After double-checking that all your non-portable Sonos devices are online in the app, please go to Settings » System » Network » Change SonosNet Channel » 1. The change will be instant and there will be no messages after you do so.

Test again with the alarm in the bedroom - it needs to be an alarm to recreate the circumstance, but it needn’t be in the morning.

If there’s no improvement, I would perhaps look at @Mr. T‘s instructions above to disable 2.4 Ghz on the Sky Q box closest to the Bedroom speaker - be sure to test the box afterwards to ensure it can still play content. Please also make sure that neither the Kitchen speaker (which is acting as an access point for the bedroom and others), nor the Bedroom speaker are within 1m of the router, other WiFi devices (especially Sky Q boxes), or a glass or metal surface.

I hope this helps.

 

Userlevel 6
Badge +11

Thanks @Corry P I will try that. I thought I’d disabled 2.4GHz on the SkyQ boxes ages ago, it was back on though. I don’t have anything on channel 11, my Sky is on 6. I have a wifi analyzer though and do see something on ch11 with a hidden SSID, might be a neighbours.

 

Userlevel 6
Badge +11

It worked ok for 2 days then played the chime again today, can you see any issues here?

885295608

Userlevel 7
Badge +18

Hi @dave77 

The Sky Q box closest to your Roam at the time of the diagnostic was on channel 11 (same SSID as the rest) - perhaps they are channel hopping? If so, you’d want to put an end to that. Disabling 2.4 on them will do that, of course.

Best of luck!

Userlevel 7
Badge +18

Hi @dave77 

Yes. The Kitchen speaker (hosting SonosNet) is having real trouble communicating with the Bedroom speaker. The signal strength is at the low end of being acceptable, but it seems interference (at the Bedroom) is probably overcoming it at times. If you put your phone near the speaker when you go to bed, that would be something to change.

Having no idea about the layout of your home, I can only really say that if you can decrease the straight-line distance between these two, please do so. Alternatively, if you can get them even further apart, the Bedroom may then use the Living Room as it’s connection point instead.

Alternatively, if you can get an ethernet connection to the Living Room, this would make that connection more “attractive” to the Bedroom speaker (One WiFi hop to a wired connection is more attractive than two hops, and stronger signals are too, but less so). In fact, Living Room looks like a more suitable location for the ethernet connection than Kitchen does as it’s more centrally located, going by the various signal strengths. The portables use WiFi, so don’t come into the equation.

I hope this helps.

Userlevel 6
Badge +11

Thanks. I do have a Boost that I could use and place a bit more central, I will try that. I’ve got a Hubitat hub and have been playing around using that to start the alarm, seems to work fine so I could use that as backup. Settings here incase anyone ever needs to fo this…..

 

Userlevel 7
Badge +18

Hi @dave77 

That’s good to hear - thanks for updating the thread!

Userlevel 7
Badge +18

Hi @GordonRoof 

Thanks for your post!

Going by your most recent diagnostics, there isn’t much to see that’s a concern - things look pretty clean. However, all rooms have an alarm set for 16:45 - no other alarms. I presume this diagnostic was taken at the end of troubleshooting with the agent? You should not set an alarm on each room - set only one and check Include grouped rooms. You would need to ensure the required rooms are grouped prior to the alarm going off (before you go to bed, for example).

The chime will sound for an alarm when, at that exact moment, the speaker with the alarm cannot receive the stream set to play. This could be for a few reasons, some of them you wouldn’t be able to do anything about - like a server problem. Therefore, success can never be guaranteed. Plus, it only takes the one speaker with the actual alarm set to have a problem, and all the others in the group will have the same problem.

So, my advice is for you to try setting the alarm on a different speaker - if it’s set on Kitchen now, please try setting it on Bedroom 2, check Include grouped rooms and ensure all required rooms are grouped to Bedroom 2 (select Bedroom 2 alone, then group other rooms to it).

If you usually have your alarms independently set on each room, that is likely the cause of the issue - normally, only the Group Coordinator (the room to which other rooms are grouped) would fetch the stream and it would then distribute it across the required rooms. If each room is set to do it independently, then you are asking for a separate stream to be fetched for each room and that’s likely to stretch your network/internet connection beyond the point at which things work reliably. The server could also be refusing to allow that many streams to a single public IP address.

If this doesn’t help, please wait for the issue to reoccur, then immediately submit a support diagnostic and reply here with the confirmation number when convenient. Please provide details such as where the alarm is set. Thanks. 

Userlevel 6
Badge +11

Hi,

I have exactly the same issue. My Play:1 has an alarm set to play Radio:X at 7am, sometimes works, sometimes doesn’t, this has been working fine for years and I have only been having issues in the past month. When the Sonos Chime plays I can go to the app, press stop, then play again to start the radio station and it works fine?!

In my case I have my Sonos system wired to the router (Play:5 G2).

Userlevel 6
Badge +11

I see that Radio X is also on Sonos Radio, I will try that first rather than TuneIn and see how that goes.

Userlevel 6
Badge +11

Hi @Corry P , the Boost didn’t fix it, I placed it at the centre of the house but still had failed alarms. Now I’ve tried something new, and it has worked 3 days in a row so far. I figured that lots of people could be setting alarms on the hour so whatever service is used it may be at its peak time, hence taking longer to respond and failing to start in the allotted timeframe. So I changed the alarm from 7am to 6:53am, I’ll see how that goes 😁

Hi,

Thanks for your reply. The 16.45 alarm was a test with the agent. The alarms including the tests with the agent were always set on grouped rooms never individual. The agent changed the Group Coordinator from Bed 2 to Kitchen. The alarms are currently set on Kitchen as the group coordinator. It again failed yesterday morning and to stop the chime I had to turn off the Sonos power circuit switch (they are all linked on the same electrical circuit which only has Sonos Units). The app on my phone would not connect to cancel the chime. I sent a diagnostic 767689216 but this was after I restarted the units so not sure how informative it will be. Exactly the same thing happened again this morning. The alarm was set to play LBC from Sonos Radio (someone else had suggested changing to Sonos Radio from Tunein) at 5am on the kitchen plus grouped speakers. Again my phone would not connect to Sonos and neither would my wife’s phone. So I had to reboot all the speakers to cancel the chime. The grouped speakers were used the previous evening as we have classic FM playing on the grouped units for 2 hours on sleep timer each night. This situation is certainly getting worse now and we had many years of exactly the same stations waking us up at exactly the same time each morning without any problems. This recent problem of not being able to connect to turn off the chime is a further extension of the problem.

Yes I do have a Sky Q box. The previous test done with the agent did reveal that 2 No. routers were registered on the Sonos units. We removed the redundant one. I have had a Sky Q box since 2019 and this alarm problem is only recent. I am not sure I still have a bridge as I was told I didn't need it. It would be complicated to hardwire a Sonos Unit to the router, however I could test it with a very long ethernet cable. Would it be worth going back to the old bridge system and can you confirm that this will work with my units? How about if I change my Internet to a different provider which I am considering anyway? Thanks

Userlevel 6

Yes I do have a Sky Q box. The previous test done with the agent did reveal that 2 No. routers were registered on the Sonos units. We removed the redundant one. I have had a Sky Q box since 2019 and this alarm problem is only recent. I am not sure I still have a bridge as I was told I didn't need it. It would be complicated to hardwire a Sonos Unit to the router, however I could test it with a very long ethernet cable. Would it be worth going back to the old bridge system and can you confirm that this will work with my units? How about if I change my Internet to a different provider which I am considering anyway? Thanks

The Bridge is only compatible with S1, not S2 so it depends what system you are running.

Changing ISP would prevent the Sky Q box acting as a repeater, however, the simpler option is to disable the 2.4GHz band from the Sky Q box. You can go into the Sky Q’s engineer’s menu (highlight Settings, press 0,0,1, then select Settings), go to Network and toggle 2.4 GHz wireless to OFF then click Confirm. If you do this make sure you leave the 5 GHz on so that the boxes can connect to each other. You’ll need to separate  the 2.4 and 5GHz bands so they have different WiFi network names in the router’s settings.

Userlevel 7
Badge +18

Hi @GordonRoof 

To back up @Mr. T’s reply, as your system is on S2, the old Bridge is not supported. Even if you were on S1, I still wouldn’t recommend its use. Literally all it is now good for is a discount on a Boost - the modern equivalent.

While the advice to deactivate 2.4GHz on your Sky Q box would have helped with some of our older models, the devices you have can all connect to 5GHz, so in this case doing so would not help.

Removing excess WiFi credentials wouldn’t have helped either, as the Sky Q box will repeat the Sky signal - same SSID, same password.

As @Mr. T confirmed, changing ISP would stop the Sky Q from repeating the signal, but I assume wiring a single Sonos device would be easier.

I hope this helps.

Thanks both. How much is a boost and is it guaranteed to work, or do I need to test first with an ethernet cable?

 

Userlevel 7
Badge +18

Hi @GordonRoof 

A Boost is £99 and available here: https://www.sonos.com/en-gb/shop/boost. The 30% discount from the Bridge will take that down to a fraction over £69

If you can’t get your 30% discount by logging in to your Sonos account at www.sonos.com/login, then our sales team will be able to help you - just call 0800 0 265 565 from the UK.

Nothing is guaranteed, which is why I would strongly recommend that you at least test it out with a speaker where you would locate a Boost - if that helps, then a Boost will too. Just be sure to keep either 1m away from any sources of interference (like your router or Sky Q box).

Reply