Question

Music will only play in the first zone added to a group - New development since power outage


Music will only play in the first zone added to a group. The other zones in the group appear in the group but they have no sound. We have had this Sonos system for 9 years and this i s anew development Has never happened before. The zones are not "muted." We have tried resetting, using various controllers, starting "fresh" with groups, etc. This seems to have happened following the power outage in SB on Saturday night. How do we fix this?

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

10 replies

Since you mention a power outage the likelihood is that you have duplicated IP addresses. The router will have lost its IP lease info across the reboot, but battery devices (phones etc) may not. As a result the Sonos units could well have been given an IP which is already in use, since the router has forgotten what went before and knows no better.

Restart all the devices on your network to ensure that everything gets a new, unique IP address. If you want you could try simply restarting all the battery powered wireless devices and see if that fixes things. Otherwise do a full restart of everything.

If power outages are a regular event I would recommend you reserve fixed IP addresses in your router configuration, to prevent a recurrence.
Thank you. We have already done a complete system restart, including all of our wireless devices. It did not fix the issue. Could anything else be causing this?
If this has been going on since Saturday, under normal circumstances the router would have refreshed all the IP addresses by now.

Does it matter which zone you start from, before adding the others? If you have a wired player in the group it's almost always best to start from that, then add the rest.

Can you play on each of the players individually, i.e. ungrouped?
It doesn't matter which zone we start with. Each zone will play individually/ungrouped. All of our players are Connect or Connect:Amps. We do not have any Play, etc. This is so strange. We have never had anything like this happen before. We are stumped.
Well, they're probably ZP80s and ZP100s if they're 9 years old, but that's not very relevant. Presumably at least one is wired to the network, so have you tried changing the SonosNet channel?
Yes, they are 80s and 100s. We had not tried changing the SonosNet channel. I just tried that. No luck. The sound still only plays in the first zone in the group. When I set up a group with only two or more zones in it, the sound plays in the first zone only. If I drop the first zone from the group, only then does the sound begin playing in the remaining zones. It doesn't seem to matter which zone I start with. It happens with all.
There's potentially more to this, and the system diagnostic might provide crucial information. Submit one and post the number for Sonos Support to pick up,

A final thought on the network topology, is there a BRIDGE or have you wired one or more ZPs?
Thanks. I will do that.
No, we do not have a bridge and we have not wired one or more ZP's.
Thank you for your help. Much appreciated.
Well you must have at least one ZP wired to the network, otherwise you wouldn't have a SonosNet wireless mesh.

Anyway, I just thought I'd ask about a BRIDGE. An age-related failure mode is for its power supply to lose output, creating various connectivity issues.
Ha ha. Yes, obviously. None wired beyond the first, required for functionality...