Answered

Music stops randomly on my Play 5

  • 7 February 2021
  • 5 replies
  • 64 views

Hi Support.

 

My Play5 music stops randomly when playing Spotify, after few minutes of play. Seems to be a recent problem. It is basically unusable.

This happens with the Android App (both Sonos App or Spotify app playing on Sonos).

This is the only Sonos in my network, connected via Wifi.

 

Diagnostic #1854636778.

Your help is greatly appreciated.

 

Thanks

 

icon

Best answer by Corry P 3 March 2021, 15:16

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies

Userlevel 7
Badge +18

Hi @dancri 

Welcome to the Sonos Community!

Thanks for your post, and your diagnostic. Are you still having this problem?

The error messages being produced - “Login user change while in progress" - immediately before a Lost Connection message made me think of @GuitarSuperstar’s suggestion of removing the service and adding it again. As you’ve already tried that, and it didn’t help, my next thought was to address the fact that you have a Asus router.

Please try the steps outlined in these two posts on other topics (depending on your router model, they may not be options that are available):

The first is for disabling AirTime Fairness, which has been found to cause problems for Sonos (on Asus routers).

The second is to prevent the router from blocking access to devices, like Sonos speakers.

In addition, we’ve had reports that Asus routers need to undergo a factory reset after updating their firmware (the update may be automatic, so you may not know it happened). If the above steps fail, please try a reset of your router - you’ll need to consult your manual or Asus Support for how to do this.

Tried that also just now. Spotify played for 10 minutes then got again the connection lost. Trying now to play the songs on Sonos from my mobile device filesystem to see if the problem is only related to Spotify.

Userlevel 7

How about unplugging your Play:5 for about a minute?

Or try this:

In the Sonos app, go to Settings > App Preferences and tap Reset App. Then close and reopen the app.

 

Yes, I have tried all those actions, same problem - Connection to Spotify was lost. Thanks for your response.

Userlevel 7

Have you tried removing Spotify from your music services in the Sonos app and re-adding it? You could also try restarting your phone and rebooting your router.