Music cuts out/jumps to next tracks



Show first post

238 replies

I am also having this problem with my brand new Play 1, streaming music from my NAS.  Tried changing the channel from 11 to 1 but problem persists.

Wondering if I need to move my bridge to somewhere else in the house, but not even sure if this problem is related to signal.  Any help would be appreciated.

Just submitted diagnostics: 3355132

Thanks Alun


Thanks Ryan, I have wired one of my wireless cameras and changed to Channel 6, so far only had the issue once in over 3 hours of playing, which is a huge improvement.  I have sent another diagnostic (3372741) please could you let me kno if you are still seeing interference on the bridge?
Userlevel 5
Badge +2
Have been experiencing the same since upgrading to newest SW. Today I submitted a diagnostics report within minutes after it happened on one of my ZP120's: Confirmation number 3339932.

Setup: 2 ZP 90's (one acting as bridge), 2 ZP120's, 1 ZP80, a Play:3 and 5 WD100's. The only wired unit is the ZP90 acting as bridge.

I have experienced the issue across both ZP120's and ZP90's - and both when listening to streaming services (TDC Play) and directly from my NAS.

I wonder if Ryan is still monitoring this thread? I hope so...

BR,

-- 
Jakob

I'm glad to hear everything is up and running properly, Jakob. We're glad to accept any and all feedback about our support. If you'd like to send some feedback, please send an email to custservmgmt@sonos.com.

Thanks very much and let us know if you have any additional questions or concerns, we're happy to help.
Userlevel 5
Badge +2
I am also having this problem with my brand new Play 1, streaming music from my NAS.  Tried changing the channel from 11 to 1 but problem persists.

Wondering if I need to move my bridge to somewhere else in the house, but not even sure if this problem is related to signal.  Any help would be appreciated.

Just submitted diagnostics: 3355132

Thanks Alun


Thanks Alun, the BRIDGE is looking leaps and bounds better than before. There's very minimal interference around it now, which allows for much smoother communication. I'd recommend keeping it in this configuration.
Userlevel 5
Badge +2
For some reason I can't find my original comment but Ryan wrote me the following and I wanted to respond: Hi Kelly, is your phone far away from the router when this happens? I'd suggest playing some music with the phone right nearby the router (for maximum signal strength) and see if the skips still occur.

Let me know what the results are and we can continue from there.

Results: So we have two routers in our house, I have tried this using both routers and get the same behavior (although I admit it isn't as consistent connected to the main one, may make the whole way through the song, half way through the song or almost to the end of the song before skipping.  Usually my phone is in the kitchen and the wi-fi extender router is in the next room at the edge.  I've tried doing it from that room right next to it as you suggested, same issue.  My husband's Android phone has no issues playing songs from his phone. My kids iPod touch's have no issues playing songs from their devices.  It's only my iPhone 5 that has issues playing music directly from my phone (no issues playing from our hard drive).  When we first got the sonos system in December I had no issues, I feel there must have been a update to the app, or maybe an iPhone update that changed this cause I can't think of anything else.  

I'd recommend following Pete's suggestion. Try telling your iPhone to forget the WiFi extender's network and have it just connect to the router at all times. See if the behavior improves. If it doesn't, try forgetting the primary network and have the phone only connect to the extender. Let me know how it goes.
Userlevel 5
Badge +2
Also having the same problem. 
Hi Jordan, it looks like the MacBook Pro is connecting to the network via WiFi. The Sonos system looks great on the diagnostic report, so I'd first like to see if Sonos is having trouble connecting with just that Mac over the router's WiFi. Try wiring the MacBook directly to the router with an Ethernet cable and disable the wireless temporarily. While the MacBook is wired in, play some music from the Music Library on Sonos and see if the cutouts continue. Let me know what the results are.

Thanks.
Userlevel 5
Badge +2
I too am experiencing music cutting out and tracks skipping before completion on both my music library (stored on s Firewire Drobo connected to a FW800 port on an ethernet connected MacMini).  Music also cuts out from two Line-In sources (Satellite receivers connected to the line in of two different zone players), Tune-In Radio, And SiriusXM also cut out without warning for no reason. I Have a Play5 (root bridge) connected directly via ethernet to my Apple Time Capsule router, and a few other Zones (ZP80's, ZP90) that are connected via ethernet to switches). With a Playbar, Subwoofer, two newer remotes, two older remotes, all told a total of 14 zones, I'm experiencing music cutouts from the line in source on my router-connected Play 5. Music even cuts out on the Play 5 itself (how can that be?) 
I am a die-hard Sonos user since inception, and I've never seen such issues before as I have these past couple months. I changed to a newer Apple 802.11AC router, changed the wireless channel multiple times, changed the root zone, moved zones, wired previously wireless zones, etc, to no avail. Zones disappear randomly and don't re-appear till I unplug and re-plug to the point I'm assigning and reserving IP addresses for the affected wireless zones. I'm at wits end. I've invested over $6k on this system and I'm not happy, especially since I spent $2k this past Fall for a Playbar, subwoofer, and two Play 1's.
My diagnostic confirmation number is 3372332.

Hi there Hassen,

We'd be happy to help get to the bottom of the audio dropouts on your system. It sounds like you've already taken a number of good steps to try to narrow down the issue (channel changes, etc). Due to the size of the system and topology of the network, I'd like to have you work with one of our technicians over the phone. I'm going to get a ticket set up for you under 140124-001453 with notes on the steps you've taken so far. When you're next available, please give us a call on our support phone line and provide the ticket number to your technician. We can continue diagnosing the system from there. Our contact information and hours of availability can be found on this page.

Thanks.
Userlevel 5
Badge +2
Same issue here with my brand new play 3. Playing songs from my iPhone library playlist. Within about 30 seconds, the system advances to the next song. This is quite an expensive speaker to have such an obvious and common glitch.
Mark, I'd like you to speak with one of our technicians over the phone so we can help get to the bottom of the issue. I've made a ticket for you under 140124-001486. When you're next available, please give us a call on our support phone line. Our contact information and hours of availability can be found here.

Thanks.
Userlevel 5
Badge +2
Same issue here with my brand new play 3. Playing songs from my iPhone library playlist. Within about 30 seconds, the system advances to the next song. This is quite an expensive speaker to have such an obvious and common glitch.
Mark, I'd like you to speak with one of our technicians over the phone so we can help get to the bottom of the issue. I've made a ticket for you under 140124-001486. When you're next available, please give us a call on our support phone line. Our contact information and hours of availability can be found here.

Thanks.
I have had this same problem too.  My PLAY3 worked wonderfully for month and a half.  Now I can't get through a song from iTunes on my iPhone without it cutting out or skipping to the next track.  I have tried setting the router to Channel 11 and the Sonos to Channel 1, but that did not work.

I was all set to purchase a house-wide system.  If I can't get this fixed very soon, I will return the device and go another route.  Please help.  My diagnostic report number taken right after the cut out is 3404288.

I have had this same problem too.  My PLAY3 worked wonderfully for month and a half.  Now I can't get through a song from iTunes on my iPhone without it cutting out or skipping to the next track.  I have tried setting the router to Channel 11 and the Sonos to Channel 1, but that did not work.

I was all set to purchase a house-wide system.  If I can't get this fixed very soon, I will return the device and go another route.  Please help.  My diagnostic report number taken right after the cut out is 3404288.



Also forgot to add that I have zero problems streaming via Sirius or Pandora.  This only happens when trying to play music from my phone.
As most of the other users on this thread have commented, I am having the same issue where songs cut off before they're supposed to. This is only happening with music I am streaming from my iPhone. I actually do not use my computer to stream, just from my iPhone, Internet Radio, and Songza.

Before each song cuts off, I get an error message that reads "Unable to play <song> - the connection to your iPhone was lost." Attached to this reply is a screenshot of the error message. I have tried both not using my wireless network for anything else and running Netflix simultaneously. Sonos will cut off songs regardless, and I know it is not my wireless network. It is at full connectivity.

I had a playlist of 25 songs from my iPhone that I tested to see how many songs would cut in the middle. All of them. This has only happened in the past little while after a Sonos update to version 4.2.

This makes my Sonos unusable. How am I supposed to use it when basic functionality is not even guaranteed. I too have really enjoyed my Play 3 up until this point but am very frustrated at the sudden crashing and skipping.

I would truly appreciate your assistance and provide a resolution to this problem.

Thank you.
every having this same issue, lucky if I get one complete track in ten from any album or playlist. I have Playbar in the lounge and Play:3 in the master bedroom, both streaming music from a wireless nas drive. Recently bought 2 Play:1's to create a surround system in the lounge, now thinking of returning these if the drop out issue cannot be resolved. Although that said, not having any issues with the audio coming directly from the TV. The whole point of investing in the Sonos kit was to create a seamless music streaming system throughout the house which was simple to add to as indicated in all your advertising. Instead I'm now finding I'm getting more and more frustrated every time I try to listen to any music of my own choosing. At the moment it's begginging act like a very expensive radio! Please help.
every having this same issue, lucky if I get one complete track in ten from any album or playlist. I have Playbar in the lounge and Play:3 in the master bedroom, both streaming music from a wireless nas drive. Recently bought 2 Play:1's to create a surround system in the lounge, now thinking of returning these if the drop out issue cannot be resolved. Although that said, not having any issues with the audio coming directly from the TV. The whole point of investing in the Sonos kit was to create a seamless music streaming system throughout the house which was simple to add to as indicated in all your advertising. Instead I'm now finding I'm getting more and more frustrated every time I try to listen to any music of my own choosing. At the moment it's begginging act like a very expensive radio! Please help.
*I'm* not 'every' at the beginning of the first sentence. Diagnostic report No. : 3407371
i have the same problem..but only with upstairs. using NAS to stream

I have had this same problem too.  My PLAY3 worked wonderfully for month and a half.  Now I can't get through a song from iTunes on my iPhone without it cutting out or skipping to the next track.  I have tried setting the router to Channel 11 and the Sonos to Channel 1, but that did not work.

I was all set to purchase a house-wide system.  If I can't get this fixed very soon, I will return the device and go another route.  Please help.  My diagnostic report number taken right after the cut out is 3404288.


I've tried calling an can't get a hold of an agent.  I have also moved the location of the bridge, but the problem still exists.  I submitted an additional diagnostic report today when it happened again with the bridge in a new place rooms away from the router.  The diagnostic report number is 3404288.

I have had this same problem too.  My PLAY3 worked wonderfully for month and a half.  Now I can't get through a song from iTunes on my iPhone without it cutting out or skipping to the next track.  I have tried setting the router to Channel 11 and the Sonos to Channel 1, but that did not work.

I was all set to purchase a house-wide system.  If I can't get this fixed very soon, I will return the device and go another route.  Please help.  My diagnostic report number taken right after the cut out is 3404288.


Finally got a hold of a rep, Jason C., through the call back feature.  Very customer friendly.  Tried a few different things.  Still haven't got it all the way worked out, but I appreciate the dedication to the effort and look forward to testing out some new things and hopefully getting it completely worked out.  Thanks Sonos.
Hello,

I am having the same problem.  Would you be able to look at a diagnostics report for me?  I have had my Play 3 for over a year, and this issue just started recently
Userlevel 5
Badge +2

I have had this same problem too.  My PLAY3 worked wonderfully for month and a half.  Now I can't get through a song from iTunes on my iPhone without it cutting out or skipping to the next track.  I have tried setting the router to Channel 11 and the Sonos to Channel 1, but that did not work.

I was all set to purchase a house-wide system.  If I can't get this fixed very soon, I will return the device and go another route.  Please help.  My diagnostic report number taken right after the cut out is 3404288.


Thank you for the updates, Milan. I'm glad you were able to get Sonos working with Jason over the phone. We Made further changes to the Sonos wireless and helped verify that the phone was not losing information when communicating with the router.

If you encounter any further drops, please let Jason know via email and we can continue.

Thanks.
Userlevel 5
Badge +2
As most of the other users on this thread have commented, I am having the same issue where songs cut off before they're supposed to. This is only happening with music I am streaming from my iPhone. I actually do not use my computer to stream, just from my iPhone, Internet Radio, and Songza.

Before each song cuts off, I get an error message that reads "Unable to play <song> - the connection to your iPhone was lost." Attached to this reply is a screenshot of the error message. I have tried both not using my wireless network for anything else and running Netflix simultaneously. Sonos will cut off songs regardless, and I know it is not my wireless network. It is at full connectivity.

I had a playlist of 25 songs from my iPhone that I tested to see how many songs would cut in the middle. All of them. This has only happened in the past little while after a Sonos update to version 4.2.

This makes my Sonos unusable. How am I supposed to use it when basic functionality is not even guaranteed. I too have really enjoyed my Play 3 up until this point but am very frustrated at the sudden crashing and skipping.

I would truly appreciate your assistance and provide a resolution to this problem.

Thank you.


Hi there Garby,

I'd first like to take a look at a diagnostic from the system to make sure that the communication between your Sonos units looks okay. Since you're able to play from other music sources without issue, I don't believe that the signal between the Sonos units is being interfered with, but I'd like to be sure. Here's how to send a diagnostic, just let me know what the confirmation number is when you receive one.

Dropouts like this are usually caused from information being lost between the phone and the router when trying to stream to Sonos. In cases like this, I recommend changing the wireless channel on the router itself to avoid any interference from outside sources. If you let me know what the make and model of your router is, I can provide or direct you to the steps on how to do so.

Please let me know if you have any wireless access points or secondary routers on the network as well.
Userlevel 5
Badge +2
every having this same issue, lucky if I get one complete track in ten from any album or playlist. I have Playbar in the lounge and Play:3 in the master bedroom, both streaming music from a wireless nas drive. Recently bought 2 Play:1's to create a surround system in the lounge, now thinking of returning these if the drop out issue cannot be resolved. Although that said, not having any issues with the audio coming directly from the TV. The whole point of investing in the Sonos kit was to create a seamless music streaming system throughout the house which was simple to add to as indicated in all your advertising. Instead I'm now finding I'm getting more and more frustrated every time I try to listen to any music of my own choosing. At the moment it's begginging act like a very expensive radio! Please help.
Hi there,

If your NAS is connecting to the network via WiFi, can you temporarily wire it directly to the network and see if this helps with the cutout issue on Sonos? I'd like to eliminate the possibility of information being lost over the wireless connection between the NAS and the router.

If you still experience a dropout, please send a diagnostic report right after you hear the cutout. Your current diagnostic shows that your Sonos units have an excellent connection to each other, which is great.

Thanks.
Userlevel 5
Badge +2
i have the same problem..but only with upstairs. using NAS to stream
Hi there, mind sending a diagnostic report right after a cutout? I can check the logs from your system and see if there's anything causing the cutouts on the Sonos side of things. Here are the instructions on how to send a report, just let me know what the number is when you get it.

Thanks.
Userlevel 5
Badge +2
Hello,

I am having the same problem.  Would you be able to look at a diagnostics report for me?  I have had my Play 3 for over a year, and this issue just started recently

Hi Mike, I'd be glad to look at diagnostics from your system. Sending one right after a cutout is best since it will capture the state of the system at the time it's having the problem. Here are the instructions on how to send one, just include the confirmation number in your reply.

In addition to the diagnostic, please let me know what music you're playing when the system drops out and how often it occurs. Is it only that music source, or does it happen with any music you try to play on Sonos?

Thanks.
I just started using the system tonight and have already had the problem twice (where music skips to the next track before a song ends). I submitted my diagnostics and the number is 3338378. Seems to be a very common problem from what I've seen online. Very frustrating one, as well.
I'm experiencing the same issue as well with music on my iPhone. Streamed musicr from Songza seems to work. Diagnostic report is 3428253.
Posting again as I mistakenly put as a comment to someone else's: I'm having the same problem as well. Music skips when playing from my iPhone. Seems to work from streaming sources such as Songza. Diagnostic report No. is 3428253.
Same problem. Report: 3428537

Reply