Music cuts out/jumps to next tracks


Userlevel 1
Music from my library cuts out and other times, jumps to next track. As many others have reported, this has never happened... only after I upgraded to 4.1. And no, it has nothing to do with my wi-fi connection (or my computer's connection to/signal from my wi-fi router to/from my controllers. It happens even when I have full signal and full functionality/connection from my controller (Macbook Pro or iPhone) for all other uses (surfing the Internet, sending/receiving email, etc.) and no glitches or downtime occurring with any of the other 10 Internet connected devices in my house. Also, yes (even in the face of my wi-fi router obviously functioning fully), I still took the time to pull the power on it for >30 secs... on several occasions, and to no affect.

234 replies

Userlevel 5
Badge +2
Hello,

Where is your music library located? Is Sonos streaming the library off of your MacBook Pro or off of another computer / Network Attached Storage device?

Has Sonos dropped out when playing from any other sources, like Internet Radio?

I'd like to see a diagnostic report from your Sonos system right after a cutout occurs. Please follow the instructions here in order to submit a report, then let me know what the confirmation number is and I'll have a look.

Thanks.
Userlevel 1
I'm having the same issues and have tried everything listed on the forums to try and resolve the issue. I loved the system, but I'm nearing the end of my patience. How do I get a refund if this isn't corrected? Sonos your reputation is on the line. I spent over 4k on my home system and it worked without fail for months. Now the skipping!!! 3165110 is my diagnostic report. Please contact me
Userlevel 5
Badge +2
I'm having the same issues and have tried everything listed on the forums to try and resolve the issue. I loved the system, but I'm nearing the end of my patience. How do I get a refund if this isn't corrected? Sonos your reputation is on the line. I spent over 4k on my home system and it worked without fail for months. Now the skipping!!! 3165110 is my diagnostic report. Please contact me
Hi there Tracy, are you experiencing this issue on all of your components or just particular ones? I'd also like to know if the tracks are skipping only when playing from a particular source like Spotify or if it happens with all sources. Since you have PLAYBARs, are you experiencing any skips when watching TV or is Sonos functioning properly in that regard? Thanks.
Userlevel 1
I'm having the same issues and have tried everything listed on the forums to try and resolve the issue. I loved the system, but I'm nearing the end of my patience. How do I get a refund if this isn't corrected? Sonos your reputation is on the line. I spent over 4k on my home system and it worked without fail for months. Now the skipping!!! 3165110 is my diagnostic report. Please contact me
All components and it I only use Spotify and the playbars for TV. No issues with TV just Spotify.
Userlevel 5
Badge +2
I'm having the same issues and have tried everything listed on the forums to try and resolve the issue. I loved the system, but I'm nearing the end of my patience. How do I get a refund if this isn't corrected? Sonos your reputation is on the line. I spent over 4k on my home system and it worked without fail for months. Now the skipping!!! 3165110 is my diagnostic report. Please contact me
Thanks Tracy, I just opened a support ticket under 130917-000876 and sent an email with some instructions based on information I found in the diagnostic report. Please follow the included steps and let's keep in contact via email to resolve the problem.
Having same problem. Cuts out 3 quarters way through a track and immediately starts next... so doesn't sound like it's a streaming capacity/bandwidth issue. Would appreciate help. This makes my Sonos unusable
Userlevel 5
Badge +2
Having same problem. Cuts out 3 quarters way through a track and immediately starts next... so doesn't sound like it's a streaming capacity/bandwidth issue. Would appreciate help. This makes my Sonos unusable
Hi there, Are you experiencing this problem with your music library or from an Internet-based service (or both)? If you don't mind, I'd like you to submit a diagnostic report within 15 minutes of the drop. Please follow the steps in this FAQ and let me know what your diagnostic confirmation number is and I'll have a look. Thanks.
New Sonos customer (as of today). Exact same issue. From the above comments looks like it's time to return my $700(!) Playbar and go back to streaming music to my $100 bluetooth speaker.
Having same problem. Cuts out 3 quarters way through a track and immediately starts next... so doesn't sound like it's a streaming capacity/bandwidth issue. Would appreciate help. This makes my Sonos unusable
as per private message, music library only, diagnostic report submitted. Issue still arising on almost a constant basis. I hope you can identify a fix otherwise I will need to return as faulty goods
Userlevel 1
Give them a chance. Their customer service contacted me next day and gave me a URL to use that fixed it. It was a really easy fix. Sonos is awesome. I'm hopeful I'll never need help again. But I give them credit for the quick response and easy fix.
Userlevel 5
Badge +2
New Sonos customer (as of today). Exact same issue. From the above comments looks like it's time to return my $700(!) Playbar and go back to streaming music to my $100 bluetooth speaker.
Hi there, Dropouts when playing music can be caused by a few things (interference with the wireless signal, etc) but we can certainly help narrow down the cause. Would you mind submitting a diagnostic report the next time the system drops out? I can take a look at the logs from Sonos to figure out what may be causing the problem. You can find instructions on how to send a diagnostic report in this FAQ. Once you have a confirmation number, let me know what it is and I'll have a look. Thanks.
Userlevel 5
Badge +2
Having same problem. Cuts out 3 quarters way through a track and immediately starts next... so doesn't sound like it's a streaming capacity/bandwidth issue. Would appreciate help. This makes my Sonos unusable
Thanks, I was able to take a look at your diagnostic report. The wireless signal between your two Sonos units looks great. I'm not seeing evidence of interference that corresponds with the dropouts. I would like to perform a test with Sonos and your computer here. The messages I see regarding the playback errors relate to Sonos trying to access the shared folder on the computer, but being unable to complete the connection. I'd like to see if a wired connection between Sonos and the computer affects this. This will help us narrow down where the problem is occurring. Temporarily wire the PLAY:5 to your computer using an Ethernet cable, then disable the WiFi on the computer. This will provide a direct, wired connection between the Sonos player and its music host. The computer will also be able to access your home network and Internet through the wireless SonosNet in this configuration. Try to play some tracks from the library and let me know if the music still cuts out. Thanks.
I have the same issue. Tracks cutout halfway through all songs. I've tried three albums so far via Spotify. I hadn't had this particular problem before and have had my system for about 10 months, but I recently upgraded the software per the Sonos recommendation and that's when the problems started. I ran the recommended diagnostic per the above instruction. My diagnostic number is 3211622.
Userlevel 5
Badge +2
I have the same issue. Tracks cutout halfway through all songs. I've tried three albums so far via Spotify. I hadn't had this particular problem before and have had my system for about 10 months, but I recently upgraded the software per the Sonos recommendation and that's when the problems started. I ran the recommended diagnostic per the above instruction. My diagnostic number is 3211622.
Hello, thank you for the diagnostic report. I have some steps you can take in order to resolve this issue. I'll open a support ticket for you under 131022-001217 and send an email. Let's keep in touch through that channel and we can work to get your issue resolved. Thanks.
I have same problem. You have not responded to my entry (title "software update trashed system"...includes diagnostic report number). System was stable for months, and went horribly unstable after I updated. Runs intermittently now, crashes all the time. I want to revert firmware versions, or I want a complete refund on all components (2* connect-amp, 1* connect, 1* bridge, 2* play-5). Can't you guys act like professionals?
I have the same issue. Tracks cutout halfway through all songs. I've tried three albums so far via Spotify. I hadn't had this particular problem before and have had my system for about 10 months, but I recently upgraded the software per the Sonos recommendation and that's when the problems started. I ran the recommended diagnostic per the above instruction. My diagnostic number is 3211622.
Hi Ryan, Got you're e-mail, thanks. I clicked the link provided and saw the "settings changed" in my browser, then tried a few albums and the skipping issue seemed to be resolved. HOWEVER... This morning at about 7:04a.m. my wife and I were awoken to a spontaneous rendition of American Jesus by Bad Religion. I thought perhaps I inadvertently hit an alarm setting on the Sonos app, so I got up and stopped the music and went back to sleep. About 4 minutes later, the music started again. Angrily, I got up stopped the music and exited out of the app, then went back to bed. A few minutes later, you guessed it, the music came back on a third time. When I went to access the app stop the music on my phone, I just got the 'Searching for Sonos Components' blue screen of pain. So I used my wife's phone to 'clear the queue', which stopped the music. In case you're wondering I did not go back to bed after that. Thank God we didn't have house guests!!! After it occurred to me, I ran the diagnostic a few minutes later, so here's the diagnostic number: 3212374. Please help fix this issue. Have an A-1 day Sonos!
I have the same issue. Tracks cutout halfway through all songs. I've tried three albums so far via Spotify. I hadn't had this particular problem before and have had my system for about 10 months, but I recently upgraded the software per the Sonos recommendation and that's when the problems started. I ran the recommended diagnostic per the above instruction. My diagnostic number is 3211622.
Just to provide an update for the public record; the skipping issue resurfaced and now it seems to jump to the middle of the next track. I provided a diagnostic number via e-mail. For those keeping score at home, I now have the skipping issue and the spontaneous music starting issue. Please help!
Userlevel 5
Badge +2
I have same problem. You have not responded to my entry (title "software update trashed system"...includes diagnostic report number). System was stable for months, and went horribly unstable after I updated. Runs intermittently now, crashes all the time. I want to revert firmware versions, or I want a complete refund on all components (2* connect-amp, 1* connect, 1* bridge, 2* play-5). Can't you guys act like professionals?
Hi there jcasey, Based on the information in your posts, I'd like to get you in touch with one of our support technicians so we can help out. I've opened a ticket for you under 131023-000673 and sent an email. Let's keep in touch there so we can get you in contact with a tech over the phone in order to resolve the problem. Thanks.
I have the same issue. Tracks cutout halfway through all songs. I've tried three albums so far via Spotify. I hadn't had this particular problem before and have had my system for about 10 months, but I recently upgraded the software per the Sonos recommendation and that's when the problems started. I ran the recommended diagnostic per the above instruction. My diagnostic number is 3211622.
My system is now unusable!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! Another update for the public record; I replied to your request for information about my system on the same day, but haven't received acknowledgment that you received the info. To be clear, my settings tell me I have Version 4.2 (build 24069180; AssociatedZP 10.0.0.2), Connect:Amp, Version 4.2 (build 24069180), Hardware version: 1.163.1-1. Here's a summary of what I've already provided to you: My Connect:Amp is wired directly to my router (the router is an ARRIS, model: TG862G/CT). On the back of my SONOS Connect:Amp, it just says "model: Connect:Amp" and doesn't appear to have a specific model number, however, it's white/silver and is maybe 7X7X3 inches if that helps. The ethernet cable between the two is plugged into the right ethernet port (when looking at it from the back) on the Connect:Amp. One the router side the ethernet cable is plugged into Ethernet Port 1. There is no other piece of networking equipment between the router and the amp. Right now the skipping issue appears to be only with Spotify. I'm playing an album right now from my music library and am four songs in and it hasn't skipped yet. However, I have had an issue listening to radio stations. The radio station will play for about 8 minutes, then I'll hear a skip like it's going to cut out, and then a few minutes later it will cut out completely and I have to hit the play button on the app to start playing the radio again. You'd think the system would just keep trying to play the radio station, since I never hit stop. It's like the system intentionally stops playing the radio station (or thinks I pressed stop). ************* So I now have 2 persistent issues, and 1 seemingly random issue: 1.) Persistent: SONOS cuts off music played via spotify and skips to next track; 2.) Persistent: Radio stations typically cut off after about 4 minutes (... yup, just cut out again for the 50th time); 3.) Random: SONOS spontaneously turns itself on unprompted. Is there any estimate of when a fix will be out or can you make the previous build, which was much more stable, available? My system is virtually unusable.
I have same problem. You have not responded to my entry (title "software update trashed system"...includes diagnostic report number). System was stable for months, and went horribly unstable after I updated. Runs intermittently now, crashes all the time. I want to revert firmware versions, or I want a complete refund on all components (2* connect-amp, 1* connect, 1* bridge, 2* play-5). Can't you guys act like professionals?
I concur with jcasey and would also like to revert to previous firmware versions or receive a refund. This is ridiculous! My system is unusable and customer service has been zero help despite my willingness to work for them as a test facility for their own equipment!
Userlevel 5
Badge +2
I have the same issue. Tracks cutout halfway through all songs. I've tried three albums so far via Spotify. I hadn't had this particular problem before and have had my system for about 10 months, but I recently upgraded the software per the Sonos recommendation and that's when the problems started. I ran the recommended diagnostic per the above instruction. My diagnostic number is 3211622.
Hello, I've sent a response to your email regarding the next steps I'd like to take. Since your local library plays fine while Spotify and Internet Radio are not, I'd like to have you work with a technician in order to narrow down the source of the problem. Let's keep in touch via email. Thanks.
Having the exact same Problem. The system was stable up to several weeks ago. Songs skip on paid lastfm and deezer accounts. System reset, moving components, new ethernet cable, changing channels. Did it all as suggested in different threads, still to no avail. Streaming radio via tunein doesn't stall or skip interestingly. Its a shame, cause sonos is a great system! Any ideas? Diagnostics number: 3217853.
Userlevel 5
Badge +2
Having the exact same Problem. The system was stable up to several weeks ago. Songs skip on paid lastfm and deezer accounts. System reset, moving components, new ethernet cable, changing channels. Did it all as suggested in different threads, still to no avail. Streaming radio via tunein doesn't stall or skip interestingly. Its a shame, cause sonos is a great system! Any ideas? Diagnostics number: 3217853.
Hi Mike,

Was the Kitchen PLAY:3 ever the primary wired Sonos component in your system? Right now it looks like Bedroom is, but Kitchen is still acting as the Root Bridge for the system (even though it's wireless). We can help change this to make the Sonos communication a bit more streamlined and organized if necessary; first, can you try swapping the Bedroom and Kitchen PLAY:3s temporarily to see if the organization change helps the dropout issue?

If it doesn't, please grab one more diagnostic report and I'll take a look at the updated layout.

Thanks.
Having the exact same Problem. The system was stable up to several weeks ago. Songs skip on paid lastfm and deezer accounts. System reset, moving components, new ethernet cable, changing channels. Did it all as suggested in different threads, still to no avail. Streaming radio via tunein doesn't stall or skip interestingly. Its a shame, cause sonos is a great system! Any ideas? Diagnostics number: 3217853.
Thanks for the quick reply.  You guys really have a great customer service (even if the product isn't quite working right now 🙂!!  Since I expanded the system over time, the Kitchen Play 3 may have originally been the root bridge, I have no idea anymore.   I'm reluctant to switch the two units, since the one in the kitchen has gotten quite dirty in there and I don't want to get the clean one in the bedroom all dirtied up.   Plus its one of the stereo pairs (L) in the living room thats the root bridge.  Here another diagnostic.   3223089
Thanks.
Userlevel 5
Badge +2
Having the exact same Problem. The system was stable up to several weeks ago. Songs skip on paid lastfm and deezer accounts. System reset, moving components, new ethernet cable, changing channels. Did it all as suggested in different threads, still to no avail. Streaming radio via tunein doesn't stall or skip interestingly. Its a shame, cause sonos is a great system! Any ideas? Diagnostics number: 3217853.
Thanks Mike. I opened up a support ticket for you under 131031-001332 and sent an email with some specific instructions on how to change the root bridge on your system. Let's keep in contact via email to make sure the change goes through properly.

Thanks.

Reply