Question

Moved to new house. Set up new network. Nothing works. Uber frustrated.


Badge +1

I have 17 Sonos speakers and I recently moved.  I set up a new Wifi network at my new house (new modem, now router).  I can’t get anything to connect.  I follow all the prompts both wirelessly and directly wired to the router.  It’s just running me in circles.  Has been for DAYS!  I’ve tried with and without my Sonos Boost.  At least with the Boost it seems to find something it likes because I can at least access my account, but I still can’t get any of my speakers to connect.  I have 2 new Songs Arcs due to be delivered next week and I can’t get a single existing speaker to connect. 

I have the new Orbi Wifi 6 mesh system and I’m getting 950 maps of download speed.  All three different Play1 speakers that I’ve tried to connect are right next to the router.  

After a couple of days of this I was able to finally get the app to see one of the Play1s, but I can’t get it to connect to my new wifi - it keeps telling me that I’m entering the wrong password for my network - and I’m not.  I’m 100% certain of that.  Then I try an alternative setup from there and it tells me that I will have to permanently wire that speaker to the router.  

Sonos has gone from my single favorite bit of tech in my life to the single worst.  I absolutely love these products, but I’m beyond frustrated.  I know what I’m doing.  I’ve set up all my speaker in the past.  I’ve moved them.  I’ve paired them in different configurations.  But this has been awful.  Please help. 


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

35 replies

Hi. Is the Orbi the full story or is another router involved?

Do I understand that you do currently have a Play:1 wired that you can see and control with your app?

In Settings, System, Network, Wireless Setup, do you have wireless details entered?

Badge +1

The new Orbi is the only router.  I was on an older Orbi before but moved into larger house so went with the new Orbi.  

I do not have any speakers working - wired or wireless.  

In Settings, System, “Wireless Setup” is greyed out.  I can’t get beyond System …. and I keep getting kicked out of Settings (Account and Systems keep greying out, then black (and clickable), then grey again. 

in your old network what Sonos version were you on? Had everything been upgraded to S2?

Badge +1

My Songs App is Version 12.0.3.  My Songs OS is S2.  I’m 99% sure everything was upgraded to S2.  Here’s a bit of info that may/may not help.  I packed up everything on June 1 and put it in storage for 2 months.  I kept 3 Play1s out to set up 2 in a second home and 1 in a temporary office that I used between 6/1 and 8/1.  I was able to connect those Play 1s on new networks at the office for example, and I’ve tried to connect both speakers that were in storage and speakers that i used while everything else was in storage, and I get nothing.  Can you remind me when S2 came out?  Maybe there is something to that given the timeline above.  

Badge +1

But either way, I have tried to connect speakers that I was using last week and I can’t get them to work. 

I can't remember exactly, but greyed out bits in app often indicate incompatible versions. And some upgrades to S2 have gone awry when not rigorously carried out. 

Could you try wiring one of the P1s that you kept out.. Power everything else off.  Uninstall the Sonos S2 app then reinstall it. Do you get an option to connect to existing system? If you do, take it.

Then do a check for updates. 

Badge +1

Yes.  I’ll do all of that and check back in a bit.  Thanks very much for the help.  

Badge +1

Wired speaker I used last week to router and reinstalled Sonos app.  Accepted terms of use.  Songs app then appears to have frozen.  I just have the gold background with the Sonos logo and no options or anything.  Nothing to swipe.  Nothing to click.  Been staring at it for probably 5 minutes.  

Badge +1

Force closed the app and it then opened.  Account, Settings and Services & Voice are all grey under Settings.  

Badge +1

ok … it finally prompted me to sign in so i did.  And then I went through the install sequence with that Play 1 that I used last week … and it worked!  Can I unplug it from the Router now? 

Badge +1

Well …………. I unplugged it from the router and went to tune it .. got, “Speaker Problem.  There was a problem communicating with your speaker.  Please try again.”

Badge +1

And it appears that all my stations are gone now too.  

The only other things I can think of are try a different mobile device if you have one and try the S1 app. Otherwise I think it is a call to Sonos Support. 

Badge +1

FOR SALE:
6x Play1

4x Play3

2x Play5

2x Subs

1x Beam

2x Arc (new in box) 

 

Sorry posts crossed. Why did you unplug the speaker for goodness sake?

We were making progress until you removed the wired connection 

Badge +1

It’s a wireless speaker and it was ready to tune, so I figured it was time to unplug it.  Obv not the case.  I’m starting the process over again. 

Just reconnect the cable and stop showing initiative 

I'm in the UK and it's very late and I'm going to bed!

Don't mess it up by starting the process again

Badge +1

OK …. i plugged it back in, tuned it and added SXM.  I’m currently listening to music on that P1 and it is wired to the router.  

If we just get one cabled speaker playing music it is a start. Make sure it's on latest software. Then leave that cabled. Factory reset one other speaker and add it using Add Product. Update again.

Do we have 2 working speakers, one wired the other wireless? Google how to reset a Sonos speaker if you need to

Badge +1

wireless speaker is running update now 

Badge +1

“Update Problem!  There was a problem during the update of your Songs system.  Select ‘try again’ to repeat the update.”

So that’s what i’m doing 

Badge +1

Got the same error again trying to update.