Answered

MacBook Air refuses to allow Sonos to access music library.

  • 21 August 2019
  • 5 replies
  • 90 views

Badge
I have changed my Firewall settings per the Sonos help article, and I have unchecked File Sharing for my MacBook Air running Mojave 10.14.6. Still, my Mac refuses to allow Sonos to access my music library. Help, please. Thank you.

icon

Best answer by Jeff S 22 August 2019, 01:09

Thanks for trying that. I'm seeing an account error. Are you logged in as an administrator account on your Mac? If not, try switching accounts, then adding the share.

It's also possible there's an issue with the Sonos account that's created when using the app to create a shared folder. Try deleting the Sonos account in your Mac's user preferences, then see if you can add the share.

If those steps don't work, it's probably best to give us a call and continue troubleshooting this live with our phone team.
View original

5 replies

Userlevel 7
Badge +20
Hi there,

That error is specifically security related, and is usually due to a firewall or antivirus setting. You should have File Sharing enabled on the Mac's system preferences in order to share files with the Sonos system. Also, make sure you don't have another computer active on the network with the same computer name.

Please try enabling file sharing, then add the share again. If you get another error, submit a diagnostic report and reply here with the confirmation number.
Badge
Thank you.
Diagnostic confirmation number: 1867445722
I have File Sharing turned on, and I further added iTunes folder again, just in case.
Firewall is on, but Sonos is added to accept connections.
Please let me know what I might be missing.
Many thanks.
Userlevel 7
Badge +20
Thanks for trying that. I'm seeing an account error. Are you logged in as an administrator account on your Mac? If not, try switching accounts, then adding the share.

It's also possible there's an issue with the Sonos account that's created when using the app to create a shared folder. Try deleting the Sonos account in your Mac's user preferences, then see if you can add the share.

If those steps don't work, it's probably best to give us a call and continue troubleshooting this live with our phone team.
Badge
Deleting the preferences worked. Thank you for your patience and assistance.
Userlevel 7
Badge +20
I'm happy to hear it's working, let me know if you run into the issue again.

Reply