Lots of line in/autoplay problems with 3.8

  • 7 June 2012
  • 7 replies
  • 2152 views

Badge
I just upgraded to 3.8. Now autoplay for line-in is behaving very inconsistently. The settings I make and save on the line-in setup pages simply do not take effect. Then the zoneplayer gets "stuck" in line-in mode and I have to switch it to another source in order to get it to work properly again.

7 replies

Inconsistent behaviour after an update can often be a consequence of a duplicated IP address.

See this post: http://forums.sonos.com/showpost.php?p=168135&postcount=5
Badge
According to "About my Sonos", each of the six Zoneplayers have a unique IP address.
According to "About my Sonos", each of the six Zoneplayers have a unique IP address.

You would have to check them against every other assigned IP on your entire network, not just Sonos components. Matter of fact, it is more likely the conflict is with another computer/WiFi device, because Sonos is connected at all times and rarely reboots, whereas other stuff comes and goes.
Badge
Yes, this is true, however the few other devices on this subnet are mostly statically addressed (except for my iPad and iPhone). I checked those and there are no conflicts there. I also re-verified that all IP address assignments made by my router's the DHCP Server will be maintained until the device is removed from the database, either by expiry or by me.

However, documentation has been wrong in the past 🙂, so I looked at the router's DHCP table and there are no duplicates. There is quite a bit of headroom between the last statically assigned address and the start of the DHCP pool, so I don't think it's an overlap issue.

The other reason why I don't think this is address-conflict related is that I have the same problem on more than one zoneplayer. For instance, if I initially select the line-in from the bedroom1 ZP to autoplay on that same ZP, then subsequently select say the bedroom2 ZP as the autoplay destination, when the line-in source activates, both ZPs start playing out the audio, which is incorrect (none of the zoneplayers are grouped, and autoplay grouping is turned off).

I wonder if I'm looking in the wrong place...maybe I need to be taking a closer look at the ZP my controller is associated to, rather than the ZP with the line-in connection (assuming they are not the ZP)?
Badge
At this point, I've had to turn off autoplay completely on this zone, due to the fact that it will frequently switch over to the line-in even if the line-in device (in this case a TV) isn't even turned on.
What has Sonos Support said about this issue? Your symptoms are most definitely not typical.

I'd induce the problem, send a diagnostic, and follow up with a call or email referencing the diagnostic number (and this thread). ZonePlayers shouldn't be playing uncommanded from LineIn -- or any source, for that matter.
Userlevel 2
Dear atebit,

it seems that i have a similar issue with line-in and some controlling issues as well.

Due to the fact its a customer installation and i will visit the customer this week i will try to find out as much as possible.

If you got any news it will be nice to get an updated posting.

i will try to check for ip-conflict issues first and than continue with sending support informations analysing.

greeting from Hamburg, Germany

Reply