Answered

Lost A Room On the Sonos App


Hi, I went on my phone and went on to the Sonos App , i went down to click T Bedroom and it wasn't there. It completely has disappeared and I can't listen to my music through Sonos. It has always worked as I always listen to music in my room. Do you know how I add my room back in? What is the problem? 
icon

Best answer by Edward R 21 June 2019, 16:08

Lately, we have noticed this topic getting a lot of traffic. Although diagnostics are much appreciated, we do not always get the opportunity to conduct one-on-one troubleshooting.

If you are still having issues maintaining connection to one or more Sonos devices, sometimes, it's as simple as turning the router off for a few seconds. If this doesn't help, below you will find some useful content that we strongly recommend reviewing.

This article, that talks about Speakers disappearing or dropping off controller. This is an issue commonly caused by WiFi interference.

If you are still having issues, you may wish to get in touch with our support team via telephone.
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

144 replies

Badge
I note from the Sonos app on my PC that this stereo pair is showing as [?&R] suggesting that the right hand speaker is not connecting (?). .... Apologies, that should obviously have read LEFT hand speaker.

UPDATE which may be useful for those having similar issues; although I had read that the Sonos system no longer requires a bridge, I reinstalled my old bridge and all worked perfectly straight off. Happy again......
Userlevel 7
Badge +19
cyaml: Thanks for the diagnostic report. I can only see the Bathroom player. What unit is missing? Have you tried plugging the missing player into the router using an Ethernet cable? The more details we have, the better we can assist.

danthea: There are a number of problems I can see on the diagnostic report that point to a problem passing data along the network on Sonos. It's may be best to give our support technicians a call to troubleshoot this in real time. They are able to set up a remote session and get a closer look at how data is getting to Sonos. Thanks!
Userlevel 7
Badge +20
Hi Toni,
Please try rebooting your missing player by removing it from power, waiting ten seconds, then plugging it back in. If this does not bring the unit back, there maybe some wireless signal interference preventing connection. To see if this is the case, we'd like to see some data from your system. Please submit a diagnostic and reply with the confirmation number: Submit diagnostic.
Hi Sonos, Have the same issue, can't seem to reconnect players even after resetting to factory settings. Diagnostic confirmation number 4530838 Frederic
Hi Sonos, I have a similar problem: a room sometimes suddenly disappears. Could you help me? I tried disconnecting the specific box but that didnt work. Diagnostic number: 6105097. Thanks in advance!
Hi Jeff. I did get in touch by phone and after running some diagnostics the agent said it was down to a router issue. My BT Homehub 6 apparently has issues around IP allocation which strangely only affects one (the Playbar, or a couple of) Sonos component (note: the rest of my devices are working better than ever). They told me to get in touch with BT to downgrade to an earlier modem - which was a little disappointing. Since then I found this: http://bt.custhelp.com/app/answers/detail/a_id/56287/~/what-is-the-wireless-mode-feature-on-my-bt-smart-hub%3F

It suggests switching to Mode 2 for devices which "sometimes struggle to use the latest wireless features" which is what this sounds like.

Things seem to be working better for now at least. I'll post more news is there is any.
Hi Max, so a few days on and I'm still experiencing the Playbar drop off issue that has been ongoing. Possibly less often since I enabled the legacy support option on the router, but it is still happening.

Do you have any thoughts on what to try next?
I have the same issue. I have 3 rooms set up and they have been working fine for over a year and a half. I made no changes to anything and last week one room dropped out and this week 2 rooms are gone. I have rebooted both speakers and the connect unit and nothing. Diagnostic confirmation number is 7089865
Userlevel 4
Badge +3
Hi lvnt, welcome to the community. Can you temporarily wire in that missing player to your router with Ethernet cable? Make sure the light flashes white for a minute or so and then goes to solid white. That's what you should see for normal operation. Once you get that white light, check on the app to see if the room has appeared. If not, try adding it again by following the menu under Settings > Add a Player or SUB. If you ever manage to get the speaker showing again, please send us a diagnostic at that point and reply here with the number you get.

If you cannot get it to appear, or the lights are not doing what you expect, you may want to try a factory reset on it. If that works, try to add it in again. Let us know how it goes.
Hi Tom, thanks for the response and suggestion. No luck, unfortunately. plugged in vie cable (tried the ConnectAMP and the router too separately) and all I get is green first, then trying to pair and nothing works... I bought this play1 on AU and now I'm in SG... diag report: 7893468
Hi Tom, would you have any advice on the seemingly dead play1 above? The weird bit is that it powers up, gets to green light and then during the pairing process goes blinking orange immediately after the sound that follows pushing the two buttons to pair.
I have have 4 rooms connected, and one has dropped off - I've tried resetting the router, tested the line, power-cycled the play:5 unit and still nothing. Diagostic #7915507 Many thanks.
I have the same issue with my system. I have lost the Playbase from the system. I have reset the wireless router frequency, I have done a factory reset, I have hardwired the speaker directly to the router, and nothing works. Diagnostic number 7921544
After diagnostics it turns out my -12month old play:5 has developed a hardware fault - replacement due.
Userlevel 7
Badge +19
Hi Tom, would you have any advice on the seemingly dead play1 above? The weird bit is that it powers up, gets to green light and then during the pairing process goes blinking orange immediately after the sound that follows pushing the two buttons to pair.
After pressing the two buttons the flashing orange LED is normal. This means it is trying to communicate with your network and get an IP address (as noted here). What we are more interested in is what the Sonos application is doing after the button press. Does the screen stay at the press the two buttons step or does it say "Connecting..." and then fail?

As you'd assume, these outcomes tell us different things about where in the handshake process things went awry. Thanks in advance.
Hi there, I've been having this issue ever since I upgraded my router to a SkyQ a few months ago. I've got three Sonos one speakers, all used to work fine. There's poor wifi in my house so two are plugged into a HomePlug (Solwise). Since changing my router only one shows up regularly (it's plugged into a HomePlug). One that is also plugged into a HomePlug doesn't show, the one plugged directly into the mains and working on wifi doesn't show at all.

I've reinstalled my router settings, plugged and unplugged the speakers, and nothing works. When I connect them directly to the router they show up on the system, but when I move them back into their proper location they don't show. I can't use my system at all at the moment - please help!

I'm using IOS controllers (Ipad/IPhone); controllers and speakers have all been updated. Diagnostic #8057907. Thank you.
Hi Sonos,
I have the same problem, Diagnostic Number # 8057853 and after reboot my router the Diagnostic Number is 8057947.
Userlevel 7
Badge +19
SusieJ: HomePlug or PowerLine network devices do not allow Sonos to function as intended. Without the HomePlug's involved, what network devices do you have? I'd be happy to help get Sonos working reliably for you. Thanks in advance.

Papa Pond: Thanks for the diagnostic report. Could you tell us a little more about your local network? I can see you have quite a few devices plugged into the network. Do you have any switches, extenders or access points? What is the make and model of the router you are using?
Hi Keith, Thanks for your reply, my router is Linksys LRT224, switch is Linksys also and the AP is Ubiquiti Unifi AC PRO.
The one the always has a problem is Play5 Gen 2 (Office (L)). I created stereo pair for this room, the right channel is working fine and never disappear from the Sonos app (when I check on "About my Sonos sytem"). if you need more info, please feel free to let me know.
Userlevel 7
Badge +19
Thanks for the details, Papa Pond. The Office (L) does not appear in the diagnostic. What color is the LED on the unit? What happens if you plug the PLAY:5 directly into the LRT224? Does it come back up on Sonos?
Same issue here. When I connect it directly to the router Sonos finds the speaker but still no music is played there. The button at the back does nothing and all reboots didn´t help. Issue no: 8065852
Userlevel 7
Badge +19
Thanks for the diagnostic report, Oliver22.This report only shows two devices that are wireless. Perhaps a few more details of whats going on could be helpful. What Sonos device is missing? What color is the LED when you plug it into power? Much appreciated.
Hi Keith.

The device is a play:5 Second Generation, the light is solid white. Thanks
Userlevel 7
Badge +19
Understood. At the time of the diagnostic report, was the PLAY:5 plugged into the router via Ethernet? If it was not plugged in, please submit another diagnostic report with the PLAY:5 plugged into the router. Additionally, can you tell me a little more about your local network? What is the make and model of your router?
Hi Keith.

I have submitted a new diagnostics with the ID: 8070257. The Paly:5 was now connected via cable. The router is a technicolor 789 VAC. Does that help?

Thanks
Oliver