Answered

Lost A Room On the Sonos App



Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

144 replies

Hey Jeff,

Same problem here, tried rebooting it before, and then it works for a few days, but the same thing keeps happening

Diagnostics 7594274
Ive lost a room too. Others in the house have it. Diagnostic code is 7620866..any advice
Same thing for me. It keeps happening, I can usually reboot and find the speaker again, but not this time. My play 5 is missing for a week. 7636092
I am having the same issue, i have lost connection with the family room on our Sonos controller. My diagnostics is 7658243
Userlevel 2
I am having the same issue. My diagnostic confirmation number is 7671626.
Thank you
I've lost a Play 5 speaker. Have tried restarting the speaker and the router a few times without success. Diagnostic number 7691000. Thanks.
A room disappeared on the app. Diagnostic number is 7705654
My Connect (which is the line-in for my record player) often disappears, and now my room with Playbase, sub, and two Play 1's has disappeared. I've rebooted the router, and rebooted all of the individual speakers with no help. Diagnostic information number is 7763443.
Lost my family room. Diagnostic 7825065.
i'm having the same problem. suddenly our Play5 (gen2) has disappeared. I've rebooted the player, the router and changed the wireless channel and nothing. I even heard the chime over and over again but it would not connect. Then i connected the player to the router via ethernet and it connected, only to lose it again once i moved it back into it's original place. very frustrating that a player that has worked perfectly for a long time suddenly is not usable. help plz diagnosics 7835673
If it works fine while wired with an ethernet cable, but not while on ethernet, I'd suggest that the wifi card in it has failed. Your best bet is to contact Sonos directly, at www.sonos.com/contact Replacements generally aren't dealt with here in these forums.
Hi, I lost a room too, can't get it back... submitted diag#7851591
thanks
Userlevel 4
Badge +3
Hi lvnt, welcome to the community. Can you temporarily wire in that missing player to your router with Ethernet cable? Make sure the light flashes white for a minute or so and then goes to solid white. That's what you should see for normal operation. Once you get that white light, check on the app to see if the room has appeared. If not, try adding it again by following the menu under Settings > Add a Player or SUB. If you ever manage to get the speaker showing again, please send us a diagnostic at that point and reply here with the number you get.

If you cannot get it to appear, or the lights are not doing what you expect, you may want to try a factory reset on it. If that works, try to add it in again. Let us know how it goes.
Hi Tom, thanks for the response and suggestion. No luck, unfortunately. plugged in vie cable (tried the ConnectAMP and the router too separately) and all I get is green first, then trying to pair and nothing works... I bought this play1 on AU and now I'm in SG... diag report: 7893468
Hi Tom, would you have any advice on the seemingly dead play1 above? The weird bit is that it powers up, gets to green light and then during the pairing process goes blinking orange immediately after the sound that follows pushing the two buttons to pair.
I have have 4 rooms connected, and one has dropped off - I've tried resetting the router, tested the line, power-cycled the play:5 unit and still nothing. Diagostic #7915507 Many thanks.
I have the same issue with my system. I have lost the Playbase from the system. I have reset the wireless router frequency, I have done a factory reset, I have hardwired the speaker directly to the router, and nothing works. Diagnostic number 7921544
After diagnostics it turns out my -12month old play:5 has developed a hardware fault - replacement due.
Userlevel 7
Badge +19
Hi Tom, would you have any advice on the seemingly dead play1 above? The weird bit is that it powers up, gets to green light and then during the pairing process goes blinking orange immediately after the sound that follows pushing the two buttons to pair.
After pressing the two buttons the flashing orange LED is normal. This means it is trying to communicate with your network and get an IP address (as noted here). What we are more interested in is what the Sonos application is doing after the button press. Does the screen stay at the press the two buttons step or does it say "Connecting..." and then fail?

As you'd assume, these outcomes tell us different things about where in the handshake process things went awry. Thanks in advance.
Hi there, I've been having this issue ever since I upgraded my router to a SkyQ a few months ago. I've got three Sonos one speakers, all used to work fine. There's poor wifi in my house so two are plugged into a HomePlug (Solwise). Since changing my router only one shows up regularly (it's plugged into a HomePlug). One that is also plugged into a HomePlug doesn't show, the one plugged directly into the mains and working on wifi doesn't show at all.

I've reinstalled my router settings, plugged and unplugged the speakers, and nothing works. When I connect them directly to the router they show up on the system, but when I move them back into their proper location they don't show. I can't use my system at all at the moment - please help!

I'm using IOS controllers (Ipad/IPhone); controllers and speakers have all been updated. Diagnostic #8057907. Thank you.
Hi Sonos,
I have the same problem, Diagnostic Number # 8057853 and after reboot my router the Diagnostic Number is 8057947.
Userlevel 7
Badge +19
SusieJ: HomePlug or PowerLine network devices do not allow Sonos to function as intended. Without the HomePlug's involved, what network devices do you have? I'd be happy to help get Sonos working reliably for you. Thanks in advance.

Papa Pond: Thanks for the diagnostic report. Could you tell us a little more about your local network? I can see you have quite a few devices plugged into the network. Do you have any switches, extenders or access points? What is the make and model of the router you are using?
Hi Keith, Thanks for your reply, my router is Linksys LRT224, switch is Linksys also and the AP is Ubiquiti Unifi AC PRO.
The one the always has a problem is Play5 Gen 2 (Office (L)). I created stereo pair for this room, the right channel is working fine and never disappear from the Sonos app (when I check on "About my Sonos sytem"). if you need more info, please feel free to let me know.
Userlevel 7
Badge +19
Thanks for the details, Papa Pond. The Office (L) does not appear in the diagnostic. What color is the LED on the unit? What happens if you plug the PLAY:5 directly into the LRT224? Does it come back up on Sonos?
Same issue here. When I connect it directly to the router Sonos finds the speaker but still no music is played there. The button at the back does nothing and all reboots didn´t help. Issue no: 8065852