Library 1002

  • 14 January 2017
  • 5 replies

New Win10 laptop. Play 3 is communicating fine. Can stream services without issue.

Cannot add local files on my computer to the library. Have tried everything I have found on this site and outside of it. Nothing works.

Stupid question: When it asks for the path, and I browse to the directory and select, why does the error message give a different directory than I selected? i.e. Let's say I use D:\Music\SonosMusic\ as my directory, the error 1002 message says \\\SonosMusic not accessible. Is there some mapping crap I have to do now? Actually tried that as well, didn't help.

I've always been frustrated by this insufferable system, but it's always been communicating with the unit, and I've usually been able to make it work after a half hour and holding my tongue on the right tooth. Can't make it work this time, and this is such a basic function (adding a library on the SAME computer), that it really bewilders me that it has to be complicated. Would appreciate any help.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies

Um, I asked Support to update their Bitdefender settings section so that people like me can solve our own problems.

My "attitude" is frustration earned over time with what I feel is a system that should be more robust, and not require so much network perfection and expertise. Of all the electronics I own, none come close to the neediness of this system.

If you don't like my attitude, or appreciate my frustration (which appears to be shared by many), then maybe just do nothing. I'm not doing you any harm. I don't need to be talked down to by you.
Userlevel 7
Badge +21
Why don't you call Sonos support? They are actually pretty good.

If you can the attitude I'm willing to bet they would sort you out in 30 minutes
So it looks like the issue is probably my new Bitdefender 2017 subscription. I gave Sonos permissions, but apparently it wasn't enough. I can only get my *local* (ON THIS PC!!!) library to work if I completely shut off my firewall, which is a non-starter.

The last Bitdefender setup instruction on this site is for 2012, I believe. Only 5 years behind.

Please update when you get a chance. Or don't. Whatever.

I've had it. I am apparently not your target demographic.
Userlevel 7
Badge +20
Don't know why, but it got the path wrong in my OP. The error is \\[computername]\SonosMusic is not accessible.


Hi sirkossorg,

The file's location on your computer is D:\Music\SonosMusic\ but when that folder is shared it shows up as a shared folder on the network under your computer's name: [computername]\SonosMusic. That's all as it should be.

Please send in a diagnostic report from your Sonos app then reply with the confirmation number. I'll take a deeper look for you.
Don't know why, but it got the path wrong in my OP. The error is \\[computername]\SonosMusic is not accessible.