Question

LG oled65cx losing sound.

  • 14 November 2020
  • 20 replies
  • 266 views

I got the new LG 65CX tv and sonos arc sound bar last July I’m having issues sometimes of losing sound from my sonos arc when I change over the channels on my sky Q box or even when I watch Netflix or the RTÉ player, the sound will eventually come back after 30 seconds or even longer sometimes, I have got on to LG but they are giving me the run around for the last 3 months asking me the same questions and that they are looking into it.


20 replies

The complexity of the settings on the LG CX TVs is most of the problem I think. My beam worked very well with an older LG TV using the hdmi/arc connection and worked for a couple of weeks with the cx. It might be that an update to the lg webos or to the beam caused my problems.  
 

Sonos does give you 2 (maybe 3 counting Bluetooth) different ways to connect. Customer support could be better though. 

I’ve got to say this all seems very complicated. I purchased a new LG OLED 65” CX in July and just installed it 2 months ago in our new house. Was planning to purchase Sonos Arc but all this trouble I’m seeing gives me PAUSE!

 

Has Sonos figured this out?  Do the HDMI ports on both New LG CX and Sonos Arc “talk” properly?  If not I’ll have to find another soundbar to work.

 

The last thing I want is a lot of problems.

More likely some of the unfavourable things mentioned here in the community about the Sonos Arc/HT setup, are related to HDMI-CEC, or sometimes issues with TV settings, or perhaps user-understanding - they are mostly issues that you might see with any brand of HDMI-eARC connected atmos-audio capable receiver - it’s not in many instances anything to do with the actual Sonos Arc. Here at home I have the slightly older LG C9 OLED TV, the Arc, sub and surrounds and there are no issues here with any of the Sonos products - the only one ‘initial’ issue I encountered with the Sonos Arc was the multichannel LPCM codec support that I and others wanted to see for Apple TV/xBox etc. - but that’s since been sorted by the recent updates.
 

The stealing of HDMI-CEC control by other peripherals (if and when that may occur with some TV connected products) is also easily solved by switching off CEC on the device, or perhaps by using a CEC-Less adapter. 
 

Personally speaking I think the Arc looks and sounds great, particularly with bonded surrounds and I think it outshines the similar competition in the similar priced soundbar market. It’s actually worth any such minor problems because you will most likely encounter the precise same issues with other such products anyway.  
 

I am more than happy with the Arc - it has turned a great TV into an incredible Home Theatre setup for our Living Room.

I’ve got to say this all seems very complicated. I purchased a new LG OLED 65” CX in July and just installed it 2 months ago in our new house. Was planning to purchase Sonos Arc but all this trouble I’m seeing gives me PAUSE!

 

Has Sonos figured this out?  Do the HDMI ports on both New LG CX and Sonos Arc “talk” properly?  If not I’ll have to find another soundbar to work.

 

The last thing I want is a lot of problems.

Well I am pretty frustrated by the lack of follow up. Sonos customer service is pretty poor I have to say. 
 

While I have not been able to get the ARC connection to work, after a lot of trying to get the optical and smart remote to work (with useless tips from Sonos) I was able to find the setting that finally allowed the lg smart remote to control my beam while the tv is on (getting  it to control the beam while the tv was off was not a problem). 
I set up the Sonos under device connector as a sound bar on the optical port. I had to disable “lg sound synch” under sound settings to get the remote to function with the beam. After this, I noticed right away when I used volume control it looked different and actually worked. See picture below:

 

I have exactly the same pb since few weeks ...now i though it was a pb with my hdmi cable i did try everything could not find a solution... sonos product becoming very poor...very disappointed...cannot send diagnostics because the app does not connect now...see play store comments...

You also have the option of the optical adapter. This works but I can not control the volume with the tv remote and I have been unable to configure the remote to talk to Beam. It is disappointing but this is better than no sound. 

I ran another diagnostics report and the reference number is 617043521  screen grab below

 


 

 

Hi Simon tried everything cable replaced, TV reset, I am not able to connect to my beam anymore...note that my LG tv is old and not receiving update since years... So I have no clue how to send you a diagnostic without the app. 

Userlevel 6
Badge +15

Hi @Tim-stl, thanks for the update and for sending a diagnostic report of your Sonos system, Upon checking, it doesn’t have any match for a diagnostic report. Can you kindly try to send another diagnostic report, Thank you.

Let us know what you have in mind with the advice above.

The Sonos community is always here to help.

Userlevel 6
Badge +15

Hi @Rachidm, Thank you for reaching out, and welcome to the community. Sorry to hear that you have the same issue with your Sonos system. Have you tried to unplug and replug the cables for the HDMI Arc. and Also do a reboot on the TV and the Sonos Arc to check for any difference or if you can submit a diagnostics afterward. 

Let us know what you have in mind with the advice above.

The Sonos community is always here to help.

I have exactly the same pb since few weeks ...now i though it was a pb with my hdmi cable i did try everything could not find a solution... sonos product becoming very poor...very disappointed...cannot send diagnostics because the app does not connect now...see play store comments...

Ok I tried the arc connection with same result. Reference 1726772282. 
 

And a picture of the cable plugged into the hdmi/arc plug on the tv. 
 

thanks. 

Userlevel 6
Badge +15

Hi @Tim-stl, thanks for the update and the diagnostic report that you’ve sent. It shows that you are connected via the optical adapter. Does it work that way? Can you try to use again the HDMI Arc cable, and run a diagnostic so we can compare and check the issue when the HDMI Arc is plugged in. 

Let us know what you have in mind with the advice above.

The Sonos community is always here to help.

Thanks!  The confirmation number is 1095187507. After I posted this last night I configured the beam to connect using the optical audio adapter, but I would prefer the ARC connection    In part because I have been unable to configure the TV remote to control the Beam’s volume. 

Userlevel 6
Badge +15

Hi @Tim-stl, Thank you for reaching out, and welcome to the community. Sorry to hear that you have the same issue with your Sonos system. So that we can check the current status of your system. I’ll ask you to submit a diagnostic report to investigate further what could be causing this issue. You may reply to the thread with the confirmation number to assist you with this issue.  

Let us know what you have in mind with the advice above.

The Sonos community is always here to help.

I have a similar issue. I had my lg oled65cx configured with the Beam and it worked great for a couple of weeks but now will not. I have worked on it for hours, tried a new cable, and every tv setting I can think of. I definitely have it connected to the arc port. I have tried moving the beam back to to the old tv which I still have (another LG) and it works fine. Can I get help troubleshooting mine?

Userlevel 6
Badge +15

Hi @Bestever59, thanks for the update and for sending a diagnostic report of your Sonos system. In this case, We’ll take this further. I'll ask you to kindly contact our phone support team for further assistance and more in-depth troubleshooting steps. They may perform additional steps, diagnostics and options on resolving this issue.

Let us know what you have in mind with the advice above.

The Sonos community is always here to help.

That setting is already enable on my tv

Userlevel 6
Badge +15

Hi @Bestever59, thanks for the update and for sending a diagnostic report of your Sonos system. Upon checking the diagnostic information, It shows that the Sonos Arc’s CEC is disabled. Kindly check on the TV settings and enable the CEC or Simplink (HDMI-CEC) settings on your LG TV  and enable it. And then do a reboot on your TV and the Sonos Arc and the SkyQ Box that you have, unplug it for 1-2 minutes from the power source and check if that will make any difference. 

Let us know what you have in mind with the advice above.

The Sonos community is always here to help.

Confirmation number 1915164729

Userlevel 6
Badge +15

Hi @Bestever59, Thank you for reaching out and welcome to the community. Thanks for bringing this up and I know where you're coming from. So that we can check the current status of your Sonos system, I’ll ask you to submit a diagnostic report for us to investigate further what could be causing this issue. You may reply to the thread with the confirmation number to assist you with this issue. 

Keep me in the know with the advice above.

We're here to answer any further questions you have.

Reply