Question

LG OLED55CX magic remote no longer working with Playbar

  • 18 October 2020
  • 3 replies
  • 27 views

Hello!

I purchased an LGOLED55CXPUA about a month ago. On set up I was able to configure the magic remote to control my Sonos playbar using the volume using the Device Control settings. The mute button would not work but the + & - for volume did which was all I needed.

As of yesterday magic remote no longer controls the volume of the playbar. I saw this topic https://en.community.sonos.com/home-theater-228993/lg-oled55cx-magic-remote-not-working-with-playbar-6843515 which describes my situation perfectly & see that this was resolved with LGs software update (03.10.20). My TV is running 03.11.10

When I contacted LG they just sent me a reply telling me about how great LG soundbars are! Points for chutzpah if nothing else…

Any help from you good people would be greatly appreciated!


3 replies

Userlevel 3
Badge +8

Hi @lesleepee, welcome to the Sonos community, and thanks for bringing this to our attention. I appreciate all your effort in checking for the resolution. Let us help you out.

The LG Magic Remote does not output Infrared (IR) signals by default like many other remote controls. It uses radio frequencies (RF) or Bluetooth to communicate directly to the TV or other devices. Some configuration is necessary to enable IR output for use with Sonos home theater products.

Try to re-setup your LG Magic remote by following the steps in these articles:

  1. LG Magic Remote setup
  2. Setup remote on the Sonos app

Note: If you’re still not able to control your home theater speaker with the LG Magic Remote, try disabling SIMPLINK for the Optical connection under Settings > Sound > Sound Out.

Let us know how you get on with the advice above. We’ll wait for your reply.

 

Thanks for the links - I had already tried following the instructions in both of them, without success. However, as of last night problem appears to have been solved with the latest software update.

TV updated to verison 03.11.25 last night & after that I was able to use Device Control settings to connect the magic remote to the soundbar to control the volume. Mute button still doesn’t work but thats ok.

Thanks again

Userlevel 3
Badge +8

Hi @lesleepee, thank you for your update. I'm glad that your remote can now control the volume of your Sonos Playbar.

If you encounter any issues, just submit a diagnostic and let us know the confirmation number for us to check what’s going on.

Please do not hesitate to reach out or create a topic if you still have further questions or concerns. 

The Sonos Community is always here to help.

Reply