Answered

LG G2 TV and Sonos System with ARC+SW+2 Surrounds -not hearing sound from the Surrounds.

  • 25 May 2022
  • 8 replies
  • 480 views

In short, I never seem to be hearing noise from the surrounds- most of the sound just seems to come from the ARC and that’s it.  I have a SW too- which is hard directionally to see if it’s coming from there too.  

I’ve got it all set up in my system as part of the ARC- i.e. the 2 surrounds and SW are hooked in thru that.   But never quite seem to hear the surrounds...any idea what’s up?

icon

Best answer by GuitarSuperstar 26 May 2022, 00:07

View original

8 replies

Userlevel 7

Make sure your TV settings are set to this:

HDMI Input Audio Format: Bitstream

Digital Sound Output: Pass Through

eARC Support: On

 

And make sure you are playing a 5.1 audio source. If you want to see what audio format is currently playing on the Arc, look on the Now Playing screen in the Sonos app. When streaming, you usually want to see “Dolby Digital Plus 5.1” or the Dolby Atmos logo.

If the Arc is only receiving Stereo PCM audio, the Arc will perform an audio up-mix of the stereo signal to create a simulated surround sound. This means you’ll still hear most audio out of the Arc, but the surround speakers will play what is determined to be ambient audio.

You can also adjust the audio level of the surrounds in the Sonos app. Read more here:
https://support.sonos.com/s/article/4804

I’m having the same issue. 
LG C2 TV setup with a surround Sonos system: Arc+Sub+2xOnes (as surrounds). 

 

Using an AppleTV input into the TV with HDMI, audio output to Arc via eARC. 
 

The surrounds work after a fresh reboot (power cycle) of the Arc speaker. Will show as “Dolby Digital Plus 5.1” in the app.  Then if I pause the show / movie, the output source seems to get messed up ~50% of the time where it will only output to the Arc while the Sub and Ones stop working as one surround system. (This occurs on all sources, YouTube tv, Netflix, Hulu, HBO). 
 

When this occurs, they still show as paired in the App (under System/Product/room, it shows “Arc+Sub+LS+RS”) but they won’t work even if I override the tv audio and choose to play Spotify through the Sonos App. Sound will only come out of the Arc while the Ones and Sub remain dead. 
 

That’s why I’m suspicious this is a Sonos pairing issue. I’ve tried factory resetting all the speakers and pairing them again and still have this issue. 
 

For what it’s worth, setting on my TV:

input audio: bitstream

eARC support: on

output audio: auto (if I set pass through it goes to PCM) 

 

Please help!!

Userlevel 7

I’m having the same issue. 
LG C2 TV setup with a surround Sonos system: Arc+Sub+2xOnes (as surrounds). 

 

Using an AppleTV input into the TV with HDMI, audio output to Arc via eARC. 
 

The surrounds work after a few reboot (power cycle) of the Arc speaker. They’ll show as “Dolby Digital Plus 5.1”.  Then if I pause the show / movie, the output source seems to get messed up ~50% of the time where it will only output to the Arc and the sub and Ones stop working as one surround system. 
 

They show as paired in the App (under System/Product/room, it shows “Arc+Sub+LS+RS”) but they won’t work even if I override the tv audio and choose to play Spotify through the Sonos App. 
 

That’s why I’m suspicious this is a Sonos pairing issue. I’ve tried factory resetting all the speakers and pairing them again and still have this issue. 
 

For what it’s worth, setting on my TV:

input audio: bitstream

eARC support: on

output audio: auto (if I set pass through it goes to PCM) 

Have you installed the 14.10 Sonos update yet?

FYI… you want to see “Multichannel PCM 5.1” from non-Dolby Atmos content when using the Apple TV 4K. If you see Dolby Digital Plus, the TV is re-encoding the audio it is receiving from the Apple TV.

I’m having the same issue. 
LG C2 TV setup with a surround Sonos system: Arc+Sub+2xOnes (as surrounds). 

 

Using an AppleTV input into the TV with HDMI, audio output to Arc via eARC. 
 

The surrounds work after a few reboot (power cycle) of the Arc speaker. They’ll show as “Dolby Digital Plus 5.1”.  Then if I pause the show / movie, the output source seems to get messed up ~50% of the time where it will only output to the Arc and the sub and Ones stop working as one surround system. 
 

They show as paired in the App (under System/Product/room, it shows “Arc+Sub+LS+RS”) but they won’t work even if I override the tv audio and choose to play Spotify through the Sonos App. 
 

That’s why I’m suspicious this is a Sonos pairing issue. I’ve tried factory resetting all the speakers and pairing them again and still have this issue. 
 

For what it’s worth, setting on my TV:

input audio: bitstream

eARC support: on

output audio: auto (if I set pass through it goes to PCM) 

Have you installed the 14.10 Sonos update yet?

FYI… you want to see “Multichannel PCM 5.1” from non-Dolby Atmos audio when using the Apple TV 4K. If you see Dolby Digital Plus, the TV is re-encoding the audio it is receiving from the Apple TV.

yep 14.10 is installed. And the speakers are running 14.8. 
 

The audio source should be Dolby atmos for the content I’m watching

Userlevel 7

@Q8tiprophet Go to System Updates > Check for Updates and upgrade your speakers to 14.10.

@Q8tiprophet Go to System Updates > Check for Updates and upgrade your speakers to 14.10.


Nice, I didn’t realize there was an update (thought I checked a few days ago). Updated the speakers to 14.10 and now is showing as “Dolby Mulichannel PCM 5.1”

Userlevel 7

@Q8tiprophet Go to System Updates > Check for Updates and upgrade your speakers to 14.10.


Nice, I didn’t realize there was an update (thought I checked a few days ago). Updated the speakers to 14.10 and now is showing as “Dolby Mulichannel PCM 5.1”

The update has nothing to do with the type of audio you are getting. It only addresses the Sub and surround audio drop outs.

What exactly are you playing and from what app?

You are getting “Dolby Multichannel PCM 5.1” because the TV is set to Auto instead of Pass Through. Ideally, you want the Sonos app to display “Multichannel PCM 5.1” from non-Dolby Atmos content.

@Q8tiprophet Go to System Updates > Check for Updates and upgrade your speakers to 14.10.


Nice, I didn’t realize there was an update (thought I checked a few days ago). Updated the speakers to 14.10 and now is showing as “Dolby Mulichannel PCM 5.1”

The update has nothing to do with the type of audio you are getting. It only addresses the Sub and surround audio drop outs.

What exactly are you playing and from what app?

You are getting “Dolby Multichannel PCM 5.1” because the TV is set to Auto instead of Pass Through. Ideally, you want the Sonos app to display “Multichannel PCM 5.1” from non-Dolby Atmos content.

The audio dropping from the sub and surrounds was my major concern so if that is fixed I’m happy. 
 

I followed your instruction and switched audio output on the tv to passthrough and now I see this:

content: Netflix show with 5.1 —> multi-channel PCM 7.1

content: Netflix show with Atmos —> Dolby Atmos

Reply