Lag between zones

  • 15 September 2018
  • 34 replies
  • 4814 views

Userlevel 2
Badge +4
Hi guys I have the following setups

Lounge: playbar sub 2x play 5 gen2

Kitchen: 2 x play 1

Bathroom: play 1

Bedroom: 2x play 1

Office: play 1

The system runs fine however when I am playing music everywhere when I change track either via app or direct on the speaker I get a lot of lag between each speaker playing the song by a lot I mean if I skip forward a track it can start playing in the lounge a good 5 seconds before it starts playing in the bathroom

Any ideas

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

34 replies

Hey ken

It now seems all issues are actually resolved the boost is running fine. It has a permanent IP address now. There is no lag on the Sonos system now. And wireless side is good now aswell. Thanks for all your help guys
please how did you fix it? I need help!!
My recollection is gazza1977 purchased the Sonos Boost (though could have used a Speaker instead) and switched his system over to SonosNet and ensured that the SonosNet Channel and the main routers 2.4ghz WiFi channel we’re least used in his locality and were operating on non-overlapping channels...

So, as an example, his WiFi was running on ‘fixed' channel 6 and his SonosNet channel was set to either channel 1 of 11 and he had just the Boost cabled to the network.

He probably also removed his WiFi credentials in the Sonos App “Advanced Settings/Wireless Setup” and I think reserved all his Sonos devices IP addresses in the main Routers DHCP Reservation Table.
thank you so much for your time. You’ve been helpful indeed! I’ll do just that tomorrow. Thanks again.
Hey ken

It now seems all issues are actually resolved the boost is running fine. It has a permanent IP address now. There is no lag on the Sonos system now. And wireless side is good now aswell. Thanks for all your help guys
please how did you fix it? I need help!!
My recollection is gazza1977 purchased the Sonos Boost (though could have used a Speaker instead) and switched his system over to SonosNet and ensured that the SonosNet Channel and the main routers 2.4ghz WiFi channel were least used in his locality and were operating on non-overlapping channels...

So, as an example, his WiFi was running on ‘fixed' channel 6 and his SonosNet channel was set to either channel 1 of 11 and he had just the Boost cabled to the network.

He probably also removed his WiFi credentials in the Sonos App “Advanced Settings/Wireless Setup” and I think reserved all his Sonos devices IP addresses in the main Routers DHCP Reservation Table.
Hey ken

It now seems all issues are actually resolved the boost is running fine. It has a permanent IP address now. There is no lag on the Sonos system now. And wireless side is good now aswell. Thanks for all your help guys
please how did you fix it? I need help!!
@gazza1977 please how did you resolve this issue? Was it the boost that help because I’m experiencing the same issue when I’m listening to Qobuz on Sonos but everything seems fine when listening with Spotify and I prefer the audio from Qobuz. Please advise me on how to fix this annoying lag as music doesn’t play in sync. Thank you.
How thick am I ken. I just realised I can have my xbox set up wireless lmao. Owned it for years and never knew lmao
Isn’t it a hassle though moving all these things around the place and getting them to work .. I really hate it. I’m dreading having to change my old Lounge Sony TV and Home Theatre System etc etc. ... it looks like a huge plate of sphagetti behind the main cabinet unit and I’ve long-forgotten what cable goes where !! ?

Glad everything is now sorted by the way !
Userlevel 2
Badge +4
Hey ken

It now seems all issues are actually resolved the boost is running fine. It has a permanent IP address now. There is no lag on the Sonos system now. And wireless side is good now aswell. Thanks for all your help guys
Gazza1977

Whilst there is no problem cabling other Sonos devices direct to the router, I often find just the Sonos Boost cabled by itself tends to work really well, because it starts the SonosNet network signal and the remaining Sonos Speakers just act as stepping stones/receivers for that Signal ...and they sort themselves out, choosing the shortest routes with more than adequate signal strength to perform everything required by Sonos.

The good news there is that the radio Signal is exclusive to Sonos and so other things on the local network don’t get in the way of things... that’s why it’s good to run it on a channel that does not overlap with your router channels ... keep them 5 channels apart for the 2.4 ghz band.

It sounds to me like you are now not too far off resolving your issues here.
Userlevel 2
Badge +4
How thick am I ken. I just realised I can have my xbox set up wireless lmao. Owned it for years and never knew lmao
Make sure the Sonos Boost and Router are a few feet apart. I have seen two feet suggested but personally I prefer 4 feet. I tend to move my Hue Hub too away from the Boost.

I don’t see why you can’t have the router in the Lounge and Boost cabled to it in the Hallway, if that’s a possibility in your home ... then cable the Xbox to the router like you did before.
Gaza1977,

See also Stanley_4’s post above about viewing your Sonos Matrix to see what changes have occurred to your system, now that you have added the Sonos Boost to your Household... just to see what that device is doing and any interference perhaps around your Sonos devices... ideally you want most things coloured green here, if possible, but yellow/amber is fine too... Red is usually an area of concern for you to focus in on. It’s not relevant of course, where devices are cabled over Ethernet.
Userlevel 2
Badge +4
Hi ken

I did try it and still had same issue hence I went and bought the boost

Since posting I have moved my router to the hallway. Only things plugged into it are Philips hue hub and Sonos hub

After moving the router it seems to be working ok NO LAG NOW

the issue must have been the amount of things around the router in the lounge.

My issue now is how to connect my x box one to the internet as that is in lounge and router now in hallway
Gazza1977,

I’m surprised you didn’t check things with your Office Play:1 first, as suggested earlier, as that would have indicated if the Boost would have worked, or not.

Can you just confirm that the Boost is now the only device cabled to your LAN... just adding a Boost to the system doesn’t mean that device has actually taken control over things here.
Userlevel 2
Badge +4
Ok update. After everything suggested I still had same problem so I purchased a boost today guess what still same problem

Diagnostic report 744776997

Sonos please advise why I am still get lag thanks
gazza1977,

I still think it maybe worth trying a Play: 1 wired to the router as the Boost (master) instead... just to see if it makes any difference to your problem . I've just wrongly assumed that it was a Play:5 that was wired to the router in your lounge.

At least you will then know if it’s the PlayBar that is causing the 'lag' issue... you can then see (perhaps) if a Sonos Boost might go onto help solve your problem, that’s if the Play: 1 fixes the 'lag' issue.

I would also consider maybe changing the Ethernet cable too... just to try to eliminate things.
Userlevel 2
Badge +4
The wired speaker is the playbar as that is the only one closet to the router
gazza1977,

I’m wondering if it’s a hardware problem with the actual wired play:5 speaker in the lounge ... what happens if you bring your office play:1 over to the router and swap that to become the Boost (Master) Controller ... note you may have to cable that play.:1 speaker and then remove your play:5 Ethernet cable and then power off/on all the non-cabled Sonos Speakers to get them to switchover to the new Boost master.

Then try that ... that’s the only thing I can think of. I’m wondering if there is some kind of 'issue' with the Play 5 wireless card ??

It has to be worth a try as a last resort, as you have tried everything else.
Userlevel 2
Badge +4
Ok guys tried swapping channels tried boost and normal mode. All speakers have there own IP address. Wireless signal is stron as room furthest from the router is the office and my iMac runs wirelessly from my router and never has any issues. So I’m out of ideas anyone suggest anything
Userlevel 7
Badge +21
Did you try the link I posted above, you originally said it didn't work, possibly you may not have replaced the place-holder text with an IP address of one of your Sonos speakers.

Needs the "speaker-ip-here replaced by your IP:

http://speaker-ip-here:1400/support/review

Change that to look like this BUT with one of your IP addresses:

What works for my system here - but your IP will be different:

http://172.16.1.115:1400/support/review
gazza1977,


Have you tried swapping the channels over .. by putting your router wifi on channel 11 and then trying SonosNet on channel 1, or even try SonosNet on channel 6... it must be worth a try, but give the settings 20 minutes, or so, just to settle, before you reach any conclusions about things.

Then the only thing I would then perhaps try myself, is to see how things run on your WiFi, rather than SonosNet... the method to switch things between Boost and Standard mode is described in this useful Sonos Support link:

Switching a Sonos Household between Standard & BOOST mode & vice versa

Hope that helps ?
Userlevel 2
Badge +4
Hi ken thanks for your advise. Sonos net running on channel 11. Router running on channel 1 on 2.4ghz wireless. Still same problem the system works fine it’s just when you skip forward or backwards a track it takes about 20 seconds for every speaker to start playing the song. Once playing it runs fine and all speakers run the song in sync it’s just that inital start
gazza1977,

It sounds like you changed your WiFi channel, whereas you have your lounge speaker wired... or so I thought... so that means you need to change your SonosNet channel in the Sonos App 'Advanced Settings' rather than your routers WiFi channel... there are only three channels to choose from 1, 6 or 11... just make sure whichever one you choose, that it’s at least 5 channels apart from your router channel, to prevent any overlap.

Don’t set your router WiFi to 'Auto' ... it may keep changing channels on reboot... best to keep the channel fixed.
Userlevel 2
Badge +4
Do I need to buy a Sonos boost???????????
Userlevel 2
Badge +4
As for interference I thought if I connect a speaker to the router direct via Ethernet then Sonos will develop its own WiFi that illuminates the interference as only the Sonos speakers run on Sonos net.

Please correct if I am wrong
Userlevel 2
Badge +4
Hi Jeff

Changed wireless channel. Nothing any different. Switched wireless channel to auto again nothing different. As for interference well there will probably be lots I have amazon Alexa in every room. Phillips hue lighting in every room. An I pad or I phone in every room and all TVs are connected wirelessly to router as is the iMac now of course all this is in between the Sonos speakers and the router so all the stuff can’t be moved to accom just the Sonos gear.

So how do I now overcome the lag please advise
Userlevel 7
Badge +20
Report submitted. 800548551. Lag is now 20 seconds between song starting to play in lounge and starting it bathroom

Hi there,

Thanks for sending in the report. Your Lounge unit is having a hard time keeping up with the streaming communication between your various components. As the wired unit, the Lounge is in charge of sending and receiving data from your Sonos units. Please try changing the wireless channel your Sonos system is using. This can reduce interference from nearby electronics and may help with the lag.

It may also help to check around and in between your Sonos units for any third party wireless electronics as they can sometimes cause interference as well.