Answered

iTunes songs not playing in imported playlist


Userlevel 1
Badge +3

Several songs in various imported playlist are not playing in the Sonos program.  The song can be found individually and plays just fine.  But not when in a playlist(s).  Thanks for any help.

icon

Best answer by Cambridgehank 26 March 2020, 16:42

Adam S and others.  I finally found a Sonos support person who figured out the issue with my playlist.  One of the artist is Chucho Valde´s.  Sonos was able to interpret his name in the song list, but not in  the playlist.  We changed the accented e´ to one with no accent and all is working.

View original

17 replies

Userlevel 1
Badge +3

Adam S and others.  I finally found a Sonos support person who figured out the issue with my playlist.  One of the artist is Chucho Valde´s.  Sonos was able to interpret his name in the song list, but not in  the playlist.  We changed the accented e´ to one with no accent and all is working.

Userlevel 1
Badge +3

Thanks and I appreciate your spending so much time with me.

I am on quarantine, so I am focused on solving this issue.

 

Userlevel 4
Badge +11

I would be happy to DM you the case number. 

I agree that due to the nature of this issue, calling in may be the best course of action moving forward. 

I appreciate you again for letting me know about this problem, I will also be investigating this issue further.

Userlevel 1
Badge +3

It did not change, so I will call.

Userlevel 1
Badge +3

If this does not work, I will call during your hours tomorrow.  Is there a case number I can give whom ever answers?

Userlevel 4
Badge +11

Removing your current path would be the action of navigating to the application and going into “Music Library Settings,” to remove the current path(s) that Sonos recognizes as the library. (step by step has been provided in the link I created)

The same step-by-step process would be used to re-add the Library pathway again.

 Please let me know if you are having difficulty opening the links.

Userlevel 1
Badge +3

Please tell me what you mean and how to remove and add the path?

Userlevel 4
Badge +11

Thanks for the update. 

I have taken a look at the diagnostic and it looks like the Sonos path that is programmed to your library is not holding a resource for the file(s)

If you have not removed and re-added the path, I would do that first.

If that does not change anything, I would recommend moving the XML file to a safe place (away from the current folder) and have iTunes generate a new one.

There may be organizational information that has moved from the XML file that Sonos is not recognizing.

Userlevel 1
Badge +3

My Mac Mini diagnostics is 1578167882

Userlevel 4
Badge +11

I’m in the same position with my computer at home. Totally understand. 

It may also be beneficial to give us a call during our operational hours, as the nature of this issue may require remote access or deeper troubleshooting moving forward.

You may continue to submit the confirmation number as a reply and I would be happy to make this determination.

Userlevel 1
Badge +3

I have avoided using Catalina on my mac mini for those reasons.

Userlevel 1
Badge +3

Yes, my laptop, sorry about that.

When I get home, I will send a diagnostic from the mini

Userlevel 4
Badge +11

Have you submitted the diagnostic from another computer? 

Upon looking into the diagnostic a bit further, I see the controller being on Mac OSX 10.15.3.

I specify this because with OS Catalina, playlist have been integrated with the Music App. The XML file have also been removed and this causes problems for users who operate playlists on third-party applications such as Sonos.

Userlevel 1
Badge +3

Mac OS Mojave 10.14.6

I can find the file and it plays in songs listing in Sonos.  That is what is strange.  The listing for the song in the playlist and in the message shows the track number in front of the title.  There are a few other songs in playlist(s) with a track number and they also do not play.  Same message.

Userlevel 4
Badge +11

Are you able to locate that file in the exact directory the message is referring to?

Additionally, what OS are you currently operating?

(Ex. Windows 10, MacOS Catalina etc.)

Userlevel 1
Badge +3

Thanks for your response and assistance.

Here is the message:

Unable to play ‘12 El manisero.m4a’ - the file cannot be found.

 

my confirmation number is: 1348950350.

Userlevel 4
Badge +11

Hi @Cambridgehank , thanks for the post.

Has there been any changes with the operating system or the XML file that the playlist is created under?

Do you receive an error when attempting to play music from the playlist? If so, what does the error state?

Finally, would you be able to provide me with a diagnostic of your Sonos system? After replying with the confirmation number, I would be happy to take a look.

Reply