Issues with playback on Sonos Connect

  • 10 March 2019
  • 2 replies

I've been having issues for a while with playback on my Sonos Connect. All my media is streamed from a NAS which is connected to my network using gigabit ethernet. When I start playing a song on the Connect it doesn't start playing straight away although I can see the progress bar moving along - normally playback starts 5-10 seconds into the song. If I then subsequently group the Connect with another one of my Sonos devices then playback stops altogether on the Connect (all my other devices are Play:1s). I have tried the Connect wired into my network, using a Bridge and also with the whole Sonos system in wireless mode and the issues don't ever get better (or worse). I have also tried the Connect playing back through a stereo amp and also through an AV receiver. The only thing I can think is that there are issues with the Connect itself - is there any way of diagnosing what?

Thanks in advance

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

2 replies


What type of wireless network are you using? Is is a central router or mesh based system? Do you have any WiFi extenders, repeaters or powerline adapters?

What WiFi channels are currently in use on the 2.4ghz band and what SonosNet channel were/are you using?

When running your Sonos devices on SonosNet, did you remove the stored WiFi credentials in the App to prevent the 'Connect’ from jumping between the SonosNet signal and your WiFi signal?
Userlevel 7
Badge +21
I'd put it in Boost mode and give it 10 minutes and submit a diagnostic to Sonos and then visit them on twitter (open 24x7) to have it looked at. Not necessary to go wired but it increases the chances your diagnostic will be sent un-corrupted.