Issues with Airplay on sonos devices

  • 30 November 2021
  • 7 replies
  • 149 views

Badge +2

This is becoming a huge deal and it is really annoying. Just about every time I am playing music through Airplay to a Sonos speakers the music just stops being heard. The music is still playing in the app, but no sound from the speaker. I open the Airplay button, switch back to play on iPhone then pick the speaker again. It first tells me the speaker is unavailable then I pick it again and it plays from the speaker again. It might work for two songs or stop again. Very random. Anyone else having these issues.

 

system is tens sonos speaker mix.   airplay played for IOS (Phone, Ipad).   I have disabled bluetooth.  Didn’t fix anything.   I followed apples recommendation to reboot (ha ha).  I use airplay other devices devices that are not sonos and have no problem, only occurs with sonos devices.


7 replies

It sounds like a wireless/WiFi stability matter between each/every device in the Airplay setup. I’ve not seen the issue here, either running on WiFi or in SonosNet mode n]but I tend to limit Airplay to no more than 6 devices only.  - What is the network setup you’re using? Perhaps describe your setup, starting with the modem/router make/model, WiFi channels and channel-width in use etc? 

If using SonosNet, include it’s channel aswell and state if your products have fixed IP addresses.

Any other wireless access points or switches (managed or unmanaged)?

More details are needed before attempting to suggest some things to perhaps try.

Badge +2

Hi Ken, thank you for responding.

I run netgear Orbi mesh RBR40.   It has two satellite device and one main router.  Modem is Arris SB8200.   I have tested it both with and without satellite devices.   The firmware is current.  My networks is a gigiblast network through our local COX business.   I have a solid 800 + Mbps download speed.   My network is fairly large for a home.   I am running both 2.4G (auto) and 5.0G (48) channels.  I have several devices connected as well as a couple other hubs.  I also have a Smarthing hub and a hub for my pool.   I have one switch to extend my wired network.  Everything runs well but sonos.  I was running all 11 speakers + 4 outside without a problem for about a year.  This problem started up about 8 months ago.

I have also tried changing channels on Boosts.   I am still a little stomped that all my speakers show wired but they are all wireless.  I thought the  boost may cause this but when I disconnect the boost nothing changes.   This doesn’t make sense unless once configured it will not change.

 

As far as the sonos system.   I am running 11 speakers. they are following

3 - Sonos One 1 1 

4 -  Sonos One SL 1 1

1 - Sonos AMP – for outdoor speaks (speakers BOSE)

1 - SYMFONISK Bookshelf

2 – Play 5

1 - Boost sonos network hub

Onkyo  - Sonos compatible 

hi @Sykes18 you may want to check this troubleshooting post - I had trouble with AirPlay but after some tweaks on my wifi network (e.g. allowing point to point connections) it stabilised  

 

@Sykes18,


With an Orbi mesh setup if you can fix its 2.4Ghz WiFi channel, then I would do that and set it to a non-overlapping channel, either 1, 6 or 11.

I would then cable the Sonos Boost to the Orbi primary router only. Do not wire any other Sonos products to your Orbi satellites. 

Keep the Orbi router at least one metre away from your wired Sonos Boost and keep both away from your Arris modem too.

Set the SonosNet channel in the Sonos App network settings so it is at least 5 channels away from your chosen Orbi 2.4Ghz WiFi channel - if you cannot set/fix the Orbi channel, then try different SonosNet channels giving each setup, at least an hour to see which channel works best.

What is also helpful (as you do not appear to have any portable Sonos products) is to also do these two things…

  1. Remove the WiFi SSID/Credentials from the Sonos App ‘Settings/System/Network/Manage Networks’ area. They are not required when running devices on SonosNet and it may prevent your devices hopping between a SonosNet signal and the Orbi WiFi signal.
  2. Reserve the Sonos product IP addresses in the Orbi Routers DHCP reservation table.

See if doing those few things improves the connection of your Sonos products and prevents all the audio dropouts.

Badge +2

Hi Ken

Thank for your response and sorry about my slow response. I had already tried most of these recommendations and I completed all that I have not tried above.   I am still having a problem.   I switch to using the sonos app and playing music from Sonos Radio and I still have the same problem.   If I keep my speakers down to maybe 3- 4  sets connected, it seems to work better, but if I connect to all my speakers, it starts to have problems again.   I am starting to feel Sonos has a limit on how many devices it can connect to.

I do have question from your recommendation.   The item you have selected as “1.”   I do not have this setting.  Should I be seeing it?

The other question is why do all my wireless speakers show wired on my network router when they are are wireless.

I am getting very frustrated with the sonos speakers I once loved. grrrrr!  It drives me crazy when them keep cutting in and out while listening to one of my favorite albums.

@Sykes18,

You will only see the network SSID mentioned in 1 in my post if you were previously running your devices on your WiFi signal. Note: leave the credentials in place if you have a Roam or Move speaker. I’ve attached a screenshot showing the area I was referring to. (I have a few networks in my case).

Because your wired device is the root-bridge, some routers see all the Sonos products as being wired as the connection is via that bridge. It’s perfectly fine to see this.

What you perhaps could try is a different SonosNet channel in the Sonos App “Settings/System/Network" area of the App and see if that improves things.🤞

May I ask what sources you are playing using Airplay? Airplay 2 is better than tbe original, but I would rather use almost any alternative, if one existed.

Reply