Question

Issues w UPNP and BrowseMetadata.

  • 21 September 2022
  • 4 replies
  • 39 views

Userlevel 2
Badge

Yesterday I noticed that I cannot retrieve the metadata of an item (a track/song) via the browse method in the UPNP interface. It doesn’t give and error, it just responds with default info. To make sure I wasn’t mistaking, I tried the same on an S1 (old SW!!) only capable player (with latest S1 SW) and there it still works. Anyone seen this? I suspect a bug on one of the latest S2 variants of SW or worse, I deliberate change, but that would make no sense,


4 replies

Userlevel 7
Badge +22

What args are you passing exactly? I don’t recall ever seeing anything like this, I recommend rebooting the target device.

Userlevel 2
Badge

Thanks @controlav. The problem is on all my S2 (SW) players and I don’t have it on my S1 (SW) players.

I would be the usual:

 

ObjectID this would be the object id of an ITEM not a CONTAINER

BrowseFlag = BrowseMetadata

Filter = *

StartIndex = 0

RequestCount = 0

SortCriteria = <blank>

 

 

Response:

<DIDL-Lite xmlns:dc="http://purl.org/dc/elements/1.1/" xmlns:upnp="urn:schemas-upnp-org:metadata-1-0/upnp/" xmlns:r="urn:schemas-rinconnetworks-com:metadata-1-0/" xmlns="urn:schemas-upnp-org:metadata-1-0/DIDL-Lite/"></DIDL-Lite>

with NumberReturned = 0

TotalMatches = 0

UpdateId = 0

 

Setting RequestCount to a non-zero value makes no difference

 

Userlevel 7
Badge +22

What is the actual ObjectID, and how did you get it? I am a few thousand miles way from either of my systems right now, but apart from the RequestCount being 0 (something I have never done) it doesn’t look dubious.

Oh and what is the UserAgent you are using?

Userlevel 2
Badge

The ObjectID depends on the content you have on your Sonos Player, so in my case I navigate either from A:TRACKS or A:ALBUMS into a song. With the ObjectId of that song item, I retrieve the meta data to get the author, art etc but more importantly the “res” so I can instruct the player to play this item.

 

I’ve been doing this for a decade now and support Sonos homeautomation for HomeSeer now for about 11 years. Over the years I wrote my own UPNP stack from scratch, which I have been using now for nearly 8 years. I also use Intel’s UPNP Device Spy and they all agree, it worked till very recently (and still works with S1 SW) and either Sonos broke it or deliberately removed it .. or it needs additional header information as part of some authentication scheme. 

 

Reply