Question

Issues maintaining a connection between Samsung TV and Sonos Beam


So I believe this may be more an issue on the Samsung side of things, but I thought I would also post something here in case anyone else has had the same issue and might know how to solve it. I have a Samsung KS8000 TV and I recently bought a Sonos Beam to use with it. Along with having the Sonos Beam plugged into the ARC HDMI port I have an Apple TV and PS4 that I also plug in to the one connect box. After two frustrating days of trying to figure out why the Beam wasn't working propertly I think I have located the source of the problem. If I plug either the Apple TV or PS4 in HDMI port 1, everything works properly. However, when I have something plugged into HDMI port 1 and then either HDMI port 2 or 3, the Beam will lose connection to the TV after an extended period of being turned off. For example, with only the Apple TV plugged into HDMI port 1, everything works properly and I can turn the tv off at the end of the night come back in the morning and it is still perfectly connected to both the Apple TV and Sonos Beam. But, if I were to have my Apple TV plugged into HDMI port 1 and my PS4 plugged into HDMI 2 and I turned the tv off at the end of the night and came back in the morning the audio will now be coming out the tv and it will have lost it's connection to the Sonos Beam. Any help solving this issue would be much appreciated.

10 replies

Ping this. Same issue I think. 

Only difference i have this setup with Sonos Beam

  • Samsung TV (different model)
  • Nintendo Switch
  • Chromecast
  • Google Assistant installed in Sonos Beam

This smacks of an issue with HDMI-CEC in my eyes. I’d be checking for an update for the the HDMI-CEC hub that controls everything, I.e the TV set, from Samsung. And I’d also contact Samsung with your findings. If you want to remove Sonos from this equation, connecting it via optical would give you the same audio, and you’d lose just the ability for voice command via the Beam. 
 

All of the devices you’ve mentioned are clients of the HDMI-CEC hub, and have very little control, other than reporting themselves to the hub device. It’s that hub that does the processing of each available device’s data, and it sounds like there’s a failure there. 

I solved by unplugging everything out and plugged Chromecast in HDMI 1 then Beam in the correct one HDMI. 

@Airgetlam  So yeah, probably HDMI-CEC that I never heard of before, you learn something new every day! 

So no playing on console :grin:

I’d just add an HDMI blocker to the cable for your console, which should make it all work for you, and keep the console from “breaking” the HDMI-CEC stuff on your TV. Found one on Amazon for about $20, I think, but that’s the adapter. You could also get full cables, but I didn’t process the cost on those, sorry. 

Update: 

I solved by unplugging everything out and plugged Chromecast in HDMI 1 then Beam in the correct one HDMI. 

@Airgetlam  So yeah, probably HDMI-CEC that I never heard of before, you learn something new every day! 

So no playing on console :grin:

It did not work in the long run, looks like I have try the adapter and see if it makes any difference. 

I’d just add an HDMI blocker to the cable for your console, which should make it all work for you, and keep the console from “breaking” the HDMI-CEC stuff on your TV. Found one on Amazon for about $20, I think, but that’s the adapter. You could also get full cables, but I didn’t process the cost on those, sorry. 

What do you mean with “full cables”. I am kinda new to these terms.

That was a reading error on my part, when I looked at Amazon. They showed me the adapters, and then a set of cables that I thought would block HDMI-CEC, but they turned out not to be true HDMI-CEC blocking cables, they just matched the search words I put into Amazon. Stick with the adapters. There may be cables that do the job out there, but I didn’t find them easily on Amazon, but I didn’t really search that much, either, once I saw the adapters. 

I should’ve updated this earlier but yes, a HDMI-CEC blocking adapter did the trick for me.  Now, over time it has taken a little longer for the blocker to kick in when I turn on the tv.  Sometimes I may have to watch my tv for 5 to 10 minutes using the tv speakers, but eventually the blocker will do its job and then the sonos speakers kick on.  This is the blocker I used https://www.amazon.com/Lindy-HDMI-Adapter-Female-41232/dp/B00DL48KVI/ref=sr_1_2?keywords=hdmi+cec+blocker&qid=1575991477&sr=8-2

I’m having the same issues with my new Samsung TV and Sonos Beam.  My set up is:

  • Samsung TV 
  • Apple TV in HDMI1
  • DVD Player in HDMI2
  • Beam HDMI4

The handshake between the beam and the TV kept breaking until I read these posts - I disconnected the DVD player and then reintroduced the Beam to the TV and voila - the TV auto-recognized the Beam and the problem was solved.  I’ll have to buy a CEC blocker for my DVD player.

There’s often, albeit not always, a setting in the device somewhere to turn off HDMI-CEC. Your DVD player may have such a setting.

Reply