Issue with google music service on SONOS

  • 6 November 2016
  • 7 replies

Hi everyone,

I have a bar and play:3 system installed in my house which had been working perfectly fine until recently. I have under my google account a subscription to google music which is added on sonos. From my phone, I can access the google music service via the sonos app, search the libraries, everything works fine. My wife however cannot access the service via the sonos app. It says "unable to browse music - there was a problem connecting to Google Play Music." She used to be able to browse for music but it recently stopped working - perhaps an app update? She has an iphone. She does have another google account on her phone. Is this what is causing this and how may I work around it? She has the google play app on her phone logged in with my details and that is working fine.

Thanks for the help!

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

7 replies

Userlevel 7
Badge +22
Iphones can have some networking issues especially after ios updates.

What I would do is

1. go into regular settings on iPhone ...wifi ... tell the iPhone to forget your home wifi network.

2. reboot your router

3. reboot the iPhone

4. go back into settings and add your home wifi to the iPhone.

See if that clears up iPhone issues (not a sonos issue but sonos problems is a symptom)
Hi Chris,

Thanks for your reply. I tried what you suggested but unfortunately it didn't fix it. Is there something else I might try?

Userlevel 7
Badge +22
I would submit diagnostic via settings... advanced. Post diagnostic number given here for Sonos rep to review.
Thanks Chris. The diagnostic number is 6726696
Userlevel 7
Badge +20
Hi, Neauneau. Thanks for the information provided. Can you please go into your WiFi settings on the phone, and change DNS to, . Then reboot the phone. Has that helped? Please let us know.
Hi Edward,

Thanks, just tried that works better now. I tried on another iphone as well and it was having similar issues, it' seems it's definitively linked to some recent iphone update. These are the google public dns arent they? Is there any drawback to using them instead of your regular isp dns?

Badge +1
Hello neauneau. These are Google DNS servers however you can try using any DNS server other than the ones that were automatically being used and it should work. Let us know if you have any other questions.