Answered

Is it possible to control Sonos One SL using WIFI and wired connection on my MBP ?

  • 26 October 2021
  • 9 replies
  • 70 views

I've had a lot of problems making Sonos One SL devices work with my network setup and my MBP.

After some debugging it hit me that the problem is that if my MBP is connected to my Thunderbolt hub (with a wired UTP connection) that I cannot control the Sonos device, nor use AirPlay 2.

I see the speakers in the AirPlay speakers menu, but when I try to stream anything (or use the Sonos Controller software) I get a generic connection error after 20-30 seconds.

When I unplug the wired connection I can use AirPlay2 or the Controller without a problem.

This is really annoying because now I need to disconnect my MBP from the wired connection if I want to AirPlay something to my Sonos. If I only have the wired connection then it does not work neither since I guess the IP address of my MBP is different.

Is there a way to have the configuration work with both the wired and wireless connection (at the same time) ?

icon

Best answer by Corry P 1 November 2021, 11:27

View original

9 replies

when you deactivate your wifi on your wired MacBook Pro you should still find the AirPlay speakers - check in the System Preferences under the Sound icon if the AirPlay speakers are shown

 

No, I don’t see the Airplay speaker in the list when I use the wired connection only

Userlevel 6
Badge +15

Is it possible your Wifi and physical connections are on two separate networks/VLANs?  Is this at work or at home?

 

Second possibility is a routing issue - I see this from time to time with my Mac when it’s been connected via one, and I disconnect it, I lose connectivity until I restart networking entirely, or reboot.  If you disable wifi, then reboot it, bringing it up with only wired, do you have the same problem?

I don't think it is a routing issue related to my Mac itself. I have lots of devices attached to wifi and I can connect to all of them on both networks without issues. The only devices that exhibit this problem are my 2 Sonos One SL speakers.

When I disable the wired connection and enable the wifi I can ping them without error.

When I disable wifi and enable wired connection ping is timing out or giving routing errors (and sometimes it actually works).

I can ping other devices on the same router or wifi access point without problems. I tried switching to another wifi access point that is connected to another router (using ubiquiti mesh network) and it does not make a difference. WIFI works, wired does not.

I digged some further:

It is only one of the 2 One SL's that is exhibiting a connectivity problem.

I decoupled the stereo pair and now I can play music on one of them without a problem.

I rebooted the other one and then suddenly I could play music on it… but after some time the connection was dropping again.

They are both connected using WIFI to the same router… so I can only assume that there is something wrong with that second speaker.

hi @dnouls (temporarily) wiring the second speaker is not an option? 

 
Userlevel 7
Badge +17

Hi @dnouls 

Welcome to the Sonos Community!

You mentioned UniFi - please try the following:

  • Log into the UniFi controller.
  • In the Settings tab, click Wireless Networks.
  • Click Edit next to the network SSID.
  • Expand Advanced Options.
  • Uncheck Block LAN to WLAN Multicast and Broadcast Data.
  • In the Settings tab, click Sites.
  • Disable Auto-Optimize Network.

I hope this helps.

@Corry P Thanks a lot, this fixes the problem I was facing! All these unifi parameters are really badly named/described. I did not have this option disabled because it was referring to WLAN, I did not want broadcasts to be submitted to the internet. But now I realise that the WIFI is not directly connected to the internet.

Userlevel 7
Badge +17

Hi @dnouls 

I’m glad to hear that fixed it - thanks for marking the Best Answer.

You were probably thinking of WAN (Wide Area Network - includes the Internet) rather than WLAN (Wireless Local Area Network - also known as WiFi) - I’ve made the same mistake myself.

 

Reply