Answered

iPhone but not Android or iPad connecting to Beam

  • 5 April 2021
  • 2 replies
  • 64 views

I updated my wireless AP to UniFi 6 Lite. I connected my Sonos Beam to wifi and to iPhone, and can normally stream music and use AirPlay. However, an Android phone or an iPad won’t anymore connect to or even recognize the existing Sonos system in the Sonos app. I have tried with separate and combined 5 GHz and 2.4 GHz SSIDs with no luck. Other UniFi controller settings are pretty much in their defaults. I would appreciate any ideas on how make the Beam accessible by other mobile devices as well.

icon

Best answer by Xander P 6 April 2021, 10:01

Hi @jaakkonen, welcome to the Sonos Community!

Just to confirm, were all of these devices able to connect on the old WiFi? Are any of the Sonos devices connected to the network via Ethernet cable, or is the system fully wireless?

I’d recommend starting by making sure that the Sonos app permissions are still set correctly, and it may also help to turn of Private Addresses in the iOS settings - let us know if this helps :)

View original

2 replies

Userlevel 5
Badge +13

Hi @jaakkonen, welcome to the Sonos Community!

Just to confirm, were all of these devices able to connect on the old WiFi? Are any of the Sonos devices connected to the network via Ethernet cable, or is the system fully wireless?

I’d recommend starting by making sure that the Sonos app permissions are still set correctly, and it may also help to turn of Private Addresses in the iOS settings - let us know if this helps :)

Hi @Xander P, disabling the private ip address did the trick for the iPad, thanks! However, the Android phone still won’t connect, I couldn’t find a corresponding ip setting to that of iOS.

In the old wifi, both iOS and Android devices connected without any problems. My current and the previous Sonos systems are fully wireless (there is no ethernet jack near the Beam)

Reply