iPhone app won't connect

  • 20 May 2017
  • 4 replies
  • 5033 views

My iPhone app won't connect and just freezes after a period of time. My wife's app works on the same network. I've tried rebooting my wifi and have re-registered my wifi network on my phone but nothing is working. I can't run diagnostics because it won't let me into the app without freezing. Any help appreciated.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

4 replies

OK, a few trouble shooting suggestions.

1) Turn off wifi assist on your phone. Go to Settings, then Cellular, and scroll to the bottom of the page. The third item from the bottom will be Wi-Fi Assist. Make sure it's turned off (not green)
2) Delete the app from your phone
3) Do a hard reset of the phone (hold down the right side button until you get a slide bar that says "Slide to power off", slide it to off, and wait 3 minutes. It takes a bit for the phone to actually shut down.
4) Power the phone back on by clicking on the thumb button at the bottom. Once it's fully booted back up, and connected to your wifi:
5) re download the Sonos app, and connect it to your system
6) Test the heck out of it, come back here and yell at me if it isn't fixed. Or post calmly, it's up to you :)

Random extra thoughts. What iPhone is it? Which version of iOS is it running? Which version of the Sonos app is it? Have you checked to make sure (on whichever controller is working) that there aren't any updates waiting for the speakers?
Thanks Airgetlam - that worked! Appreciate the help
Badge
It crashes each time the app needs an update. So take your pick. Mine has the same issue.
Still crashes. thanks