Answered

IP address change on router, now Sonos offline

  • 15 January 2019
  • 7 replies
  • 567 views

Hi there
We had an IT contractor into my house to sort an issue with our wifi. The wifi network is still named exactly the same, with the same password, they merely changed the IP address range. All other laptops and ipads etc all still ok.... No sonos though.

I have:
• Playbar in lounge, plus a sub plus a bridge
• 2 x play ones in kitchen plus a bridge
* A play 5 in dining room
• A play 3 on upstairs landing
• A beam in the bedroom

All on wifi, none ethernet.

How should I get it all up and running please. Does each device need to be plugged into ethernet to get it back on? Sorry I have looked at various instructions but it only refers to one device, not several.

Thanks
icon

Best answer by Bigg1970 16 January 2019, 10:26

Hi there

We had to change te IP range as it conflicted with my IP range at my business that we need to VPN to. So we changed the IP range and everything was ok..... except SONOS!

Thanks
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

7 replies

Hi. If the issue really is IP addresses then wiring won't make any difference.

The first thing I would do would be to power off your router and all your Sonos. Connect one device by Ethernet. Power back on one device at a time, starting with router, then the wired Sonos, then each other Sonos, letting each come up fully bedore doing the next.

Then please post back, whether or not this has helped.
Hi John B,

Thanks so much for this. I did as you said and turned everything off. I turned on bridges first and saw them in my system, then turned on each speaker and waited for it to show up in sonos app.

Brilliant thank you very much!!

One issue though is when I try and go into room settings, in more, it says "Network Problem! Check your internet connectiion and make sure all of your speakers are plugged in. If you are still getting problems check date and time are correct in setting etc". I tried going into date and time. Set time from internet was OFF, so I turned it on, but still the same issue, so I turned it off again.

Does anyine know what this means? Ipad is on same network as speakers and I can see them in the app!

Giles
I have to admit I have never come across that. It may require a call to Sonos, as they can look remotely at your set up. What problem was your IT contractor trying to solve? Do you have any switches, extenders, access points etc in your network?
Hi there

We had to change te IP range as it conflicted with my IP range at my business that we need to VPN to. So we changed the IP range and everything was ok..... except SONOS!

Thanks
It may be the VPN that Sonos is objecting to. If yo can briefly turn off the VPN, you can see if the message disappears.
Thanks for this. The vpn is only on occasionally so it’s not connected. Maybe I contact Sonos.

Thank you very much for your help and comments.
Thanks for this. The vpn is only on occasionally so it’s not connected. Maybe I contact Sonos.

Thank you very much for your help and comments.
I think that is probably now the most efficient thing to do. We made some progress, but don't have a complete resolution.